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1. Introduction 
 

1.1 New in SHAPE 7 
SHAPE-THIN is a professional, user-friendly program for the analysis and design of thin-
walled cross-sections. The stand-alone module is based on the effective program concept of 
the RSTAB and RFEM software family. For example, the user is able to exchange different 
sectional elements between individual SHAPE files with drag & drop. At the same time, the 
internal forces and moments of member elements can be taken from any RSTAB or RFEM 
structure. It is also possible to directly export the section properties to MS Excel for addi-
tional editing. 

SHAPE-THIN characteristics include: 

• Interactive input in graphics and tables 

• Access to cross-sections of the extensive DLUBAL sections’ library 

• CAD-like modeling due to comfortable construction tools 

• Editing tools: Smoothen or round out corners, connect elements, insert openings etc. 

• Generation of circular or rectangular hollow sections 

• Determination of section properties for general open and closed cross-sections 

• Plastic section characteristics due to non-combined loading 

• Design of normal, shear and equivalent stresses and comparison with limit stresses 

• Import of load cases and internal forces of members from RSTAB and RFEM 

• Export of the section properties to RSTAB/RFEM and design modules 

• Consideration of different materials in the cross-section 

• Section characteristics of reinforced skyscraper cores and forces in the individual walls 

• Project Manager for overall data management of SHAPE-THIN sections 

• Printout report with individual contents and layout 

Essential innovations in SHAPE 7 are: 

• Precise modeling of section geometry via arcs and point elements 

• DXF import of contours or center lines to facilitate the modeling 

• Dummy elements with user-definable effective thickness for shear 

• Plastic load capacity based on Simplex algorithm for general line-up of internal forces  

• User-definable c/t zones and check of maximum c/t ratios according to DIN 18 800 

• Colored results distribution on cross-section with adaptable color spectrum 

• Display of section contour and inertia ellipse 

• User-definable icons and selection in the results tables 

• Option to display distribution of results in sheet plane 

• Filtering of stresses for extreme results of all x-locations 

• Determination of J according to St. Venant or FEA 

• Analysis of the effective cross-sections according to DIN 18 800, EN 1993-1-1 and  
EN 1993-1-5 or EN 1999-1-1 

• Extended material and cross-section libraries 

• Integral of shear forces due to shear stresses for each element 

• User-definable factor for v in order to determine equivalent stresses 

We wish you much success using SHAPE-THIN. Your comments resulting from the everyday 
use of DLUBAL applications are welcome for the ongoing development of the program. 

DLUBAL ENGINEERING SOFTWARE 
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1.2 Company Profile 
Since its beginnings in 1987, ING. SOFTWARE DLUBAL has been involved in the development of 
user-friendly and powerful programs for structural analyses. In 1990, ING. SOFTWARE DLUBAL 
moved into its current location to Tiefenbach in Eastern Bavaria. 

Looking at our programs, you can feel the enthusiasm of everybody involved in the devel-
opment and you will notice the underlying philosophy of all our applications, which can be 
subsumed in the word ‘user-friendliness’. These two points combined with the professional 
competence build the base for the ever-growing success of our products. 

The software is designed to allow even users with basic computer skills to handle the soft-
ware successfully after a short while. With considerable pride, we now count more than 
7,000 engineering offices, construction companies from a variety of fields and places of 
higher education to our list of satisfied customers around the world. To remain true to our 
objectives, there are more than 100 internal and external employees working continuously 
to improve and develop the DLUBAL applications. For general questions and problems, you 
can always rely on our qualified and free hotline. 

The perfect balance between price and performance combined with the excellent customer 
service make DLUBAL programs an essential tool for anyone involved in the areas of statics, 
dynamics and design. 

1.3 The SHAPE Team 
The following people were involved in the development of SHAPE 7: 

Program Coordination: 
Dipl.-Ing. Georg Dlubal 
Ing. Jan Rybín, Ph.D. 

Dipl.-Ing. (FH) Robert Vogl 

Programming: 
RNDr. Vladimír Ulrich 
Dipl.-Ing. Georg Dlubal 

Mgr. Petr Oulehle 

Program Design, Dialog Boxes and Icons 
Dipl.-Ing. Georg Dlubal 
MgA. Robert Kolouch 

Zdeněk Ballák 
Ing. Jan Miléř 

Program Supervision: 
Ing. Jan Rybín, Ph.D. 
Ing. Martin Hlavačka 

Ing. František Knobloch 

Manual, Help System and Translations 
Dipl.-Ing. (FH) Robert Vogl 
Ing. Jan Rybín, Ph.D. 

Mgr. Petra Pokorná 
Jan Jeřábek 

Technical Support and Program Testing 
Dipl.-Ing. (FH) Matthias Entenmann  
Dipl.-Ing. Frank Faulstich 
Dipl.-Ing. (FH) René Flori 
Dipl.-Ing. (FH) Bastian Kuhn 
M. Sc. Dipl.-Ing. Frank Lobisch 

Dipl.-Ing. (BA) Andreas Niemeier 
Dipl.-Ing. (FH) Walter Rustler 
M. Sc. Dipl.-Ing. (FH) Frank Sonntag 
Dipl.-Ing. (FH) Christian Stautner 
Dipl.-Ing. (FH) Robert Vogl 
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1.4 Using the Manual 
To facilitate the reading of this manual, the term “SHAPE” will be used instead of the full 
name of the “SHAPE-THIN” program. 

Many ways lead to Rome – this also applies to working with SHAPE: Graphics, tables and 
the data navigator are on an equal footing here. To maintain the character of a reference 
book, the manual follows the order and the structure of the tables for the input and results 
data. The individual tables are described in detail column by column. Instead of presenting 
general Windows features, the manual rather gives practical hints and notes. 

If you are new to the SHAPE cross-section software, you should work through the introduc-
tory example in chapter 3. Thereby, you will get familiar with the most important features 
of the program. 

The text of the manual shows the described buttons in square brackets, e.g. [OK]. Addition-
ally, the expressions of the dialog boxes, tables and menus are set in italics to clarify the ex-
planations. 

Another feature of this manual is its index which is very useful if you are looking for partic-
ular expressions. You can also check our website at www.dlubal.com where you can go 
through our FAQ pages. 

 

http://www.dlubal.com/
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2. Install SHAPE 
 

2.1 System Requirements 
To use SHAPE 7 comfortably, we recommend the following minimum system requirements: 

• Operating system Windows XP/Vista/7 

• X86-CPU with 1 GHz 

• 512 MB RAM 

• DVD-ROM drive for installation, alternatively installation via network 

• 10 GB hard disk capacity, around 80 MB for installation 

• Graphics card with a resolution of 1024 x 768 pixels 

SHAPE 7 does not run under Windows 95/98/Me/NT. 

With the exception of the operating system, no product recommendations are made, as 
SHAPE basically runs on all systems that fulfill the system requirements. 

SHAPE benefits only very little from SMT systems. Because SHAPE is a 32 bit program, it 
does not use 64 bit extensions like EM64T or AMD64 or the features of Windows 7 64 bit. 

2.2 Installation 
SHAPE is delivered on the Dlubal Applications DVD. This DVD contains the main programs 
RFEM and RSTAB with all add-on modules and also the stand-alone module SHAPE 7. 

To run the program as a full version, you need the corresponding hardlock and an authori-
zation file. Your authorization file contains coded data for your authorization. Attach the 
hardlock to your printer port or USB connector. The printer cable can then be connected to 
the hardlock. The performance of the printer will not be influenced by the hardlock. 

You need the authorization file for each work station. The authorization file can be copied 
as many times as required. However, if the content is changed in any way, it cannot be used 
for authorization any longer. In case you later receive a new DVD as an update, you normal-
ly can use again the existing authorization file. However, when you have purchased an addi-
tional program module, you will receive a new authorization file. Then the old one must not 
be used. 

Before you install SHAPE, close all other programs and install the hardlock on a printer port, 
resp. the USB hardlock to a USB port of your computer. 

For the installation, you have to be registered as administrator resp. have administrator 
rights. When working with SHAPE, user rights will be sufficient. 

2.2.1 Installation from DVD 
First, read the instruction guide on the back of the DVD cover. There you will find infor-
mation on how to install the software. 

• Insert the DVD into your DVD-ROM drive. 

• The installation process will start automatically. 

• Select the language in the opening screen. 

• Click [Install RSTAB]. 

• Follow the instructions of the setup wizard. 
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If the installation does not start automatically, autoplay is disabled on your DVD-ROM drive. 
In this case, click the icon [My computer] with the left mouse button, then the symbol of 
your DVD-ROM drive with the DLUBAL logo. In this folder of the DVD-ROM, you have to dou-
ble-click the file setup.exe. 

The DVD also contains the manual as PDF document. For this, you need the Acrobat Reader 
that can be installed from the installation menu with [Install Acrobat Reader]. By clicking 
[SHAPE Manual], the Acrobat Reader will open the manual. Afterwards you can view and 
print the document. 

There are also several video clips on the DVD to make the first steps easier. To play these, 
you will need the Windows Media Player or the Real Player. 

The button [Software Information] opens a PDF document with information on the current-
ly available programs of DLUBAL ENGINEERING SOFTWARE. 

2.2.2 Network Installation 
The installation can be started from any drive of the computer or of a server. Copy the con-
tents of the DVD and - if needed - the authorization file simply to a specific folder. Then 
start the file setup.exe from a client. The following steps are no different than the installa-
tion directly from the DVD. 

2.2.3 Updates 
As mentioned before, the DVD contains the complete program package. When as part of a 
service delivery you need to install a new RSTAB or RFEM DVD, make sure that you always 
use the up-to-date authorization file. 

In case you work with user-defined printout report headers, you better save these before in-
stalling an update. These headers are stored in the file DlubalProtocolConfig.cfg in the 
master data folder (by default C:\Program Files\Dlubal\Stammdat). This folder is write-
protected, even though a backup copy is advisable here. 

If you use the sample print reports, you should save the file DuenqProtocolConfig.cfg be-
fore installing an update. This file is located in the Dlubal master data folder, too. 

The projects in the project manager are managed in the ASCII-type DU_PRO.DLP file that is 
located in the Dlubal master data folder (..\Dlubal\Stammdat), too. If you want to uninstall 
SHAPE 7 completely before a reinstallation, you should save also this file. 

2.2.4 Installation of SHAPE 5/6 and SHAPE 7 
All Dlubal applications SHAPE 5, SHAPE 6 and SHAPE 7 can be run parallel on one comput-
er, as the program files are contained in different folders. The default folders are 

• SHAPE 5: C:\Program Files\Dlubal\DUENQ, 

• SHAPE 6: C:\Program Files\Dlubal\DUENQ6, 

• SHAPE 7: C:\Program Files\Dlubal\DUENQ7. 

All cross-sections created with the previous versions of SHAPE can be opened and edited in 
SHAPE 7. The files are upwards compatible without any problem. Sections created with 
SHAPE 7 can e.g. also be opened in SHAPE 6 but specific features of the newer version will 
not be available there, such as arcs or effective cross-section data. Make sure not to over-
write sections by accident when opening them in previous versions as the data format is 
identical. 

When installing SHAPE 7, the Project Manager is updated automatically so that your exist-
ing cross-sections will be available without further settings. 
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3. Introductory Example 
This chapter helps you to become familiar with the most important functions of SHAPE us-
ing a simple example. Because there are many ways how to do things according to the situ-
ation and preferences of the user, it might make sense to use one or the other way. This ex-
ample wants you to discover the possibilities and options of SHAPE on your own. 

3.1 Cross-Section and Internal Forces 
In our example SHAPE, a welded steel angle is connected to an unequal rolled angle section 
L 200x100x14. Additionally, a bolt hole is punched in the top flange. 

The section properties and stresses are to be determined for the following cross-section. 

Cross-Section 

t = 10 mm

t = 14 mm

40
7

200200

400

L 200x100x14

Weld 6 mm

50 20

 
Figure 3.1: Sketch of the SHAPE cross-section 

Material 
Steel Grade S 235 JR 

Internal Forces 
The internal forces of two different load cases are to be analyzed. The shear forces and 
bending moments are related to the principal axes u and v of the cross-section. 

Internal Force LC 1 LC 2 

  N  [kN] 80.0 -30.0 

  Vu  [kN] 25.0 -25.0 

  Vv  [kN] 95.0 95.0 

  Mu  [kNm] 50.0 50.0 

  Mv  [kNm] 10.0 -10.0 

Table 3.1: Internal forces 
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3.2 Start SHAPE and Create Section 
You can start SHAPE via 

Start → Programs → Dlubal → Dlubal SHAPE-THIN 7.xx 

or the icon Dlubal SHAPE-THIN 7.xx on your desktop. 

When SHAPE is started, a dialog box in the main window appears and asks you to enter the 
general data for the new section. If a section has already been entered, close this opened 
file by clicking on the [X] in the toolbar or via menu File → Close. Then select File → New 
so that the following dialog box is shown. 

 
Figure 3.2: Dialog box New Cross-Section - General Data 

Type Shape in the input field Section and Manual example in the Description field as 
shown above. The Section must always be filled in because this entry will be used as file 
name. The Description does not necessarily need to be filled in. 

In the input box Project, select the project Demo from the list, if not already set by default. 
The Description of the project and the specific File Location will be displayed automatically. 

Adopt the remaining settings of this dialog box without changes. You can enter some addi-
tional explanation in the Comments field. 

When you close this dialog box with [OK], an empty work area will be displayed. 

3.3 Section Data 
3.3.1 Work Window and Grid 
First, maximize the work window with the button in the title bar. The directions of the axes 
y0 and z0 are visible on the screen. 

The position of the axis system can be adjusted on the screen. For this, select [Move] from 
the toolbar. The mouse pointer changes into a hand. You can now position the work area 
according to your wishes with the pressed left mouse button. 
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In the same way you can also zoom in a section by pulling with the pressed [Ctrl] or [Shift] 
key. Alternatively, you can use the mouse wheel. 

The work area has a grid as background. You can set the spacing of the gird points in the 
dialog box Grid settings. 

 
Figure 3.3: Dialog box Grid settings 

You can access this dialog box with the button [Set grid] in the toolbar. 

The default settings are suitable for our example so that we can close this dialog box with 
[OK] to start the input of the section. 

3.3.2 Set Elements 
It would be possible to individually define the corner nodes either in the graphics or in the 
table first and to connect them by elements later. It is faster, however, to enter the ele-
ments directly in the graphics. The corresponding nodes will be created automatically. 

Call up menu Insert → Elements → Graphics → Polygonwise or the corresponding button 
in the toolbar. The dialog box New Element appears. 

 
Figure 3.4: Dialog box New element 

The Element and Node are already set at 1. As the node coordinates are be applied on the 
Absolute Zero of the coordinate system, accept this default setting as well as the element 
Thickness of 10.0 mm which we will modify later. Steel S 235 has been preset as Material. 
We accept also this default setting as the steel grade is to be changed subsequently, too. 

If you move the mouse over the graphical work area now, you will see the coordinates of 
the pointer position change in the defined grid spacing of 50 mm. 
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Node number 1 is set as Start Node by clicking with the left mouse button exactly on the 
origin. The End Node 2 of the element is set on the y’ = 200.0 mm, z’ = 0.0 mm location. 

Because we selected the Polygonwise option, node 2 now represents the start node of the 
next element number 2. So, we can now set node 3 on the y’ = 200.0 mm, z’ = 400.0 mm 
location. 

The command is ended by clicking with the right mouse button or pressing [Esc]. The dialog 
box closed in the same manner. Fill the main window with the two elements using the 
View → Show All menu or pressing the [F8] key or the corresponding button seen to the 
left. 

For the further input, we recommend you to show the numbering of nodes and elements. 
Do this through the context menu, reached by right-mouse clicking on an empty area of the 
graphics. In the context menu, click the Numbering option with the left mouse button. 

 
Figure 3.5: Context menu: Numbering 

3.3.3 Edit Elements 
If you move the mouse pointer over element 1 and hold it there, SHAPE shows further in-
formation on the element, including its thickness t of 10.0 mm. 

 
Figure 3.6: Element info 

Because the element is 14.0 mm thick in reality, a correction is necessary. Double-click the 
element 1 to open the Edit Element dialog box. There, click in the Thickness t input field. 
Type in 14.0 for the correct thickness and confirm it by clicking on the [OK] button. 
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Figure 3.7: Dialog box Edit element 

The section will be updated in the graphics and also in table 1.4 Elements. 

3.3.4 Set Section 
The next step is to add the unequal angle cross-section 200 x 100 x 14 from the sections’ 
library to element 1. Choose the Insert → Sections → Graphics → Section library menu or 
click the corresponding button in the toolbar as seen on the left to call up the library. 

 
Figure 3.8: Cross-section library 

Click the L-shape button (Rolled Cross-Sections, 2nd row, left) to open the entire table of 
L-shaped rolled sections. In the Table list, select L Unequal Legs, Preferred and then scroll 
down the Cross-Section list to the end to select L 200x100x14. Finally, confirm with [OK]. 
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Figure 3.9: Rolled angle sections L 

The dialog box Set Section opens. The dotted L section can be moved over the work area 
with the mouse. Enter the Section Rotation β = –90° using the small spin button next to the 
input field or typing in the value. 

 
Figure 3.10: Dialog box Set section: Rotation and offset point 

The current Offset Point to set the section lies in the center of gravity. It is marked with a 
slightly larger red circle in the image of this dialog box. Because we want to connect the 
section with its longer leg, we select a new, more favorable offset point by picking it in the 
image. Move the pointer (now a square) on the small red square at the left end of the long-
er leg until the pointer changes to a crosshair. Then press the left mouse button. This point 
should now be marked by a larger red circle as shown in the figure above. 

In this dialog box, the option Reduce section into individual elements is to be activated as 
well by ticking the respective check box. 

To set the section, steer the crosshair-shaped pointer on node 2 in the graphics. The angle 
section can be seen as a dotted line attached to the defined offset point. As soon as node 2 
with its coordinates appears in the status bar, press the left mouse button. 
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Figure 3.11: Setting the angle section on node 2 

3.3.5 Mirror Elements 
As both of the newly set elements are still selected (i.e. colored in the graphics and tables), 
we can mirror the angle right away. If the elements are not marked, either hold down the 
[Shift] key while clicking on both elements or simply pull up a window over them. 

To mirror the two elements, call up menu Edit → Mirror/Copy or press the corresponding 
button in the toolbar. The Mirror dialog box appears. 

 
Figure 3.12: Dialog box Mirror 

Make sure that Create Copy is not checked in this dialog box. The Mirroring Axis can be de-
fined via Point and Parallel Axis y so that the default setting is applicable. Now move the 
mouse pointer to node 1, 4 or 5. As soon as the box shows the 1st Point with its correct co-
ordinate z = 0.0 mm, you can mirror the angle by clicking with the left mouse button. 
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3.3.6 Set and Delete Point Elements 
The splice still has to be reworked a bit. Zoom in on the area around node 2 by activating 
the View → Zoom menu or the corresponding button in the toolbar. 

 
Figure 3.13: Menu View → Zoom 

The 6 mm weld with concave shape is modeled as so-called Point Element with 15 mm 
seam length. Via menu Insert → Point Elements → Graphics or the related button, you 
can call up the dialog box Set Point Element. 

 
Figure 3.14: Dialog box Set point element 
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The default settings of this dialog box are suited for the weld, apart from the Radius r that 
you can change to 15 mm in the input field. Now move the crosshair-shaped pointer pre-
cisely on the contours intersection of elements 2 and 3. As soon as the dotted shape of the 
point element has reached the Position y = 205.0 mm, z = 7.0 mm as seen in the above 
figure, press the left mouse button. Then cancel the command by a right-mouse click or via 
[Esc]. 

The point element 4 represents an unwanted opening that results from mirroring the rolled 
angle. The fastest way to remove this point element is to right-mouse click it and then to 
choose Delete Point Elements in the context menu. 

 
Figure 3.15: Deleting point element 4 via context menu 

The button [Show All] or the [F8] key fills the work area with the updated input of our 
section. 

 
Figure 3.16: Result of the graphical input 



3  Introductory Example 

 

 

20 Program SHAPE-THIN © 2012 by Ing. Software Dlubal 

 
 

Demo Version 
 

 
 

3.3.7 Insert Opening 
The bolt hole in the top flange can be modeled via the Edit → Insert Opening in Element 
menu which calls up the following dialog box. 

 
Figure 3.17: Dialog box Insert opening in an element 

Click the [Pick] button and then select element 1 in the graphics by a mouse click. Right-
mouse clicking in the work area takes you back to the initial dialog box. Now enter the 
Opening Length of 20 mm at a Distance of 50 mm from the Element Start. The zoomed 
image in this dialog box is dynamical with the input, and it also gives information on the el-
ement direction. 

[OK] then inserts the opening. Element 1 is divided by two nodes. A Null element is created 
with the thickness t = 0.00 mm to model the hole as a shear-stiff connection. 

If you try this example in the demo version, there will be a problem when this section is to 
be calculated later because the demo restriction confines the analysis to only four elements. 
For the demo version, it is therefore recommended to proceed without this opening: Click 
the [Undo] button to restore the original state of element 1. 

3.3.8 Plausibility Check and Save 
The input is checked with the Extras → Plausibility Check menu. 

 
Figure 3.18: Plausibility check 

Save the data with the File → Save menu or the corresponding button as seen to the left. 
(In the demo version, saving the file will not be possible if the opening is included.) 
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3.3.9 Check Input Tables 
SHAPE offers several possibilities to define the data. All graphical input is automatically en-
tered in the corresponding input tables at the bottom of the screen, and vice versa. If the 
tables are not shown, open them with the View → Tables menu or the button as seen to 
the left. 

There are six distinct input tables: 

• 1.1  Nodes 

• 1.2  Materials 

• 1.3  Sections 

• 1.4  Elements 

• 1.5  Point Elements 

• 1.7  Forces and Moments 

Move between the tables by clicking on the register tabs below the tables. The graphic in-
put done in the example so far can be found in the Nodes, Elements and Point elements ta-
bles. 

 
Figure 3.19: Table 1.1 Nodes 

There is still no input for the Principal axis coordinates in the first table. The program will 
automatically put in these results after the analysis of the section. 

As the rolled angle section was split up into individual elements when setting it, the table 
1.3 Sections is empty. 

Table 1.4 Elements lists the Thickness and Material of every element, plus Length, Direction 
and Area. 

 
Figure 3.20: Table 1.2 Elements 
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In the 1.5 Point Elements table, all inserted or removed point elements are compiled. The 
weld seam is contained in row 5. 

 
Figure 3.21: Table 1.5: Point elements 

As the geometrical input of our example requires no changes, click the Materials tab or 
move to that table with the [←][→] buttons in the table toolbar. 

3.3.10 Edit Material 
In table 1.2 Materials, the material characteristics and limit stresses are defined. 

 
Figure 3.22: Table 1.2 Materials 

Steel S 235 was set as default for all elements. To access the material library, click this steel 
grade in the Material Description column and then on the small button within the input 
field (see above). The Material Library is called up. 
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Figure 3.23: Dialog box Material Library 

In the dialog section Filter Choice to the left, select the Code Group EN from the list. Click 
the steel grade Steel S 235 JR in the section Material to Select and then click [OK]. 

The new material characteristics and the Limit Stresses σx, v and σeqv are imported into the 
Materials table. This input table is now complete, as a Comment is only optional. 

3.3.11 Define Internal Forces 
The internal forces (cf Table 3.1, page 11) can be entered in table 1.7 Forces and Moments. 
Move to this table by clicking on the corresponding tab or by using the [←][→] buttons as 
before. 

There are two different constellations of internal forces. Instead of creating two different 
load cases, it is easier to specify two different design locations x within a single load case. In 
our example, those locations can be freely defined. With the first entry of a Location x, the 
new load case LC1 is created automatically. Put in the internal forces as follows. 

 
Figure 3.24: Table 1.7 Forces and moments 
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3.4 Calculation 
The input is complete now. You can start the analysis of the section properties and stresses 
via the Results → Display Results menu or by clicking on the button as seen to the left. 
Pressing the function key [F5] has the same effect. 

The results will be displayed after a quick calculation. 

3.5 Results 
The cross-section graphics show the 

• principal axes u and v, 

• area bisection axes (dotted lines), 

• centroid C, 

• inertia ellipse and 

• shear center M. 

In our example, the axis u represents the major principal axis. 

In table 2.1 Section Properties, the characteristics of the section are listed in detail. 

 
Figure 3.25: Section after the analysis 
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3.5.1 Select Results 
The display of the section properties or stresses can be controlled with the Results menu. 

 
Figure 3.26: Results menu 

The Results toolbar represents even faster options to evaluate the results graphically and to 
select among the load cases and locations x. It is possible to page forward to the next load 
case or location x with the [] buttons or by choosing them from the list. 

 
Figure 3.27: Toolbar Results 

Click the stresses [σx] button and make sure that the location x = 0.00 mm is set. The nor-
mal stresses will be displayed on the center lines of the section. 
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Figure 3.28: Normal stresses σx 

Now click the Sigma-x folder tab of the input tables to open the 3.1 Normal Stresses table. 
There you can read the normal stresses in detail that result from the individual internal forc-
es at both design locations x. The stresses for every Element can be identified on both end 
nodes and the element center (column Distance s). 

Via menu Results → Color Spectrum or the corresponding button in the toolbar, you can 
display the normal stresses as isosurfaces on the section. 



3  Introductory Example 

 27 Program SHAPE-THIN © 2012 by Ing. Software Dlubal 

 

 
 

 
Figure 3.29: Normal stresses as isosurfaces 

You can skim through the different types of results both graphically and numerically now. 

3.5.2 Arrange Results Windows 
It is possible to display several results simultaneously. Click the button as seen left or call up 
menu Results → Arrange Results Windows. The Results - Display Options dialog box 
opens. For our example, select the Statical Moments Qu and Qv to be shown exclusively. 

 
Figure 3.30: Dialog box Results - Display options 

After clicking on [OK], a partitioned window opens with both of the selected cross-section 
characteristics. The illustration the numbering can be disabled for both views (cf Figure 3.5, 
page 14). When you now open the 2.2 Property Distribution table by clicking on the corre-
sponding folder tab, the screen looks like the following. 
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Figure 3.31: Statical moments Qu and Qv 

3.5.3 Printout Report 
To document the screen view above in the printout report, click the [Print] button in the 
toolbar or select the File → Print menu. The Print image dialog box is opened. 

 
Figure 3.32: Dialog box Print image 

As seen in the image above, choose the following settings. 
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• Print  All windows 
• Print destination To printout report (no short form printout) 
• Image size  Window filling 
• Page settings Use whole page 

Click the [Window arrangement] button to define how the graphics are to be arranged on 
the sheet. 

 
Figure 3.33: Dialog box Window Arrangement 

For the Arrangement of Graphics on Page, select Case 3 and then confirm this with [OK]. 

The two tabs Print quality and Color spectrum in the previous Print image dialog box con-
tain more options for the printout, e.g. print color, frame, position of color spectrum, which 
you can quickly check. 

If you accept those settings, confirm the dialog box with [OK] to start printing the image to 
the printout report. This preview of the print data appears after a short while. 

 
Figure 3.34: Printout report with results graphics 



3  Introductory Example 

 

 

30 Program SHAPE-THIN © 2012 by Ing. Software Dlubal 

  
 

 
 

The printout report is a separate section of the SHAPE program and consists of a two-part 
layout. To the left is the Print Navigator where the contents of the printout report are seen 
in a hierarchal list. Like the Windows Explorer, the topics are opened and closed by clicking 
on the [+] and [-] buttons respectively. 

Using the Drag & Drop function, topics can be moved to rearrange the contents. We will 
apply this function now to place our image of the statical moments – which was added at 
the end of the printout report – at a different location: Click the left mouse button on the 
Results graphics in the Print Navigator, drag it over Statical Moments and release the mouse 
button. 

 
Figure 3.35: Printout report: Moving graphics and context menu 

Clicking the right mouse button on any topic in the Print Navigator opens a context menu 
with more settings. To change the headline of the image, click the Properties option in the 
context menu and type in Statical Moments Q-u and Q-v as new Title. 

 
Figure 3.36: Dialog box Properties 

After [OK], the printout report will be created with the modified image. 
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When the printout report has been completely arranged, it can be finally sent to the printer 
via menu File → Print or the corresponding button in the printout report. 

3.6 Outlook 
This concludes our introductory example. We hope that we could give you a short overview 
and made you curious to discover more of the program functions on your own. Detailed 
descriptions of all SHAPE functions follow in the next chapters of this manual. 

The SHAPE online help which is based on this manual can be opened via menu Help or [F1]. 
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4. User Interface 
 

4.1 Overview 
When you open one of the demo examples in SHAPE, your screen should look as shown in 
figure 4.1. The user interface conforms to the usual Windows standards. 

The following figure shows the most important areas. 

 
Figure 4.1: SHAPE user interface 

4.2 Terminology 
This chapter explains some important terms of the Windows user interface that are fre-
quently used in this manual. 

Different expressions are used to describe the individual elements of the user interface. The 
following table lists the most common expressions. 

Term Figure Synonym Explanation 

Menu 

 

Pulldown 
Menu 

Commands and 
functions below 
the title bar 
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Context 
Menu 

 

Pop-up 
Menu 

The context 
menu can be 
activated by a 
right mouse 
click. 

It contains useful 
items for the 
selected object. 

Toolbar 

 

Button Bar Collection of 
buttons beneath 
the menu bar 

Dialog 
Box 

 

 A window which 
is opened in the 
main window for 
the user to enter 
data. 

Tab 

 

Register Extensive dialog 
boxes are struc-
tured by several 
tabs. 

Clicking a tab 
activates the 
appropriate 
index card. 

Section 

 

Group, 
Frame 

Various elements 
in a dialog box 
that belong to-
gether logically. 

Button 

 

Icon Clicking a button 
starts an action, 
e.g. a new dialog 
box is opened or 
changes take 
effect. 
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Input 
Field 

 

Input Box, 
Input Line 

Space for text or 
numbers to be 
entered 

Spin 
Button 

 

Spinner Two tiny buttons 
at the end of an 
input field to 
increase resp. 
decrease the 
numerical values.  

List 

 

List Box, 
Combo Box 

Offers a selection 
of options to 
choose from. 

Sometimes user-
defined terms 
can be included 
in the list. 

Check Box 

 

 Yes/No inquiry 
for specific 
choices. 
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Selection 
Field 

 

Radio 
Button 

Selection among 
several options. 
Only one of 
these alternatives 
can be true. 

Slide 
Control 

 

 “Continuously“ 
adjustable con-
troller for certain 
features. 

Tree 
Structure 

 

Tree 
Diagram 

Arrangement of 
information simi-
lar to the Win-
dows Explorer. 

Table 4.1: Terminology 
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4.3 SHAPE User Interface 
This chapter describes the individual operating elements of SHAPE (cf Figure 4.1, page 32). 
The program follows the general standards for Windows applications. 

4.3.1 Menu Bar 
The SHAPE menu beneath the title bar contains all program functions. They are organized in 
logical blocks. 

A menu can be opened by clicking with the right mouse button or activating the keyboard 
by pressing the [Alt] key in combination with the underlined letter. The menu will open and 
the individual menu entries will be accessible. The selection is again carried out either with 
the mouse or the keys of the underlined letters. A function can also be selected with the 
cursor keys [] and [] and then started with the [] key. 

When a menu has been opened, you can move between the entries with [] and []. 

Next to some menu items, so-called hot keys are specified. These keep with the Windows 
standards and can also be used to start certain functions, e.g. [Ctrl]+[S] save the data. 

4.3.2 Toolbars 
Beneath the menu bar, there is a collection of many buttons which permit direct access to 
the most important functions. When the mouse pointer rests over a button for a moment, a 
short info text will be displayed as Tooltip. 

It is possible to customize the toolbars. The position can be changed by picking a toolbar at 
its left side and then moving it to a different location. 

 
Figure 4.2: Toolbar 

As soon as the toolbar is being moved to the work area, it is transformed to a “floating” 
bar within the active window. 

 
Figure 4.3: Floating toolbar Tools 

The toolbar can be moved back to its original place with the mouse or by double-clicking its 
headline. 

Menu View → Customize Toolbars calls up a dialog box which makes it possible to change 
the contents and look of the toolbars. 

 
Figure 4.4: Dialog box Toolbars 
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All available toolbars are listed in this dialog box. If a toolbar is visible, its check box in sec-
tion Index is activated. If a toolbar is to be made invisible, the appropriate check box can be 
disabled with a mouse click. 

After clicking on button [New Toolbar...], a user-defined toolbar can be created. 

 
Figure 4.5: Creating a new toolbar 

A dialog box is opened in which the name of the new toolbar can be entered. After [OK], 
the new tab Commands is available in the Customize Toolbar dialog box (see below) where 
the individual buttons can be assigned to the new toolbar. 

The description of a user-defined toolbar can be changed in the input field Toolbar Name. 

[Default] resets everything to the original state. If a user-defined toolbar is marked in the list 
on the left, it will be removed. The default toolbars cannot be removed, only hidden. 

Three checkboxes are available for the look and features of the buttons. 

Show Quicktip 
When the pointer is moved over a button, a short explanation of its 
function appears. 

Cool Look A button emerges when the pointer is placed on it. 

Large buttons The buttons are drawn to a larger scale. 

Table 4.2: Options for the button display 

 
Figure 4.6: Dialog box Customize Toolbars, Commands tab 

The Commands tab of the dialog box is accessible when a new toolbar is created or when 
you have activated the button [Customize toolbars]. The contents of the single toolbars can 
be modified in the second tab of this dialog box. All commands are assigned to certain cat-
egories. When a category has been selected, all command buttons belonging to this cate-
gory are displayed to the right side. Click one of these buttons to get a short explanation of 
its function in dialog box section Explanation. The buttons can be moved to any toolbar by 
drag & drop. 

To remove a button from a toolbar, press the [Alt] key and drag the button to the work area. 
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4.3.3 Navigator 
The navigator is displayed on the left side of the work window. It can be switched on and 
off with the corresponding button in the View toolbar or via menu View → Navigator. 

 
Figure 4.7: Button [Display navigator] in the View toolbar  

In its handling, the navigator is similar to a toolbar. It can be picked with the mouse at its 
top edge and then be moved to the work area. Double-clicking the headline or moving it to 
the left or right margin will dock it again. 

A clearly arranged tree structure presents all data of a selected structure. [+] opens the 
branches of this tree, [-] shuts them again. Double-clicking on the entry has the same effect. 

 
Figure 4.8: Navigator 

All input and results data are listed in this navigator. Double-clicking an entry (a “leaf“ of 
this tree) calls up a dialog box to modify the item. When clicking on an entry with the right 
mouse button, a context menu appears which contains the most important functions 
relevant for this item. 

Objects that have been defined incorrectly are marked by an asterisk. 
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4.3.4 Tables 
The numerical tables are arranged at the bottom edge of the SHAPE window. They can be 
switched on and off via the View → Tables menu or the appropriate button in the View 
toolbar. 

 
Figure 4.9: Button [Display table] in the View toolbar  

All data can be entered numerically in the tables. Several powerful functions enable a very 
effective input (for details see chapter 10.3, page 181). 

Working through the tables successively warrants that all data will be included. The tables 
reflect the internal organization of the SHAPE data. For this reason, the structure of chap-
ters 5 and 7 in this manual corresponds with the table sequence. 

In its handling, the table is similar to a toolbar. It can be picked with the mouse at its top 
edge and then be moved to the desktop. Double-clicking the headline or moving it to the 
one of the margins will dock it again. 

When a row has been selected in the table, this element is highlighted in the graphics 
above. Vice versa, the corresponding row is highlighted in the table if an object has been 
selected in the graphics. This synchronization of the selection can be controlled via menu 
Tables → Settings or with the two buttons shown on the left. 

4.3.5 Status Bar 
The status bar represents the bottom end of the SHAPE window. Menu View → Status Bar 
switches it on and off. 

The status bar consists of two areas. 

Left Area 

 
Figure 4.10: Status bar, left area 

The text that is shown here varies according to the active program function. If the mouse 
pointer is above an object of the graphical desktop, some further information is given on 
this. 

Please keep an eye on this part of the status bar. Useful information will be given about 
buttons or input fields in dialog boxes. 

Right Area 

 
Figure 4.11: Status Bar, right area 

This part of the status bar shows the current coordinates of the nodes or of the mouse 
pointer when setting elements or nodes. 
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4.3.6 Control Panel 
When displaying stresses or utilizations, several parameters with regard to view and control 
of the display are accessible through the Panel. The menu 

Results → Color Spectrum 

or the corresponding button opens and closes this panel. 

This panel has two folder tabs.  

Color Spectrum 

 
Figure 4.12: Panel - Color Spectrum tab with activated button [] 

When a multi-color view was selected, this tab will show the color spectrum with the as-
signed value areas. A color spectrum of eleven colors is set by default, covering the extreme 
values in equidistant intervals. 

The color spectrum can be edited by double-clicking one of the colors. You can also use the 
details button [] on the bottom right and then Define the values of the isosurfaces and 
the color spectra by clicking on the […] button. The following dialog box appears: 

 
Figure 4.13: Dialog box Define Color Spectrum 
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By means of the two vertical slide buttons to the right of the values, the number of colors 
can be reduced from both sides. In addition, every color can be modified by double-clicking 
the color box. 

You can also adjust the values of the spectrum according to your needs. However, a conse-
quently ascending resp. descending order has to be observed. The buttons in the dialog 
section Value Spectrum help with assigning values. Their meanings are as follows: 

Button Function 

Default The eleven color zones are set to default. 

Save The value spectrum is saved as a global sample. 

Apply The current settings take effect for the results display. 

Delete The user-defined value resp. color spectrum is deleted. 

Empty All values in the input boxes are deleted. 

Fill in 
The values are equidistantly intercalated between maximum and 
minimum depending on the number of color zones. 

Table 4.3: Buttons in dialog box Define Color Spectrum 

When the details button [] is activated, additional settings are available in a small dialog 
box. 

 
Figure 4.14: Dialog box Options, Limiting values +/- 

The option Limiting Values allows for a detailed evaluation within a defined area. Every ex-
cess of the top or bottom limits will be covered by a single color. For example, the figure 
above implies the normal stresses within the interval of ± 100 N/mm2 to be scaled in detail. 

When the check box Smooth Color Transition is active, the distinct range borders of the 
ranges disappear. This option for a continuous color spectrum does not depend on the se-
lected reference of the result values. 
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Filter 

 
Figure 4.15: Panel - Filter tab 

The Color Spectrum tab can be used to filter results in general. However, the Filter tab con-
trols the result display for selected elements. 

The numbers of the relevant elements can be entered in the input box Display Diagrams for. 
The filter function is carried out via [Apply]. The numbers can also be imported from the 
graphics via the [Select] button (multi-selection with window or pressed [Ctrl] key). Then 
the button [Apply] can be used. 
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4.3.7 Default Buttons 
Certain buttons are used in many dialog boxes. When you let the mouse pointer hover on a 
button of the toolbar, a short description of its function will appear. 

The following overview describes these default buttons. 

Button Description Function 

 New Opens as dialog box to define an object 

 Edit Opens a dialog box to modify an object 

 Pick Graphic selection 

 Import Imports from current selection 

 Library Opens a collection of stored data 

 Help Opens the help function 

 Apply Applies changes without closing the dialog box 

 Settings Opens a dialog box for detailed settings 

 
Units and Decimal 
Places 

Settings for units and decimal places 
 chapter 10.4.3, page 193 

 Standard Restores default settings 

 Set as default Stores the current settings as default 

 Fonts Option to define fonts and font sizes  

 Info Displays information to an object 

 Transfer selection Transfers selected items from one list to another 

 Transfer all Transfers all items from one list to another 

 Save Stores a user-defined entry  

 Import Imports a stored entry 

 Select Selects certain resp. all objects 

 Deselect Deletes resp. deselects all entries 

Table 4.4: Default buttons 



4  User Interface 

 

 

44 Program SHAPE-THIN © 2012 by Ing. Software Dlubal 

4.3.8 Keyboard Functions 
In spite of graphical interfaces, it may be helpful for experienced users to call up frequently 
used functions by keystrokes. Here is a list of all keyboard functions: 

[F1] Help 

[F2] Next table 

[F3] Previous table 

[F5] Start Calculation 

[F7] Selection function in tables 

[F8] Displays the entire structure – Show all 

[F9] Calculator 

[F10] Menu Bar 

[F12] Saves the structure under a different file name 

[Alt] Menu Bar 

[Ctrl+2] Copies a row of the table to the next row 

[Ctrl+A] Redo 

[Ctrl+C] Copies to the clipboard 

[Ctrl+F] Searches within the table 

[Ctrl+G] Generates entries in the table 

[Ctrl+H] Finds entries in the table and replaces them 

[Ctrl+I] Inserts rows in the table 

[Ctrl+L] Goes to a specific row number in the table 

[Ctrl+N] Creates a new structure 

[Ctrl+O] Opens a structure 

[Ctrl+P] Prints the picture to the printer, printout report or clipboard 

[Ctrl+R] Deletes a row in the table 

[Ctrl+S] Saves the structure 

[Ctrl+U] Deselects in the table 

[Ctrl+V] Inserts from clipboard 

[Ctrl+X] Cuts items in the table 

[Ctrl+Y] Deletes the contents of a row in the table 

[Ctrl+Z] Undo function 

[+] [-] NumPad Zoom functions 

Table 4.5: Keyboard functions 
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4.3.9 Context Menus 
For most elements, a context menu can be activated by a right mouse click. It contains use-
ful items for the selected object. 

Context menus can be used in the SHAPE graphics, navigator and tables. 

 
Figure 4.16: Point elements context menu in the navigator 
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4.4 File Management 
SHAPE includes an administration of the cross-sections called the Project Manager which 
helps to organize all user-defined sections. It allows for the management of several sections 
under one project. 

4.4.1 Project Manager 
The Project Manager can be called with the appropriate button in the default toolbar or via 
menu File → Project Manager. 

 
Figure 4.17: Button Project Manager in the toolbar 

The General Data dialog box also offers a button to directly access the Project Manager. 

 
Figure 4.18: Dialog box General Data 

After calling up the Project Manager, a three-part window appears. This window has its 
own menu and its own toolbar. 
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Figure 4.19: Project Manager 

Project Navigator 
A navigator with a list of all existing projects is displayed in the top left part. The current 
project is set bold. A different project can be selected as ‘current’ by double-clicking it or via 
the list Current Project in the toolbar. To the right, a listing is shown with all sections of the 
selected project. 

Table of Sections 
The sections are listed with their names and descriptions, numbers of nodes and lines as 
well as the types and the dates of the last modification. 

Sections Preview 
When one of the section names is selected, the corresponding illustration of this section 
appears in the lower left part of the Project Manager. 
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4.4.1.1 Projects 

Create New Project 
A new project is created via the 

• menu Project → New 

• button [New Project] in the toolbar 

 
Figure 4.20: Button New Project 

In the following dialog box, it is necessary to provide the Project Name and Folder. The 
[Browse] button is used to locate the index path. Also a Description can be added as short 
specification of the project. 

 
Figure 4.21: Dialog box Create New Project 

[OK] will create a new folder with the project name on the local or network drive. 

The Description of the project is shown in the headline of the printout report and has no 
further relevance. 

Connect Existing Folder 
The function can be called up via the 

• menu Project → Connect Folder 

• button [Connect Folder] in the toolbar. 

 
Figure 4.22: Button Connect Folder 

It is irrelevant on which local or network drive the folder is located that is to be connected. 
It will simply be included, but left at its location – similar to creating a shortcut on the desk-
top. All project information is saved in the DU_PRO.DLP file which is located in the 
..\Dlubal\Stammdat folder. 

The Name and Description for the project is to be entered. Then set the path for the Folder 
to be connected with the [Browse] button. 
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Disconnect Project Folder 
This function can be called up via the 

• menu Project → Disconnect (a project must have been selected) 
• context menu of a project. 

 
Figure 4.23: Context menu Project 

Connected projects in the Project Manager are removed from the internal management, but 
the folder and its contained data will not be deleted from the hard drive. 

Delete Project 
You can delete a project via the 

• menu Edit → Delete (the project must have been selected) 
• button [Delete] in the toolbar 
• context menu of a project in the navigator. 

 
Figure 4.24: Button Delete Project 

The folder on the hard disk will be deleted together with its contents. If the folder contains 
other files apart from SHAPE files, they will be deleted as well. 

Change Project Description 
This function can be called up via the 

• menu Project → Properties (the project must be selected)  

• context menu of a project in the navigator. 

 
Figure 4.25: Context menu Project 
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The Description of the project can be changed in a dialog box. Apart from this, the location 
of the project on the hard disk is shown. 

 
Figure 4.26: Dialog box Project Description 

If the project is to be renamed, you can use the 

• menu Edit → Rename (the project must be selected)  

• context menu of the project in the navigator. 

4.4.1.2 Sections 

Open Section 
An existing cross-section can be opened via 

• double-clicking 

• menu Position → Open (a section must have been selected) 

• its context menu. 

 
Figure 4.27: Context menu Section 

Move and Copy Section 
A section can be moved or copied via 

• menu Section → Copy (the section must have been selected) 

• the context menu of the section 

• drag & drop. 
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Figure 4.28: Dialog box Copy Section 

In this dialog box, the target project as well as the name and the description are to be en-
tered for the copy of the section. 

Rename Section 
It is possible to rename a cross-section via the 

• menu Edit → Rename (the section must have been selected) 

• context menu of the section. 

If the description of the section is to be changed, the section has to be opened first. Then 
its description can be modified in the General Data dialog box (cf Figure 4.33, page 53). 

Delete Section 
A structure can be deleted via the 

• menu Edit → Delete (the section must have been selected) 

• button [Delete] in the toolbar 

• context menu of the section. 

 
Figure 4.29: Context menu Section 
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4.4.1.3 Data Archiving 

Archive Data 
Selected sections or an entire project folder can be saved in a compressed backup file. The 
original sections remain in their folders. 

It is possible to archive selected sections or a folder via the 

• menu Archive Data → Make Archive (select sections or project before) 

• context menu of the project. 

Before archiving all data, it can be decided whether the results and printout reports are to 
be excluded from the backup file in order to save space. 

 
Figure 4.30: Dialog box Save as 

When the Name and Folder of the archive file have been defined, the *.arr archive file can 
be created. 

Dearchive Data 
This function decompresses a SHAPE archive file via the menu 

Archive Data → Extract from Archive. 

When the archive file has been selected, its contents are shown: 

 
Figure 4.31: Dialog box Contents of rsarch1.arr 

The files that are to be restored can be selected in section Sections. The chosen sections can 
be restored to the Current or an Other Target Project which can be picked from the list. It is 
also possible to create a [New] project in a separate dialog box. 
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4.4.1.4 Appearance 

It is possible to adjust the listing of the sections in the project according to your needs. As 
usual with Windows applications, the list will be sorted ascending or descending by clicking 
on the column title. 

All viewing functions are accessible in menu View of the Project Manager. 

4.4.2 Create New Section 
A new cross-section can be created via the 

• menu File → New 

• button [New Cross-Section] in the toolbar 

• menu Position → New in the Project Manager 

 
Figure 4.32: Button New cross-section 

The dialog box New cross-section - General data is opened. 

 
Figure 4.33: Dialog box New cross-section - General data, General data tab 

At a later date, it is possible to modify the general data of a section via the 

• menu Edit → Section Properties → General data 

• context menu in the navigator. 
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Figure 4.34: Context menu of the section 

This dialog box consists of several tabs. Some of these are only available when the corre-
sponding check box is activated among the options Calculate additionally of the first tab 
General. The different registers are described in the following chapters. 

4.4.2.1 General Data 

Section 
In the Section input field, the name of the cross-section can be specified. This will be the file 
name of the section, too. The Description can be used for more detailed information. It will 
be shown in the headline of the printout report but has no further relevance. 

 
Figure 4.35: Section description in the Printout Report 

Project 
The project folder of the new section can be selected from the list of projects. The default 
folder is the current project which can be changed in the Project Manager (cf chapter 4.4.1, 
page 47). You can call up the [Project Manager] by clicking on the corresponding button. 

The Description of the project and the File location are displayed for information, too. 

Calculate Additionally 
In this part of the dialog box, specific settings can be defined for the analysis of the section. 

Plastic Section Properties 
If this check box is activated, SHAPE determines the plastic section characteristics without 
considering the interaction of the internal forces. After the analysis, the plastic forces Npl, Vpl 
and moments Mpl will be listed in the results table 2.1, together with the plastic section 
moduli Z and the plastic shear areas Apl. 
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Plastic Capacity Design 
The plastic capacity design is disabled by default as it is time-consuming and not required in 
most cases. If this check box is set active, the additional tab Plastic calculation appears. 
There, the settings for the discretization can be made (see below). Please note that internal 
forces are to be defined in table 1.7 so that the plastic capacity design can be carried out. 

Check Limiting c/t 
If the c/t zones of the elements are to be checked according to DIN 18800, this check box is 
to be activated. Then the additional tab c/t Check is available to specify the detail settings 
(see below). 

Effective Cross-Sections 
SHAPE is able to determine the effective cross-section widths according to EN 1993-1 and 
DIN 18800. If this option is set active, the above-mentioned three check-boxes will be disa-
bled. In the additional tab Effective cross-sections, the details can be set (see below). 
To calculate the effective cross-section widths, internal forces are to be defined in table 1.7. 

Positive Direction of the y0 Axis 
This dialog section controls the direction of the global coordinate axis y0 (absolute zero) 
which can be defined to the left or to the right (default). 

Independent of the selected direction, SHAPE assumes the cross-sectional areas positively 
according to the following convention. 

 
Figure 4.36: Sign convention for internal forces 

The positive direction of the y axis only represents the view on the illustrated positive cross-
sectional area against or in direction of the positive axis x of the member. 

Comments 
A text can be used to describe the section which will also appear in the printout report. 

The [Units] button calls up the dialog of the same name. It is described in chapter 10.4.3 on 
page 193. 
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4.4.2.2 Details 

In the Details tab, further settings allow for a user-definable tuning of the calculation pa-
rameters. 

 
Figure 4.37: Dialog box New cross-section - General data, Details tab 

Lateral Restraint D 
In this part of the dialog box, you can define whether or not a laterally supported rotation 
axis is effective. The Location of restraint can be entered by its y-0,D and z-0,D coordinates 
or picked in the graphics. 

Thus, a torsionally loaded section does not rotate freely about its shear center M but rather 
about the defined point of support D. This has an effect on the warping constant Iω, the re-
duction factor λ, the normalized warping constants and the stresses σMω and vMs. 

Forces and Moments Related to 
You can specify whether the forces and moments that are entered in table 1.7 refer to the 
Principal axes u,v of the cross-section or to the Axes y,z that are parallel to the global input 
axes y0 and z0. With this option, is not necessary to transform the internal forces when de-
fining them in the input table. 

Reference Material 
With composite sections, it is recommended to check the type of material which is set as 
Reference material. The idealized section properties will be determined in proportion to the 
various moduli of elasticity relating to this material. If desired, a different material can be 
chosen from the list. 

Options 
The Automatic calculation after every change is disabled by default but can be activated via 
this check box. 

It is recommended to Consider overlapping elements only once in the calculation so that 
the section properties are determined correctly. For example, overlapping elements can be 
seen in the corners of sections. For the analysis, point elements with the status “Remove” 
will be applied internally there. This function does not apply to arcs, however. 
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If elements with different materials overlap, the dialog box Overlapping Elements appears. 
There, the material can be selected which is to be assigned to the overlapping area. 

 
Figure 4.38: Dialog box Overlapping Elements 

Calculation of Sigma-eqv 
There are different approaches available to calculate the equivalent stresses. 

For steel sections, σeqv can be determined according to the yield criteria of 

• VON MISES: ( ) ( )22
xeqv 3 vΣ⋅+σΣ=σ  

• TRESCA: ( ) ( )22
xeqv 4 vΣ⋅+σΣ=σ  

For welds, σeqv can be determined according to the following equation: 

   ( ) ( )22
xeqv vΣ+σΣ=σ  

Equation 4.1 

Please note that SHAPE covers the planar state of stresses. Thus, the shear stresses of longi-
tudinal seams of welds v have additionally to be taken into accout for the weld design. 

The factor that controls the shear stresses v in those equations also has an effect on the 
plastic capacity design of the section. 

Partial Safety Factor 
This factor describes the safety factor of the material resistance. Thus, the index M is used. 
The factor γM is used to reduce the characteristic values of the material yield strength fyk for 
e.g. the limiting axial and bending stresses σR,d and the limiting shear stress vR,d. 

Buckling Curves 
For buckling analyses, every section has to be classified to specific buckling curves with re-
spect to the principal axes y and z respectively u and v (cf DIN 18 800 Part 2, Table 5 or 
Eurocode 3, Table 6.2). The buckling curves BCy/u and BCz/v control e.g. the imperfection 
factor α as described in EN 1993-1-1: 2005, Table 6.1: 

 

 

Table 4.6: EN 1993-1-1: 2005 – Imperfection factor α subject to buckling curves 

Generally, the buckling curves mainly depend on the shape of the section. As the program 
cannot allocate the buckling curves automatically for user-defined sections, BCy/u and BCz/v 
are to be specified manually via the two list boxes. 

Buckling Curve a0 a b c d 

α 0.13 0.21 0.34 0.49 0.78 
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J Calculation 
If a rolled section is made up of rectangular elements, the St. Venant torsional constant (2nd 
moment of area) J can be multiplied with a correction factor η that accounts for the corner 
radii. Depending on the shape of the section, this factor lies between 0.99 and 1.30. 

Section

η 0,99 1,12 1,12 1,30
 

Figure 4.39: Correction factor η 

Alternatively, a FEA calculation can be carried out to determine J. 

Principal Axis Inclination α 
For sections that are wider than high, the major axis u may be in horizontal position, which 
means that the principal moments of inertia are swapped with regard to their sizes. With 
the option to Transform the principal axes such that Iu is always greater than Iv, the axis u 
always represents the major axis, independent of the position of the section. 

This option is not recommended if this section is used in RSTAB to model tapered members. 
A change of the principal axes within the members might occur. 

Determine Stresses 
In this part of the dialog box, it is possible to determine if the stresses are to be calculated 
at the most unfavorable element edges (default) or only at the element center lines. The 
following figure shows the stress points for those two options. 

     

Figure 4.40: Stress points at most unfavorable edges (left) and only at element center lines (right) 

Even if the stresses are calculated at the most unfavorable edges, they will nevertheless be 
drawn at the element center lines. For a realistic distribution over the section, the panel has 
to be activated in order to display the isosurfaces (cf Figure 8.4, page 140). 

Internal Divisions for Calculation 
For the analysis, an internal division of the objects is used. In this final part of the dialog 
box, detailed settings can be made for Elements, Arc elements and Point elements. 

Please note that the division for arc elements is not a numerical sub-division as it is applied 
for elements and point elements. Instead, the division is made via equal angles whose size 
can be entered in degrees [°]. 
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4.4.2.3 Plastic Design 

The Plastic design tab allows for specific settings to control the plastic analysis. 

 
Figure 4.41: Dialog box New cross-section - General data, Plastic design tab 

There are two options available to control the discretization by so-called Simplex elements: 

• The Maximum total number of Simplex elements represents the overall limit of the 
sub-elements that are to be created for the entire section (default: 100). 

• The Number of Simplex elements across the thickness of the elements controls the 
distribution of the Simplex elements on the elements of the section (default: 2). 

In most cases, the default settings represent a practical compromise between accuracy and 
calculation speed. The more Simplex elements are to be processed, the more time the anal-
ysis will take. 

 
Figure 4.42: Simplex elements 
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To reduce the calculation time for the plastic design, the following notes may be useful: 

• Reduce the number of Load Cases and Locations x in table 1.7 Forces and Moments. 
Thus, the really required design can be carried out exclusively. 

• Two Simplex elements across the element thicknesses are sufficient in most cases for 
thin-walled sections. 

• If there are only short arc elements at the corners of the section, the internal division 
of the arcs can be increased to e.g. 30° for a smooth distribution of Simplex elements 
on the overall cross-section. For details, see the previous chapter on page 58. 

4.4.2.4 c/t Zones 

This tab controls the settings for checking the width-to-thickness ratios c/t according to  
DIN 18800. 

 
Figure 4.43: Dialog box New cross-section - General data, c/t Zones tab 

Design Method 
There are three options available to check the c/t ratios which depend on the design 
method according to DIN 18800 Part 1: 

• Elastic-Elastic (Tables 12, 13 and 14) 

• Elastic-Plastic (Table 15)  

• Plastic-Plastic (Table 18) 

If the Elastic-Elastic design method has been chosen, the Consideration of the shear stresses 
can optionally be made according to the BEUTH comment on element (745), cf [5]. 

For the Elastic-Plastic or Plastic-Plastic design methods, the Discretization settings to deter-
mine the coefficient Alpha allow for a user-defined arrangement of the so-called Simplex 
elements on the section. There are two options available: 

• The Maximum total number of Simplex elements represents the overall limit of the el-
ements that are to be created for the entire section (default: 100). 

• The Number of Simplex elements across the thickness of the elements controls the 
distribution of the Simplex elements on the elements of the section (default: 2). 
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Geometrical Criterion for Restraints 
If several elements are connected in a straight line, SHAPE automatically recognizes the con-
tinuous lengths (inclusive of dummy elements) in order to determine the c/t ratio of this 
sectional part. An end support will be assumed where another element is connected at an 
angle greater than 45° by default. In the input field End restraint of a c/t zone, a different 
angle can be specified. 

If the element thicknesses vary within a c/t zone, the thickness of the thinnest element is as-
sumed for this zone. If there is a dummy element between two ordinary elements that have 
the same thickness t, a continuous c/t zone is created from all three elements by applying 
the thickness t. This implies that there are no end restraints for dummy elements. 

c/t zones that have been detected automatically can be modified via the menu 

Extras → Edit c/t zone restraints. 

The dialog box c/t Zone Restraint on/off appears as seen in Figure 4.45 on page 62. 

SHAPE can only check the width-to-thickness ratios if internal forces have been defined for 
the section. With all three design methods, the maximum c/t values depend on the stress 
distribution in the section due to the current forces and moments. 

4.4.2.5 Effective Cross-Sections 
In the Effective cross-sections tab, specific settings can made for the analysis of the effective 
cross-section according to DIN 18800 and EN 1993-1. 

 
Figure 4.44: Dialog box New cross-section - General data, Effective cross-sections tab 

Design according to Code 
There are two selection fields available in the upper part of this dialog box to determine the 
standard according to which the effective widths are to be calculated: 

• DIN 18800 (design method Elastic-Elastic) 

• EN 1993-1 
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In DIN 18800, the design details are described in Part 2, Chapter 7. As for Eurocode 3, the 
description of the effective widths is contained in EN 1993-1-5, Chapter 4. 

Please note that the analysis of the effective cross-section according to DIN 18800 is only 
applicable for rectangular hollow sections, doubly or singly symmetric I-shape sections, U-, 
C- and Z-sections, top-hat sections and corrugated hollow sections. 

Determine ψ according to Table 5.2 
The factor ψ describes the stress ratio of the boundary stresses for each c/t zone. These 
stresses are determined from the normal stresses. This factor is required to analyze width-
to-thickness ratios according to EN 1993-1-1, Table 5.2.  

If there are stresses due to compression and bending within the cross-section, the ratio of 
the boundary stresses can be determined in two ways: Either only the flexural stress com-
ponent σM is increased in order to reach the yield strength fyd, or both stress components σN 
and σM are uniformly increased until the yield strength is reached. 

It is possible to Increase the limiting c/t proportions for Class 3 cross-sections according to 
EN 1993-1-1, 5.5.2 (9) by taking into account an increased material factor ε. Thus, Class 4 
sections can be treated as Class 3 sections. 

Geometrical Criterion for Restraints 
If several elements (inclusive of dummy elements) are connected in a straight line, SHAPE 
automatically recognizes the continuous lengths in order to determine the c/t ratio of this 
sectional part. An end support will be assumed where another element is connected at an 
angle greater than 45° by default. In the input field End restraint of a c/t zone, a different 
angle can be specified. 

If the element thicknesses vary within a c/t zone, the thickness of the thinnest element is as-
sumed for this zone. If there is a dummy element between two ordinary elements that have 
the same thickness t, a continuous c/t zone is created from all three elements by applying 
the thickness t. This implies that there are no end restraints for dummy elements. 

c/t zones that have been detected automatically can be modified via the menu 

Extras → Edit c/t zone restraints. 

The dialog box c/t Zone Restraint on/off appears. 

 
Figure 4.45: Dialog box c/t Restraint on/off 

After having selected the Node in the graphics, you can Remove or Set an end restraint 
there. 

SHAPE can only analyze the effective cross-section widths if internal forces have been de-
fined for the section. 

Number of Iterations 
In the last input field of this tab, the number of iterations can be defined. The more itera-
tions, the longer the analysis will take but the more precise the calculation will be. In gen-
eral, though, the default setting of 1 iteration provides suitable results. 

 



4  User Interface 

 63 Program SHAPE-THIN © 2012 by Ing. Software Dlubal 

 

4.4.3 Network Management 
If several persons in the office use the same stock of cross-sections, the sections can be or-
ganized by the project manager. It is necessary, however, that the sections are stored in a 
folder that is accessible on the network. 

Connect the network folder to your internal project management. This is described in chap-
ter 4.4.1.1 on page 48. After that, the sections of this folder can be accessed by the Project 
Manager, i.e. opened, modified and made write protected. 

If a user works on a section that another user wants to open, a warning will appear. This 
section can then be opened as a copy. 

 
Figure 4.46 Question when opening a read-only file 

An automatic merging of the changes is not possible. 

The data for the projects registered in the Project Manager are stored in the DU_PRO.DLP 
file. This is an ASCII file which is located in the folder ..\Program Files\Dlubal\Stammdat by 
default. 

To avoid connecting the folders by projects one by one, you can copy the DU_PRO.DLP file 
to a different computer. The file can also be modified by means of an editor. This facilitates 
the task to import all relevant project folders into the Project Manager, especially after new 
installations. 

Before pasting the file DU_PRO.DLP, you should save the existing file. 
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5. Section Data 
A cross-section needs to be opened before the input of sectional data can start. For more 
details, see chapter 4.4.2 on page 53. 

SHAPE offers several ways to enter data. The objects can be specified in a dialog box, a  
table and often also directly in the graphics. 

The dialog boxes and the graphic input can be called up via the 

• items in menu Insert 

• buttons in the toolbar Input 

• context menus of the cross-section data objects in the navigator. 

 
Figure 5.1: Input options via menu, toolbar and navigator context menu 

If you want to change an already defined object, you can do this in a dialog box or in a  
table. 

The editing dialog boxes are called up via the 

• items in menu Edit → Section Properties 

• context menus or double-clicking on the objects the graphics 

• context menus or double-clicking on the objects in the navigator. 
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Figure 5.2: Opening the editing dialog boxes via menu and context menus 

The input and modifications within the graphics are immediately shown in the tables, and 
vice versa. If the tables are not shown, they can be switched on via menu View → Tables or 
the corresponding button as seen to the left. 

 
Figure 5.3: Input table 1.1 Nodes 

By working through the individual tabs, a smooth and flawless workflow for the input is 
ensured. This allows also for a good overview over the record. The data can be also be 
quickly edited or imported from spreadsheets. 

Comments can be added in every dialog box or table to describe the object in more detail. 
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5.1 Nodes 
General Description 
Nodes are used to describe the geometry of the section. They are essential for elements and 
sections. Every node is defined by its coordinates (y0, z0). The coordinates usually refer to 
the origin of the coordinate system (0/0), but it is also possible to define the reference to a 
specific node. 

 
Figure 5.4: Dialog box Insert node 

 
Figure 5.5: Table 1.1 Nodes 

The node number is assigned automatically. If desired, a different number can be entered in 
the Node input field. The order of the numbering has no significance, gaps are permitted as 
well. ‘Free’ nodes (i.e. without connected elements) are irrelevant for the analysis. 

Coordinate System 
The coordinates of a node always refer to a coordinate system which describes the position 
of the node. According to the geometry of the section, you can choose between two coor-
dinate systems. 

Cartesian 
The axes y0 and z0 describe a translational expansion (linear). All directions of the coordi-
nates are on an equal footing. Usually, the nodes are defined in this coordinate system. 

 
Figure 5.6: Cartesian coordinate system 
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Polar 
In the circular coordinate system, the position of a node is described by the radius R which 
defines the distance to the origin, and the angle ϕ. 

 
Figure 5.7: Polar coordinate system 

The polar coordinate system is orientated clockwise. 

To facilitate the input, the section might be arranged with reference to the origin so that 
the y0 and z0 axes correspond with the main directions of the sectional elements. 

If the floating dialog box New Node is used for the graphic input, the nodes can be set di-
rectly by mouse clicks. The nodes usually snap on the grid points which are orientated on 
the global coordinate system. 

 
Figure 5.8: Floating dialog box New Node 

When modifying the coordinate system afterwards, the nodal coordinates can be automati-
cally converted into the new system. 

Reference Node 
In general, the coordinates of a node refer to the origin of the coordinate system y0 / z0. In 
this case, the node (0/0) does not need to be defined explicitly as SHAPE recognizes the ab-
solute zero automatically. 

Any other node can also serve as reference node. Even a node with a higher number can be 
used as reference node. The reference to a different node is e.g. useful when you want to 
define a new node at a certain distance from a known location. 

In the Insert Node dialog box (cf Figure 5.4), the node can be entered directly, selected from 
the list or selected in the graphics via [Pick]. 

Node Coordinates 
The nodal coordinates are to be defined in the previously defined coordinate system. The y0 
and z0 coordinates or the radius and the angle clearly define a node within the 2D system. 
Depending from the selected coordinate system, the coordinate parameters and column ti-
tles will change. 

Via menu Options → Units, the units of the Lengths and decimals of the nodal coordinates 
can be customized (cf Figure 10.57, page 193). 

If several nodes are selected, their collective properties can be modified by double- clicking. 
Now, only those input fields of the coordinates are filled with values that are identical for 
all selected nodes. In this way, deviations can be recognized or a new common coordinate 
can be assigned to all nodes. 
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Nodal coordinates can be also be imported from a DXF file (cf chapter 11.2, page 198) or 
from Excel (cf chapter 10.3.6, page 188). There are also two generators for hollow sections 
available which facilitate the definition of nodal coordinates (cf chapter 10.2.9, page 179 
and chapter 10.2.10, page 180). 

Principal Axis Coordinates 
These two columns in the table remain empty during the input. After the calculation, the 
nodal coordinates will be listed with reference to the principal axes y and z of the section. 

Comment 
This column can be used to enter user-defined remarks. 

5.2 Materials 
General Description 
Materials are essential to define elements and point elements. The limit stresses of the ma-
terials control the stress ratio, i.e. the utilization of the single elements. 

SHAPE allows any material to be assigned and, if necessary, the inclusion of parts with dif-
ferent material characteristics and limit stresses. The ideal cross-section properties and the 
stresses are then determined with respect to the reference material. 

The reference material can be set in the list of table 1.2 or in the Details tab of the 
General Data dialog box (cf Figure 4.37, page 56). 

 
Figure 5.9: Dialog box Enter new material 

 
Figure 5.10: Table 1.2 Materials 

Material Description 
The description of the material can be chosen according to needs. When the name entered 
matches an entry of the material library, SHAPE imports all relevant material properties. 

The import of materials from the library is described further below. 
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Elastic Modulus E 
The modulus of elasticity is required to calculate the reduction factor λ. 

For sections that consist of different materials, the elastic moduli will be converted with 
respect to the defined reference material (cf chapter 4.4.2.2, page 56). 

The settings for the units and decimal places can be modified via menu Options → Units. 

Shear Modulus G 
The shear modulus G is the second parameter that describes the elastic behavior of a linear, 
isotropic and homogeneous material. It is also needed to determine the reduction factor λ. 

Specific Weight γ 
The specific weight γ describes the weight of the material per volume unit. It is required to 
calculate the weight of the section. 

Yield Stress fy,k 

When this specific limit stress is reached, the steel begins to yield. The definition of the yield 
stress is relevant for these circumstances: 

• Calculation of the plastic section properties 

• Design of plastic capacity 

• c/t Check according to the design methods elastic-plastic and plastic-plastic 

• Calculation of the effective cross-section widths 

In this column resp. input field, the characteristic value of the yield stress fy,k is entered. The 
design, however, has to be carried out with the design value of the yield stress fy,d which is 
determined according the following equation. 

M

k,y
d,y

f
f

γ
=  

Equation 5.1 

The factor γM describes the safety factor of the material resistance. Thus, the index M is 
used. It is defined globally in the Details tab of the General data dialog box, cf chapter 
4.4.2.2 on page 57. 

When clicking on a cell in the Yield stress column of the table, the [...] button appears in 
this cell. This button calls up the new dialog box Element thickness related yield stresses. In 
the Enter new material dialog box, the [Details] button can be used after having activated 
the check box Yield and limit stresses dependent on element thickness. 

 
Figure 5.11: Dialog box Element thickness related yield and limit stresses 

In this dialog box, up to eight element thickness areas can be defined. The respective yield 
and limit stresses can then be allocated to the thickness zones in the table. 
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Limit Stresses σx, v, σeqv 

These three columns resp. input fields define the allowable normal, shear and equivalent 
stresses. 

Comment 
This column can be used to enter user-defined remarks. 

Material Library 
Many materials are already stored in the so-called material library. 

Call up the Library 
The material library can be called up in the New Material dialog box by clicking on the  
[Library] button. The library is also accessible in table 1.2 Materials: Clicking on a cell in col-
umn A highlights a button within this cell. Click this [...] button, or press the [F7] key. 

 
Figure 5.12: Dialog box Material Library 

Materials can be selected from the list Material to select. The values can be controlled in the 
lower part of the dialog box. With [OK] or [↵], the material can be imported. 

Filter Library 
Because of the size of the material library, there are several Filter options. The material list is 
used to filter according to the criteria Material category, Code group and Code. 

Create Favorites  
Frequently used materials can be saved as favorites. If the option Show favorites only is ac-
tive in the material library, only the selected materials will appear. The dialog box to create 
favorites is called up via the button [Edit Favorites and Sequence]. 
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Figure 5.13: Dialog box Favorites and Sequence of Materials 

This dialog box contains the already described filter options. Frequently used materials can 
be marked as Favorite by activating the check box in the last column of the Materials list. 
Also the sequence of the materials can be modified via the buttons [] and []. 

If the check box Show Favorites Only is active, the material library looks more compactly. 

The favorites also have an effect on the material that is preset when creating a new section: 
Additionally to the default Steel S 235 material, the top favorite will be imported. 

Expand Library 
The data base for the materials is expandable. Immediately after adding a new material, it 
can be used for all SHAPE sections. 

The button [Create New Material], which is located in the dialog section Material to select 
of the material library, opens the New material dialog box. The parameters of the selected 
item from the list Material to select are already set. 
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Figure 5.14: Dialog box New Material 

The Material Description and the Material Constants are to be defined. Furthermore, suita-
ble Categories for Filter Cchoices need to be specified. The categories can be either modi-
fied or newly created. 

 
Figure 5.15: Dialog box Edit Material Categories 

You can adjust the sequence of the items with the [] and [] buttons. 
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5.3 Sections 
General Description 
In SHAPE, types of rolled or welded cross-sections – the “sections” – can be chosen from an 
extensive library and be integrated in the SHAPE cross-section. 

It is also possible to create user-defined sections from cross-sectional parts. 

 
Figure 5.16: Table 1.3 Sections 

Material Description 
An entry can be selected from the list of the materials that have already been defined. This 
list is available via the [] button which appears at the end of the active cell. 

In the Set section dialog box (cf. Figure 5.19), there are two buttons next to the list. These 
can be used to modify the material or to access the material library. 

Details to the materials can be found in the previous chapter 5.2 on page 68. 

Section Description 
The Section Description has to correspond to a registered entry of the cross-section library if 
rolled or parameterized sections are to be used. It is recommended to use the […] button in 
the table which calls up this library. There, the desired section can be selected. Its descrip-
tion will be imported into the table after having set the section. 

How to set sections from the library is described below. In chapter 10.1.8 on page 171, it is 
explained how user-defined sections can be created from selected elements. 

Section Offset Points 
When setting the section graphically, a location of the cross-section is to be defined where 
to ‘grab’ it – the so-called Offset Point. In the Set section dialog box (cf. Figure 5.19), the 
coordinates of this offset point are shown in the two input fields above the image. Those 
coordinates yP and zP can be referred either (statically) to the centroid or (geometrically) to 
the center point of the section. 

Position 
These two columns of the table define the location of the offset point in the global coordi-
nate system y0 and z0. 

Rotation β 
It is possible to rotate the section about the angle β which can be freely defined. 
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Area 
The value of the cross-sectional Area is imported from the library. For user-defined sections 
from selected elements, SHAPE immediately determines the area and shows the value here. 

Library of Cross-Sections 
There is a great variety of cross-sections available in a library. 

Call up the Library 
The cross-section library can be called up via the 

• menu Insert → Sections → Graphics → Section Library 

• button [Set section] in the toolbar 

• button […] or the [F7] key in column Section description of table 1.3 Sections. 

 
Figure 5.17: Dialog box Cross-section Library 

Set Section 
The types of cross-sections are divided into three groups: Rolled, Welded and Combined 
Cross-Sections. Due to the thin-walled calculation theory, both solid sections and round or 
flat bars are not accessible. Click one of the buttons to open a new dialog box with a list of 
all available sections in this group. 

 
Figure 5.18: Selecting a rolled cross-section from the UB table 
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Here you first specify the Table so that you can select the relevant Cross-Section. You can 
use the [Details] button if you want to check the sectional properties of this cross-section. 

When the cross-section has been chosen, click [OK] to open the final dialog box where the 
various parameters can be set before placing the section in the graphics. 

 
Figure 5.19: Dialog box Set section, option to connect section to Edge of existing element 

The image in the right part of this dialog box shows the position of the current Offset Point 
which represents the “grab point” of the section. It is symbolized by a red circle. It is possi-
ble to define a different offset point by entering the coordinates of the Offset point location 
or by simply picking it in the image of the section. Regular SHAPE Nodes are shown in red, 
Auxiliary points in blue. The new offset point is then portrayed as a large red circle. If it is 
difficult to focus on the offset point, use the zoom function to enlarge the relevant area in 
the image. 

There are three options in the dialog section Place section on to set the section at the 

• Node, auxiliary point or grid point which can be picked in the graphics 

• Edge of element, which creates a rigid connection via a dummy element to the left or 
right of the element that you can [Pick], at a certain distance of the element start 

• Coordinates y0 and z0 

It is possible to define a Section rotation about a user-definable angle β or by defining a 
Parallel or Perpendicular arrangement to the edge of another element. 

The Material can be selected from the list or [Database], cf Figure 5.12 on page 70. 

Optionally, it is possible to Reduce the section into individual elements so that its elements 
can be edited subsequently. The Snap on function is useful to set the section on the grid 
points. If auxiliary points are to be picked instead, this check box could be disabled. 

When all input has been completed, confirm the settings with [OK]. It is faster, however, to 
set the section graphically by moving the dotted-line section over the screen to the desired 
location with the mouse. When the convenient node, auxiliary point or grid point is shown 
in the dialog box or status bar, the section can be set there by a single mouse click. 
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5.4 Elements 
General Description 
The geometry of the section is described by elements. Elements are defined by a start node 
and an end node and by a thickness that is assigned to this straight or curved line. Elements 
can only be connected with each other on nodes. 

 
Figure 5.20: Dialog box Insert element 

 
Figure 5.21: Table 1.4 Elements 

The element number is assigned automatically. If desired, a different number can be en-
tered in the Element input field. The order of the numbering has no significance, gaps are 
permitted as well. 

Material Description 
An entry can be selected from the list of the materials that have been defined. It is possible 
to assign various materials to different elements within one section. 

In the Insert element dialog box, there are three buttons next to the list. They can be used 
to create or modify materials and to access the material library. 

Details to the materials can be found in chapter 5.2 on page 68. 
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Node Start - End 
Every element is defined geometrically by a start node and by an end node. The order of 
those two nodes controls the orientation of the element, too. In turn, the element direction 
controls the results distribution on the element in some cases (e.g. statical moments). 

The nodes can be entered manually, selected or newly defined. 

 
Figure 5.22: Activating the Element orientation in the Display dialog box 

The element orientation can be changed quickly: Right-mouse click the element and select 
Reverse Orientation in the context menu. The numbers of the nodes for element start and 
end will then be exchanged. 

Thickness t 
The thickness t defines the thickness of standard elements. If the effective thickness for 
shear transfer is not identical to this thickness, however, the effective thickness t* can be 
entered in a separate input field resp. dialog box that is called up via the […] button at the 
end of this input field in the table. 

The effective thickness is relevant especially for dummy elements. SHAPE recognizes the 
thickness zero as a non-interruption of the shear flow. For certain formulae, the thickness 
must be greater than zero, however, as t is in the denominator. 

 
Figure 5.23: Dialog box Effective thickness t* 

Arc 
The check box in the Insert element dialog box or in the table column controls whether the 
element is straight or curved. The following input fields are only accessible when the box is 
marked with a cross, which can be done by a single mouse click. 

In the analysis, arcs are taken into account as straight elements based on polygonal lines. 
The internal division of arcs can be specified in the Details tab of the General Data dialog 
box (cf Figure 4.37, page 56). 
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Arc Parameters 
Although an arc can be defined in the Insert element dialog box by activating the option 
Arc (cf Figure 5.20), there is an extra button available in the toolbar to set arcs graphically. 
It calls up the following dialog box. 

 
Figure 5.24: Dialog box Set arc element 

Radius r 
The radius must be large enough for the arc to be created between the two nodes. It the 
Set arc element dialog box, the two nodes are to be picked in the graphics before the radi-
us can be defined. This can be done either by entering the size of r directly and then press-
ing [Set] (but be careful not to leave the dialog box with the mouse), or by simply moving 
the mouse pointer with the dotted-line arc over the screen and selecting the radius with a 
final mouse click. 

Right 
This check box controls whether the arc is created to the right or to the left of the line 
which is defined by the start and end node. 

Long 
By activating or deactivating this check box, it can be defined whether the arc is longer or 
shorter than the semicircle with the same radius. 

In the Set arc element dialog box, further parameters are listed that depend on the above 
input and which can be accessed directly as well (e.g. Rise of the arc, opening angles Alpha 
and absolute coordinates of the arc Center). 

The fastest way to modify an existing arc is to double-click it in the graphics and then adjust 
its parameters in the Edit element dialog box. 

Length L 
This column of the table shows the total length of the straight or curved element. 

Direction β 
The inclination angle of the element (or of the straight line between start and end nodes of 
an arc) towards the axis y0 is specified so that the position of the element can be checked. 

Area A 
The values represent the gross areas of each element. They are the products of the element 
thicknesses t and the element lengths L. Overlappings are not considered here. For arcs, the 
areas are determined by the inner and outer radii. 

Comment 
This column can be used to enter user-defined remarks. If an element is part of a specific 
section (cf previous chapter 5.3), the section description is listed here. 
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5.5 Point Elements 
General Description 
Point elements are useful to add or to remove small sectional parts. Thus, fillets or notches 
can be modeled in detail, for example. The sections of the section library also include point 
elements internally, which can be noticed after having reduced the section into its ele-
ments. Stresses in point elements are not covered by the analysis, however. 

Please note that the ratio of all point elements should not exceed 10 % of the sectional area 
so that the section properties can be determined correctly. If a point element is of consider-
able size, it is rather to be modeled by using a ‘real’ element. 

Point elements can be ‘grabbed’ at the offset points that are displayed in the image of the 
dialog box. When a new offset point is chosen by clicking on it in this image, it is highlight-
ed by a larger circle. You can then move the dotted-line point element at this offset point 
over the screen and connect it to a node or auxiliary point of an element or point element. 

 
Figure 5.25: Dialog box New point element 

 
Figure 5.26: Table 1.4 Point elements 

The point element number is assigned automatically. If desired, a different number can be 
entered in the Point element input field. The order of the numbering is insignificant. 

Status 
It is possible either to Insert or to Remove point elements to resp. from the sectional model. 
In the following image of an I-shape section of the library, the flanges are modeled in detail 
by inserted and removed point elements. 
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Figure 5.27: Flange of I-section with inserted and removed point elements 

Type 
There are four types of point elements available that allow for a detailed modeling. 

Type Image Description 

Rounding 

 

This point element represents a square with a 
removed quadrant sector. 
The Radius r has to be defined. 

There are three offset points available. 

Rectangle 

 

The rectangle is described by the two param-
eters Length and Width. 

Apart from the offset point in the center, one 
of the four offset points at the corners can 
be used to set the point element. 

Circle 

 

The circular point element is defined by its 
Radius r. 

Apart from the offset point in the center, 
there are four offset points on the circumfer-
ence available. 

Triangle 

 

A right-angled triangle is identified by the 
parameters Length and Width. 

There is an offset point in every corner of the 
triangle. 

Table 5.1: Types of point elements 

The adequate offset point can be chosen by a single mouse click. If the parameters of the 
point element (length, width or radius) are modified subsequently, it may be necessary to 
update the offset point by picking it again. 
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Material Description 
An entry can be selected from the list of the materials that have been defined. It is possible 
to assign various materials to different elements within one section. 

In the Insert element dialog box, there are three buttons next to the list. They can be used 
to create or modify materials and to access the material library. 

Details to the materials can be found in chapter 5.2 on page 68. 

Position y0, z0 
These two input field resp. table columns define the location of the point element with ref-
erence to the global origin (0/0). To be precise, these coordinates represent the position of 
its offset point (cf Table 5.1). 

Length/Width resp. Radius 
The geometrical parameters of the point element depend on its type. For a rectangle or a 
triangle, the Length and Width are to be specified. For a rounding or a circle, the Radius r is 
has to be defined. 

To modify the parameters in the table, the […] button can be used. It appears when you 
click the cell. It calls up the Edit point element dialog box in which the parameters can be 
adjusted. 

Rotation β 
It is possible to rotate the point element about the angle β which can be freely defined. 

Area A 
The area of every point element is listed in this table column. This value is positive if the 
point element is inserted and negative if it is removed. 

Comment 
This column can be used to enter user-defined remarks. If a point element belongs to a 
specific section (cf chapter 5.3), the section description is listed here. 
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5.6 c/t Zones 
General Description 
For stress analyses, the ratio of width to thickness c/t is important so that full contribution 
of sectional parts in the case of compressive stresses is warranted. 

The c/t zones are only accessible in the graphics and in the table if one of the following op-
tions has been enabled in the General data dialog box (cf Figure 4.33, page 53): 

• Check limiting c/t 

• Effective cross-sections 

Internal forces must be defined, too, in order to check the width-to-thickness ratios. 

 
Figure 5.28: Dialog box Insert c/t zones 

 
Figure 5.29: Table 1.6 Cross-section parts for classification according to EN 1993-1 

SHAPE detects the c/t zones automatically and displays them in the graphics and the table. 
In the General data dialog box, the settings when to create end restraints of the c/t zones 
can be controlled (cf Figure 4.43, page 60 and Figure 4.44, page 61). 

If several elements are connected in a straight line, SHAPE automatically recognizes the con-
tinuous lengths (inclusive of dummy elements) in order to determine the c/t ratio of this 
sectional part. An end support will be assumed where another element is connected at an 
angle greater than 45° by default. The settings can be controlled in the General data dialog 
box (cf Figure 4.43, page 60 for DIN 18000 and Figure 4.44, page 61 for EN 1993-1). 
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Elements 
All elements that belong to the c/t zone are listed in this input field of the dialog box or 
table. 

c/t Zone Type 
In this table column, every c/t zone is assigned automatically to one of the following types: 

• Straight 

• Arc 

• CHS (circular hollow section) 

This table column is not accessible for user-defined specifications. 

Restraints Start / End 
Every c/t zone can be supported at its start and/or end, or it can be without a restraint on 
one side. Thus, internal compression parts or outstand flanges are defined. 

Subtracted Length ∆Start / ∆End 
In these two input fields of the dialog box or table, the distance of the restraint from the 
start resp. end node of the relevant element is defined. If there is no restraint, the distance 
is zero in general. Thus, it is possible to reduce the width of the c/t zone by taking into ac-
count connecting elements or fillets. SHAPE automatically recognizes favorable effects. 

Width c 
The total width of a c/t zone is made up of the lengths of all contained elements which is 
reduced by the subtracted lengths at the start and end of this zone. 

Thickness t 
The thickness is defined as the smallest thickness of all elements which are integral parts of 
the c/t zone. 

Existing c/t 
In this table column resp. dialog box field, the resulting width-to-thickness ratio is listed. 
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5.7 Forces and Moments 
General Description 
In this table, internal forces and moments can be defined or imported from RSTAB or RFEM. 
Those are the basis of the sectional design which can be carried out by load cases and loca-
tions x. The entire input is done in the table 1.7, i.e. there is no specific input dialog box. 

 
Figure 5.30: Table 1.7 Forces and moments 

The location number is assigned automatically, but the order of the numbering is irrelevant. 

Location x 
These locations define e.g. the positions along a beam where the associated internal forces 
occur. This location x, however, needs not necessarily represent a real position of the beam. 
Different locations x can be defined manually to design the section if its internal forces give 
not immediate evidence about the position of the maximum stresses. 

When entering the first location x, the load case 1 will be created automatically. See below 
for details on how to create load cases or to import internal forces from RSTAB or RFEM. 

Although identical locations x are permitted, they make the evaluation of the results a bit 
difficult. 

Axial Force N 
An axial force N results in the normal stress σx,N which is constant in the section. 

Tensile forces are entered with positive signs, compressive forces with negative signs.  

Shear Forces Vu / Vv 
The shear forces Vu and Vv (acting in the direction of the principal axes u and v) result in the 
shear stresses vVu and vVv. If they act parallel to the global axes y0 and z0, the column titles 
are labeled as Vy and Vz. In this case, they result in the shear stresses vVy and vVz. 

The reference of the internal forces can be set in the Details tab of the General Data 
dialog box (cf Figure 4.37, page 56) which can be called up via menu 

Edit → Section properties → General data. 

Torsional Moments Mxp / Mxs 
If the shear force does not act in the shear center M or lateral restraint D, the section is ad-
ditionally subjected to torsion. This results in a torsional moment (torque) about the longi-
tudinal axis x of the beam. 
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In these columns, the two components of the torsional moment Mx can be entered – the 
primary torsional moment Mxp and the secondary torsional moment Mxs. If the effects of 
warping torsion are of no concern, then only the primary torsional moment Mxp is relevant, 
i.e. Mxs can be set to zero. 

yzzyxp eVeVM ⋅+⋅−=  or 

)yy(V)zz(VM MVzzVyMyxp −⋅+−⋅−=  

Equation 5.2 
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Figure 5.31: Eccentricities ey and ez 

If the positive axis y is oriented to the right, Mxp is defined as positive when the torsional 
moment rotates clockwise about the shear center M. 

Instead of the common shear center M, it is possible to define a different point of rotation. 
The lateral restraint D can be specified in the Details tab of the General Data dialog box 
(cf Figure 4.37, page 56) which is called up via menu 

Edit → Section properties → General data. 

For sections that can be considered as warp-free in general (e.g. closed sections), the warp-
ing torsional effects may be neglected. The secondary torsional moment Mxs can then be set 
as zero. 

M=C and t=constant

One intersection

 
Figure 5.32: Warp-free and quasi-warp-free sections 

The torsional moment Mxs will be relevant for open, thin-walled, non-warp-free sections 
(e.g. I-, W- or C-shape sections). The total torsional moment MT has then to be split up into 
the Mxp component (causing primary torsional shear stresses from St. Venant torsion) and 
the Mxs component (causing secondary torsional shear stresses due to warping restraint). 
The two values are then to be entered in the table columns. 
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Bending Moments Mu / Mv 
The moments Mu and Mv (acting in the direction of the principal axes y and z) result in the 
normal stresses σx,Mu and σx,Mv. If they act parallel to the global axes y0 and z0, the column 
titles are labeled as My and Mz. In this case, they result in the normal stresses σx,My and σx,Mz. 

The reference of the moments can be set in the Details tab of the General Data dialog box 
as described for the shear forces. 

The sign convention in SHAPE corresponds to that of RSTAB, RFEM and RF-/STEEL:  My is 
positive when there are tensile stresses on the positive member side (i.e. in direction of its 
axis z). Mz is positive when there are compressive stresses on the positive member side (i.e. 
in direction of the member axis y). The following figure illustrates the sign convention. 

 
Figure 5.33: Sign rule for internal forces and moments 

Bimoment Mω 
The bimoment causes warping normal stresses σx,Mω. 

If the stresses are to be calculated without consideration of the warping torsion on account 
of a warp-free, quasi-warp-free, closed or not warp-restrained section, then the moments 
Mx,s and Mω can be set as zero for the design. Here, the torsional moment Mx,p corresponds 
to the common torsional moment MT. 

Comment 
This column can be used to enter user-defined remarks on the internal forces. 

Via menu Options → Units, the units of the Forces and Moments and the decimals can be 
customized (cf Figure 10.57, page 193). 

Create Load Case 
Different combinations of internal forces can be organized either in separate load cases or 
by defining different locations x within one and the same load case. If there are only few 
line-ups of internal forces, the last-mentioned alternative will be sufficient. 

A new load case can be created via the 

• menu Insert → New Load Case 

• button [New Load Case] in the toolbar of table 1.7 Forces and moments 

 
Figure 5.34: Button New load case in the table toolbar 
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• context menu of the navigator item Forces and moments. 

 
Figure 5.35: Context menu Forces and moments in the navigator 

The New Load Case dialog box is opened. 

 
Figure 5.36: Dialog box New load case 

The LC Number is allocated by the program, but can be replaced by a different number. If 
this number already exists, a warning will appear and the dialog box cannot be closed. The 
button [LC Index] opens an overview of all load cases that have already been defined. 

In the input field Load Case Description, a name can be assigned. The description can be 
entered or selected from the list. It is also possible to add an explicative Comment. 

Import Internal Forces from RSTAB or RFEM 
The calculated internal forces of RSTAB or RFEM members can be imported via the 

• menu Extras → Import results from RSTAB (table 1.7 must have been set) 

• button [Import Results] in the toolbar of table 1.7 Forces and moments. 

 
Figure 5.37: Button Import RSTAB results in the table toolbar 

A dialog box opens in which you can make your choice. 
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Figure 5.38: Dialog box Import Results 

In the input field Import into LC No., the first free load case number is preset. A different 
number can be entered if necessary. 

First select the Program (e.g. RSTAB 7, RFEM 4), then the Project and finally the Structure 
whose results are to be imported. The choice can be made from the list boxes which are 
opened when clicking on the input fields. 

As soon as the position has been selected, the image of the structure is shown to the right 
and all calculated Load cases are listed below. Of course, load groups, load combinations 
and super combinations are also included in this list which is sorted by No. and associated 
Description. Select the desired load case with a mouse click. 

In the Members input field, enter the relevant numbers of the members. It is recommended 
to select only specific members in order to limit the number of locations x that are to be 
imported, which facilitates the evaluation of the results later on. 

The [Browse] button makes it possible to choose a different folder. Thus, structures can be 
accessed that are not contained in projects of the RSTAB/RFEM Project Manager. 

[OK] imports the selected member results into table 1.7 Forces and moments. As load case 
description, SHAPE automatically includes the program and structure name, the member 
numbers and the original load case description. 

The forces and moments are imported at the locations x subject to the number of divisions 
for the member results in RSTAB or RFEM. To avoid identical locations x when importing the 
results of several members, SHAPE adds up the locations of all members successively. 

For load combinations, however, adding up locations x is not possible even within one and 
the same member. Thus, there are several identical locations x with the distinct maxima and 
minima, together with the associated internal forces. 

For clearly arranged combinations of results, irrelevant table rows can be deleted one by 
one via e.g. [Ctrl]+[Y]. Alternatively, select those rows with the pressed mouse button in 
column Location No. Then call up the context menu with the right mouse button to Delete 
the selected rows. 

 



5  Section Data 

 89 Program SHAPE-THIN © 2012 by Ing. Software Dlubal 

 

 
Figure 5.39: Table context menu to Delete selected lines 
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6. Calculation 
Before the calculation is started, it is recommended to check whether the data are complete 
and the references of the data sets are correct. 

Detected input errors can easily be corrected as the table line with the problem is called up 
directly. 

6.1 Plausibility Check 
The plausibility check is called up via menu  

Extras → Plausibility Check 

or the corresponding button in the toolbar of the tables. 

The check is carried out immediately afterwards. If no errors are detected, SHAPE shows an 
according message. A warning is displayed when a mismatch has been detected, however. 

 
Figure 6.1: Plausibility check with warning 

6.2 Crossing Elements 
The sectional model can be explicitly checked for elements that cross but have not common 
node at the intersection. This test is also included in the above-mentioned plausibility check. 

The examination for crossing elements can be started via menu 

Extras → Check for crossing elements. 

 
Figure 6.2: Check for crossing elements 

If there are crossing elements, a warning appears, and the elements are highlighted in the 
graphics. The sectional model can then be corrected manually or by applying the function 
Connect elements (cf. chapter 10.2.4, page 176). 
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6.3 Interconnecting Elements 
Before the calculation, SHAPE decides whether the section consists of elements that are all 
interconnecting or whether there are several independent sectional parts. 

The check for interconnecting elements can be carried out via menu 

Extras → Check for interconnecting elements. 

 
Figure 6.3: Check for interconnecting elements 

This classification is important with respect to the calculation theory: If the elements are not 
connected, the individual parts will be assumed as shear-flexible. The sectional properties 
are calculated according to the theory of stiffening shear walls. There, it is assumed that the 
global section is made up of individual shear walls (braced panels) which are tied to each 
other via floors or beams. The calculation of the section properties and stresses is carried 
out in a different manner than for coherent sections (e.g. moment of inertia without the 
parallel axis theorem component Ai ⋅ ei

2, cf chapter 7.8 on page 122). 

Unconnected sectional parts can be joined via menu 

Extras → Connect nodes and elements. 

Dummy elements are automatically created between the unconnected parts of the section. 
This function is described in chapter 10.2.5 on page 177.  

6.4 Plastic Calculation 
The parameters of the plastic calculation are controlled in the Plastic calculation tab of the 
General Data dialog box. It can be called up via menu 

Edit → Section properties → General data. 

This tab is described in chapter 4.4.2.3 on page 59. 

In most cases, the default settings represent a practical compromise between accuracy and 
calculation speed. The more Simplex elements are to be processed, the more time the anal-
ysis will take. 
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6.5 Start Calculation 
There are several options to start the calculation. Before, it is advisable to perform a short 
plausibility check of the input data (cf chapter 6.1, page 90). 

The analysis can be started via the 

• menu Results → Display Results, 

• button [Display results] in the toolbar, 

• function key [F5]. 

 
Figure 6.4: Button Display results 

If there are unconnected elements in the sectional model, SHAPE inquires whether the sec-
tion is to be calculated according to the shear wall theory which applies different formulae. 

 
Figure 6.5: Warning before calculating shear-flexible sections 
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7. Results 
Immediately after the calculation, the results are displayed in the section graphics and in 
the results tables (cf chapter 4.3.4, page 39). 

The available results tables depend on the settings specific to the calculation, i.e. stresses, 
c/t check, plastic design, effective cross-section widths or shear wall section. 

7.1 Section Properties 
Table 2.1 Section properties presents all significant sectional characteristics. To view the en-
tire list, you can enlarge the table window by pulling up its top edge with the mouse. Alter-
natively, the function Display rows can be used to hide those properties that are of second-
ary importance (cf Figure 10.47 on page 188). 

 
Figure 7.1: Table 2.1 Section properties 



7  Results 

 

 

94 Program SHAPE-THIN © 2012 by Ing. Software Dlubal 

Composite Sections 

If the section consists of elements with different materials, the table header reads Ideal 
Section Properties inclusive of the Reference Material which has been defined in the 
Details tab of the General Data dialog box (cf chapter 4.4.2.2, page 56). 

This table includes the Effective Section Properties if the effective cross-section design has 
been selected in the General Data tab of the General Data dialog (cf chapter 4.4.2.1, page 
54).The section properties refer to the effective cross-section of the current load case and 
location x, not to the gross cross-section. This kind of analysis takes no notice of section 
properties that would not make sense on the basis of this model, e.g. the “effective“ cross-
section weight or perimeter. In the same way, no plastic cross-section properties are deter-
mined when analyzing the effective cross-section. 

Cross-Sectional Area A 
The total sectional area is determined from the sums of single areas for all elements ΣAi,E 
and point elements ΣAj,PE. 

∑∑ += PE,jE,i AAA  

Equation 7.1 

If the elements of the section feature different materials, the ideal section properties are 
determined as follows: 

ref

PE,jPE,jE,iE,i

E

)EA()EA(
A ∑ ∑ ⋅+⋅

=  

Equation 7.2 

where Ai,E Area of element i 

 Aj,PE Area of point element j 

 Ei,E Elastic modulus of the material of element i 

 Ej,PE Elastic modulus of the material of point element j 

 Eref Elastic modulus of the reference material (cf chapter 4.4.2.2, page 56) 

Shear Areas Ay / Az / Au / Av 
The shear areas can be applied to determine the shear deformations due to the shear forces 
Vu and Vv (in direction of the principal axes) resp. Vy and Vz (in direction of the global axes). 
SHAPE does not use the shear areas to determine the shear stresses, though. Those are cal-
culated by use of the statical moments (1st moments of area). 
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Equation 7.3 

where Iv resp. Iu 2nd moment of area with reference to the principal axis v resp. u 

 Iz resp. Iy 2nd moment of area with reference to the global axis z resp. y 

 Qv resp. Qu 1st moment of area with reference to the principal axis v resp. u 

 Qz resp. Qy 1st moment of area with reference to the global axis z resp. y 

 t* Effective element thickness for shear transfer 
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Composite Sections 

Composite Sections 

If the elements of the section feature different materials, the ideal section properties are 
determined as follows: 

∫ ⋅⋅
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
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Equation 7.4 

where Iz / Iy 2nd moment of area with reference to z-axis resp. y-axis 

 Qz / Qy 1st moment of area with reference to z-axis resp. y-axis 

 Gref Shear modulus of the reference material 

 t* Effective width of element for shear transfer 

Centroid Position yC,0 / zC,0 
These two table lines specify the global coordinates of the center of gravity C, with respect 
to the origin (y0 / z0). 

∫ ⋅⋅=
A

00,C dAy
A
1

y    ∫ ⋅⋅=
A

00,C dAz
A
1

z  

Equation 7.5 

Moments of Inertia Iy / Iz / Iyz 
The 2nd moments of area Iy and Iz as well as the centrifugal moment Iyz refer to the section-
related axis system y,z which lies parallel to the global system y0,z0 through the centroid C 
(cf Figure 7.2). 

∫ ⋅=
A

2
y dAzI   ∫ ⋅=

A

2
z dAyI          ∫ ⋅⋅=

A
zy dAzyI  

Equation 7.6 

If the elements of the section feature different materials, the ideal section properties are 
determined as follows: 

( ) ( )
ref

PE,jPEj,,yE,iEi,,y
y E

EIEI
I

∑∑ ⋅+⋅
=  

Equation 7.7 

where Iy,i,E 2nd moment of area of element i with reference to the principal axis y 
(sum of innate moment of inertia and parallel axis theorem component) 

 Ei,E Elastic modulus of the material of element i 

 Iy,j,PE 2nd moment of area of point element j with reference to the principal axis y 
(sum of innate moment of inertia and parallel axis theorem component) 

 Ej,PE Elastic modulus of the material of point element j 

 Eref Elastic modulus of the reference material (cf chapter 4.4.2.2, page 56) 

The ideal moments of inertia Iz and Iyz are determined analogously for composite sections. 

Inclination of Principal Axes α 
The position of the principal axes u and v is defined by the angle α. This is the angle be-
tween the axis y and the axis u which is positively clockwise if the positive direction of the 
axis y0 is to the right. 
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Figure 7.2: Inclination of principal axes 

The angle α is determined from the following equation: 

yz

zy

II

I2
2tan

−

⋅
=α  

Equation 7.8 

The transformation of the principal axes can be controlled indirectly in the Details tab of the 
General Data dialog box (cf Figure 4.37, page 56) which can be called up via menu 

Edit → Section properties → General data. 

With the option to Transform the principal axes such that Iu is always greater than Iv, the 
axis u always represents the major axis, independent of the position of the section. 

Principal Moments of Inertia Iu / Iv 
The 2nd moments of area Iu and Iv refer to the principal axes u and v of the section. 

α⋅−α⋅+α⋅= 2sinIsinIαosII zy
2

z
2

yu  

α⋅+α⋅+α⋅= 2sinIαosIsinII zy
2

z
2

yv  

Equation 7.9 

Polar Moments of Inertia Ip / Ip,M 
The polar 2nd moments of area Ip resp. Ip,M refer to the centroid C resp. the shear center M. 

( ) zy
A A

222
p IIdAzydArI +=⋅+=⋅= ∫ ∫  

( )2
M

2
MpM,p zyII ++=  

Equation 7.10 

If there is a lateral restraint D, the polar 2nd moment of area Ip,D is displayed instead of Ip,M. 

( )2
D

2
DpD,p zyII ++=  

Equation 7.11 

Radii of Gyration iy / iz / iyz / iu / iv / ip / ip,M / iω,M 
The radii of gyration represent important values for the stability analyses of sections that 
are subject to compression. In the following general equation, the index a stands for the 
above-mentioned indices of the various radii of gyration. 

A

I
i a
a =  

Equation 7.12 
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Cross-Section Weight G 
The section weight is the product of the cross-sectional area A of all elements and point el-
ements and the specific weight γ that has been defined in table 1.2 Materials. It is given in 
terms of weight per unit length of the section. 

( ) ( )∑∑ γ⋅+γ⋅= PE,jPEj,E,γEγ, AAG  

Equation 7.13 

The mass is determined with the standard gravity of 9.81 N/kg. 

Cross-Section Perimeters U / Uexternal / Uinternal 
The perimeter U of the section represents the sum of the external and the internal perime-
ters. As the latter is zero for open sections, only the perimeter U is displayed in such cases. 

Torsional Constants J / JSt.Venant / JBredt / Js 
The torsional constant J is the sum of the torsional constants due to ST. VENANT JSt.Venant and 
BREDT JBredt. The latter is zero for open sections. 

Bredt.Ven.St JJJ +=  

Equation 7.14 

For thin-walled sections, the Saint Venant torsional constant is determined as follows. 
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Equation 7.15 

where η Correction factor for ST. VENANT torsional constant (cf Figure 4.37, page 56) 

 li Length of element i 

 t*i Effective thickness of element i for shear transfer 

 t*i,f Effective thickness of element with free end i,f for shear transfer 

 l*i,f Length of element with free end i,f for shear transfer 

The default value of the correction factor η is 1.00. It can be adjusted in the Details tab of 
the General Data dialog box (cf Figure 4.37, page 56). 

The Bredt torsional constant of a single-cell section is determined as follows: 

∫ ⋅

⋅
=

s
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*t
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A4

J  

Equation 7.16 

where Am Cell area bounded by center lines of surrounding elements 

 t* Effective element thickness for shear transfer 

The secondary torsional constant is determined according to the following equation: 

∑ ∑ ⋅⋅
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Equation 7.17 

where Iω,M Warping constant 

 t*i Effective thickness for shear transfer of element i 

 li Length of element i 

 Qω,M Warping statical moment which is required to determine the shear flow 
due to secondary torsional moment Mxs (cf. chapter 7.2, page 106) 

 



7  Results 

 

 

98 Program SHAPE-THIN © 2012 by Ing. Software Dlubal 

Composite Sections If the elements of the section feature different materials, the ideal torsional constants are 
determined as follows: 
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
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Equation 7.18 

where Gref Shear modulus of the reference material (cf chapter 4.4.2.2, page 56)  

 Gi Shear modulus of the material of element i 

 Gi,f Shear modulus of the material of element with free end i,f 
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Equation 7.20 

Shear Center Location yM,0 / zM,0 / yM / zM 
In the shear center M, the moment caused by the shear stress due to a shear force is zero. If 
the shear force acts through the shear center, the section is subjected to bending but not to 
torsional moments so that the member does not undergo any rotation. 

Regarding doubly symmetrical sections, the shear center lies in the intersection of the axes 
of symmetry, i.e. coincides with the center of gravity C. 

The y/z coordinates of the shear center are listed with respect to both the global origin (0/0) 
and the centroid C. The latter are determined as follows: 
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Equation 7.21 

where ( )[ ]s,Cee,Cse,Ces,Csy,C zzzz2A
6
1

R y⋅+y⋅+y⋅+y⋅⋅⋅∆⋅= ∑  

 ( )[ ]s,Cee,Cse,Ces,Csz,C yyyy2A
6
1

R y⋅+y⋅+y⋅+y⋅⋅⋅∆⋅= ∑  

In the equations of RC,y and RC,z, the indices s and e characterize the start resp. end nodes of 
the elements. The normalized warping constants ωC (cf chapter 7.2, page 106) are related 
to the center of gravity C. 

If the coordinates of the shear center are transformed in the following manner, they refer to 
the global zero (0/0): 

0,CM0,M yyy +=  

0,CM0,M zzz +=  

Equation 7.22 
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Composite Sections 

Composite Sections 

Warping Constants Iω,C / Iω,M 
The warping constant is required to determine the warping stresses σx,Mω and vMxs. For the 
warping constant Iω,M, the normalized warping constant about the shear center M is taken 
into account as follows. 

∫ ⋅ω=ω
A

2
MM, dAI  

Equation 7.23 

If there is a lateral restraint, the warping constant Iω,D about the location of this restraint D 
is displayed instead. The warping constants Iω,S, Iω,M, Iω,D with respect to rotation about the 
center of gravity C, the shear center M or the lateral restraint D are defined as follows: 

( )2
e,Ce,Cs,C

2
s,CC, A

3
1

I ω+ω⋅ω+ω⋅∆⋅= ∑ω  

z,CMy,CMC,M, RzRyII ⋅−⋅+= yy  

z,CDy,CDC,D, RzRyII ⋅−⋅+= yy  

Equation 7.24 

The indices s and e characterize the start resp. end nodes of the elements. The normalized 
warping constants ωC (cf chapter 7.2, page 106) are related to the center of gravity C. The 
constants RC,y and RC,z are explained beneath Equation 7.21. 

If the elements of the section feature different materials, the ideal warping constant Iω,C is 
determined as follows: 
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I 2
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ref
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⋅
= ∑ω  

Equation 7.25 

The ideal warping constants Iω,M resp. Iω,D are calculated as for homogenous sections, with 
consideration of the modified ideal auxiliary values: 
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Warp Rotation rω,M 
The auxiliary value for the warp rotation is determined according to the following equation: 
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Equation 7.26 

where ( ) ( )[ ]∫ ⋅−+−⋅ω=ω
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If the elements of the section feature different materials, Rω,M is determined as follows: 
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Equation 7.27 
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Composite Sections 

Composite Sections 

Elastic Section Moduli Su / Sv / Sy / Sz 
By means of the elastic section moduli, the stresses due to bending moments can be calcu-
lated. Those section moduli are related to the principal axes u and v resp. the axes y and z 
that lie parallel to the global system y0 / z0 through the centroid C. 

To determine the maximum or minimum elastic section moduli, the 2nd moments of area 
are divided by the respective positive or negative distances of the outermost element edges 
from the centroid C. The distances are specified in the Comment column. 

minmax/,v

u
minmax/,u e
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minmax/,u

v
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S =  

minmax/,z

y
minmax/,y e

I
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z
minmax/,z e

I
S =  

Equation 7.28 

By applying the ideal 2nd moments of area in these equations, the elastic section moduli can 
be determined for sections with elements that feature different materials.  

Warping Section Modulus Sω,M  
The warping elastic section modulus Sω,M relates to the shear center M. It is determined as 
follows: 

minmax/,M

M,
minmax/,M,

I
S

ω
= ω

ω  resp. 

minmax/,D

D,
minmax/,D,

I
S

ω
= ω

ω  for a section with lateral restraint 

Equation 7.29 

where ωM Normalized warping constant about M (cf chapter 7.2, page 106) 

 Iω,M Warping constant (cf Equation 7.23) 

The nodes of the maximum and minimum values of ωM are stated in the Comment column. 

By applying the ideal warping constant Iω,M, the warping section moduli can be determined 
for sections with elements that feature different materials.  

Torsional Section Modulus St 
When determining the torsional section modulus, it has to be differentiated between open 
sections and closed sections. For open sections, the value of St is determined as follows: 

max
t *t

J
S =  

Equation 7.30 

where t*max Effective maximum thickness for shear transfer of all elements 

For closed sections that include one or more cells, the value of St is calculated according to 
the following equation. 

minmt *tA2S ⋅⋅=  

Equation 7.31 

where Am Cell area bounded by center lines of surrounding elements 

 t*min Effective minimum thickness for shear transfer of all cell elements 
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Section Ranges ry / rz / rMy / rMz 
The section ranges ry and rz are required to calculate the ideal slenderness ratio for lateral 
torsional buckling analyses according to DIN 4114. 
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Equation 7.32 

The section ranges rMy and rMz represent the transformed section ranges according to the 
above Equation 7.32. Those are used for the FEA design in various additional modules of 
RSTAB and RFEM. The section ranges are determined as follows: 

M,yzMy e2rr ⋅−=    M,zyMz e2rr ⋅−=  

Equation 7.33 

Reduction Factor λM 
The reduction factor is required in order to calculate the internal forces and moment due to 
warping. 

M,
M IE

JG

ω⋅
⋅

=λ  resp. 

D,
D IE

JG

ω⋅
⋅

=λ  for a section with lateral restraint 

Equation 7.34 

where G Shear modulus 

 J Torsional constant 

 E Elastic modulus 

 Iω,M Warping constant (cf Equation 7.23) 

When splitting up the torsional moment into its components Mxp and Mxs, the reduction 
factor may be helpful: For small values of λ, the warping component is predominant. For 
large values of λ, however, the St. Venant component prevails. 

Plastic Moment Capacities Mpl,y,d / Mpl,z,d / Mpl,u,d / Mpl,v,d 
In general, the maximum plastic bending moments are determined via the area bisecting 
axes, i.e. without consideration of any interaction formulae. 

The plastic design moment capacities are calculated from the design yield strength and the 
plastic section moduli. 

d,yyd,y,pl fZM ⋅=    d,yzd,z,pl fZM ⋅=  

d,yud,u,pl fZM ⋅=    d,yvd,v,pl fZM ⋅=  

Equation 7.35 

where Zpl Maximum plastic section moduli (see below) 

 fy,d Design value of yield strength 
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Composite Sections 

Composite Sections 

If the elements of the section feature different materials, the ideal plastic moment capaci-
ties are determined by applying the ideal maximum plastic section moduli (see below) and 
the design yield strength of the reference material. 

ref,d,yyd,y,pl fZM ⋅=    ref,d,yzd,z,pl fZM ⋅=  

ref,d,yud,u,pl fZM ⋅=    ref,d,yvd,v,pl fZM ⋅=  

Equation 7.36 

Plastic Section Moduli Zy / Zz / Zu / Zv 
The plastic section moduli are determined by adding the absolute values of the 1st moments 
of area (statical moments) of the various section components about an axis which bisects 
the cross-sectional area. 

bottom,ytop,yy QQZ +=   bottom,ztop,zz QQZ +=  

bottom,utop,uu QQZ +=   bottom,vtop,vv QQZ +=  

Equation 7.37 

The plastic reserve capacities are listed in the Comment column. They represent the ratios of 
the plastic section moduli and the elastic capacities. 
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y
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Z
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Z
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Z
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Equation 7.38 

where ( )min,ymax,yy S,SminS =   ( )min,zmax,zz S,SminS =  

 ( )min,umax,uu S,SminS =   ( )min,vmax,vv S,SminS =  

If the elements of the section feature different materials, the ideal plastic section moduli are 
determined via the area bisecting axes (see below). Those are calculated from the products 
of the areas and yield strengths of elements and point elements. 

For example, the maximum ideal plastic section modulus Zy is determined as follows: 

( ) ( )
ref,d,y

PE,j,d,yPE,j,z,fPE,jE,i,d,yE,i,z,fE,i
y f

feAfeA
Z

∑∑ ⋅⋅+⋅⋅
=  

Equation 7.39 

where Ai,E Area of element i 

 ef,z,i,E Distance of centroid of element i from area bisecting axis fy 

 fy,d,i,E Design yield strength of material of element i 

 Aj,PE Area of point element j 

 ef,z,j,PE Distance of centroid of point element j from area bisecting axis fy 

 fy,d,j,PE Design yield strength of material of point element j 

 fy,d,ref Design yield strength of reference material (cf chapter 4.4.2.2, page 56) 
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Composite Sections 

Composite Sections 

Plastic Shear Areas Apl,y / Apl,z / Apl,u / Apl,v 
The plastic shear areas are determined as follows. 

( )[ ]∑ −⋅= E,i,sE,i,e
(
E,iy,pl yytA   ( )[ ]∑ −⋅= E,i,sE,i,e

(
E,iz,pl zztA  

( )[ ]∑ −⋅= E,i,sE,i,e
(
E,iu,pl uutA   ( )[ ]∑ −⋅= E,i,sE,i,e

(
E,iv,pl vvtA  

Equation 7.40 

where t*
i,E   Effective thickness of element i 

 ye,i,E  resp.  ze,i,E Distance of end of element i from axis z resp. y 

 ys,i,E  resp.  zs,i,E Distance of start of element i from axis z resp. y 

If the elements of the section feature different materials, the ideal shear areas are calculated 
with consideration of the reference material. For example, the ideal shear area Apl,z is deter-
mined as follows. 

dzft
f

1
A

s

0
d,y

*

ref,d,y
z,pl ⋅⋅= ∫  

( )[ ]∑ ⋅−⋅⋅= E,i,d,yE,i,sE,i,e
(
E,i

ref,d,y
z,pl fzzt

f
1

A  

Equation 7.41 

where fy,d,i,E Design yield strength of material of element i 

 fy,d,ref Design yield strength of reference material (cf chapter 4.4.2.2, page 56) 

Area Bisecting Axes Location fy,0 / fz,0 / fu / fv 
When calculating the plastic section properties (cf Figure 4.33, page 53), the area bisecting 
axes are determined iteratively. They are illustrated by dotted lines in the section graphics. 
The intersection point of the axes fy,0 and fz,0 is related to the global zero (0/0), the intersec-
tion point of the axes fu and fv to the center of gravity C. 

The inclination of the area bisecting axes fu and fv corresponds to the principal axes inclina-
tion α. 

Plastic Shear Capacities Vpl,y,d / Vpl,z,d / Vpl,u,d / Vpl,v,d 
The plastic shear capacities are calculated from the shear areas and the design value of the 
yield strength fy,d. 

3

fA
V

d,yy,pl
d,y,pl

⋅
=    

3

fA
V

d,yz,pl
d,z,pl

⋅
=  

3

fA
V

d,yu,pl
d,u,pl

⋅
=    

3

fA
V

d,yv,pl
d,v,pl

⋅
=  

Equation 7.42 

If the elements of the section feature different materials, the ideal plastic shear capacities 
are determined with the yield strength of the reference material. 
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Plastic Axial Force Capacity Npl,d 
The limiting internal force Npl,d represents the sum of the products of areas and design yield 
strengths of all elements and point elements. 

( ) ( )∑∑ ⋅+⋅= PE,j,d,yPE,jE,i,d,yE,id,pl fAfAN  

Equation 7.43 

where Ai,E Area of element i 

 fy,d,i,E Design yield strength of material of element i 

 Aj,PE Area of point element j 

 fy,d,j,PE Design yield strength of material of point element j 

Buckling Curves BCy/u / BCz/v 
For buckling analyses, every section has to be classified to specific buckling curves with re-
spect to the principal axes y and z respectively u and v (cf DIN 18 800 Part 2, Table 5 or 
EN 1993-1-1, Table 6.2). 

The buckling curves mainly depend on the shape of the section. As the program cannot al-
locate the buckling curves automatically for user-defined sections, the buckling curves BCy/u 
and BCz/v are displayed which have been defined in the Details tab of the General Data dia-
log box, cf chapter 4.4.2.2 on page 57. 

7.2 Statical Moments 
The second results table includes the statical moments Qy and Qz (1

st moments of area) as 
well as the normalized warping ordinates ωM and the warping statical moments QωM. 

The distribution of the statical moments and warping ordinates can also be displayed in the 
graphics. 

 
Figure 7.3: Table 2.2 Statical moments and warping statical moments 

If the section consists of elements with different materials, the table header reads Ideal 
Property Distribution inclusive of the Reference Material which has been defined in the 
Details tab of the General Data dialog box (cf chapter 4.4.2.2, page 56). 
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Via the [Filter] button in the table toolbar, the types of results can be selected that are to be 
displayed in this table. 

 
Figure 7.4: Dialog box Show Columns 

Element Number 

All statical moments are listed by elements. 

Node Number 

The statical moments are listed at the start and end nodes of each element. Additionally, 
the values of the following columns are also shown for all element centers. 

Distance s 

This value indicates the distance of a particular location from the start node of the element. 

Ordinates y, z, u, v 

In these four columns, the ordinates of all element locations are listed. They are related to 
the global axes y and z or the principal axes u and v, with reference to the centroid C. 

Statical Moments Qy / Qz / Qu / Qv 

The statical moments (1st moments of area) are listed with reference to the global axes y 
and z or the principal axes u and v of the section. The statical moment is defined as the 
product of dA and the distance from its centroid to a reference axis that lies in the plane of 
the section. 

  

  

Equation 7.44 

where z  resp.  y Distance from the elemental area centroid to axis y resp. z 

 v  resp.  u Distance from the elemental area centroid to axis u resp. v 

The statical moments are required to determine the shear stresses due to the shear forces Vy 
and Vz. The element direction, which is defined by the order of the start and end nodes, has 
an effect on the sign of the statical moments. 
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Composite Sections 

Composite Sections 

If the elements of the section feature different materials, the ideal statical moments are 
determined as follows: 

dAEz
E
1

Q
Aref

y ⋅⋅⋅= ∫   dAEy
E
1

Q
Aref

z ⋅⋅⋅= ∫  

Equation 7.45 

where Eref Elastic modulus of the reference material (cf chapter 4.4.2.2, page 56) 

The ideal statical moments Qu and Qv are determined analogously. 

Maximum Statical Moments Qy,max / Qz,max / Qu,max / Qv,max 

In these four columns, the maximum statical moment (top value) and its location (second 
value) can be read for each element. The location s represents the distance of the maximum 
value from the start node of the element. 

Warping Ordinates ωM 

The normalized warping constants ωM about the shear center M are geometrical quantities. 
They are required to determine the stresses σx,Mω and vMxs caused by warping restraint. For 
thin-walled, open sections, the warping ordinates are defined as follows. 

∫ ⋅=ω
s
MM dsr  

Equation 7.46 

where rM Perpendicular distance of the element from shear center M 

With warp-free sections, the normalized warping ordinates are zero. If there is a lateral re-
straint, the warping ordinates ωD about the point of rotation D are listed. 

Warping Statical Moments Qω,M  
The warping statical moment is determined from the normalized warping constants ωM. 

dAQ
A

MM, ⋅ω= ∫ω  

Equation 7.47 

where ωM Warping constant of the elemental area about shear center M 

The warping statical moments are zero with warp-free sections. If there is a lateral restraint, 
the warping statical moments Qω,D about the point of rotation D are listed. 

If the elements of the section feature different materials, the ideal warping statical moment 
is determined as follows: 

dAE
E
1

Q
A

M
ref

M, ⋅⋅ω⋅= ∫ω  

Equation 7.48 

where Eref Elastic modulus of reference material (cf chapter 4.4.2.2, page 56) 

Cell Areas Am 
For closed sections, the areas of the cells are specified for every element. They are deter-
mined from the thicknesses and the locations of the respective elements. 

With single-cell sections, Am is identical to the cell area bounded by the center lines of the 
surrounding elements. 
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7.3 Normal Stresses σx 
In this results table, the various normal stresses σx are listed for every Location x that has 
been defined in table 1.7 Forces and moments (cf chapter 5.7, page 84). 

The sign rules are illustrated in Figure 5.33 on page 86. 

This table lists the stresses of the Effective Section if the effective cross-section design has 
been chosen in the General tab of the General Data dialog box (cf chapter 4.4.2.1, page 
54). 

The Extremes can be read at the end of the list for each location x. 

The list is concluded by the overall maximum and minimum stresses Σ σx of all locations x. 

 
Figure 7.5: Table 3.1 Normal stresses 

Element Number 

For every location x, the normal stresses are listed by element numbers. Stresses in point 
elements are not covered by the analysis. 

Node Number 

The normal stresses are listed at the start and end nodes of each element. Additionally, the 
values of the following columns are also shown for all element centers. 

Distance s 

This value indicates the distance of a particular location from the start node of the element. 

LC Number 

In this column, the number of the respective load case is shown. 

σx,N 

A
N

N,x =σ  

Equation 7.49 

where N Axial force 

 A Cross-sectional area 
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Shear Wall Sections 

 

σx,Mu 

v
u

u
Mu,x e

I

M
⋅=u  

Equation 7.50 

where Mu Bending moment about principal axis u 

 Iu Principal moment of inertia (2nd moment of area) about axis u 

 ev Distance from center of gravity in direction of principal axis v 

The reference of the internal forces is controlled in the Details tab of the General Data dia-
log box (cf. Figure 4.37, page 56) which can be called up via menu 

Edit → Section properties → General data. 

σx,Mv 

u
v

v
Mv,x e

I
M

⋅−=u  

Equation 7.51 

where Mv Bending moment about principal axis v 

 Iv Principal moment of inertia (2nd moment of area) about axis v 

 eu Distance from center of gravity in direction of principal axis u 

The negative sign in Equation 7.51 results from the correlation of the internal forces to the 
RSTAB or RFEM program. A positive moment effects tensile stresses in the strained fiber of 
the beam, i.e. the stresses are positive. This RSTAB convention was transferred to SHAPE, 
too, in order to obtain consistent signs in e.g. STEEL and SHAPE after having imported the 
internal forces. Thus, unit moments might be useful to check on the effects of the signs. 

For shear wall sections, the normal stresses due to the bending moments Mu and Mv are 
calculated as follows. 

( )
2

uvvu

vvuvuv
Mu,x

III

eMIMI

−⋅

⋅⋅+⋅
=u   

( )
2

uvvu

uuuvvu
Mv,x

III

eMIMI

−⋅

⋅⋅+⋅
=u  

Equation 7.52 

where Iu, Iv, Iuv 2nd moments of area about total center of gravity 

 eu, ev Distances from centroid Ci of partial section i 

σx,Mω  

M
M,

M,x I

M
ω⋅−=σ

ω

ω
ω  

Equation 7.53 

where Mω Warping bimoment 

 Iω,M Warping constant about shear center M 

 ωM Warping constant of the elemental area about shear center M 

If there is a lateral restraint, the warping stresses about the point of rotation D are listed. 
Those are determined with the values of Iω,D and ωD. 

Σ σx 
In this column, the individual components of the normal stresses are added. 

ωσ+σ+σ+σ=σ∑ M,xMv,xMσ,xN,xx  

Equation 7.54 
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Composite Sections 

 

 

Limit σx 

This column lists the allowable normal stresses of each material as defined e.g. in column F 
of table 1.2 (cf Figure 5.10, page 68). 

Stress Ratio 
The last column contains the ratios of existing stresses to limit stresses. Thus, the user is 
able to quickly check on the utilizations at the various locations x of the section. 

Via the button [Show columns], the stresses due to the corresponding moments My and Mz 
(resp. Mu and Mv) can be activated. In a specific dialog box, the transformed moments are 
also accessible. 

 
Figure 7.6: Dialog box Show columns 

σx,My / σx,Mz 

   

Equation 7.55 

where My / Mz Bending moment about section-related global axis y resp. z 

 Iy / Iz Principal moment of inertia (2nd moment of area) about axis y resp. z 

 ez / ey Distance from center of gravity in direction of global axis z resp. y 

It is possible to select specific results via the filter function. The following dialog box ap-
pears. 

 
Figure 7.7: Dialog box Display Table Rows 

If the elements of the section feature different materials, the stresses are independent of 
the selected reference material. Internally, this is effectuated by multiplying the normal 
stresses of element i by Ei / Eref, i.e. the ratio of the elastic moduli of element i and of the 
reference material. 
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7.4 Shear Stresses v 
In this results table, the various shear stresses v are listed for every Location x that has been 
defined in table 1.7 Forces and moments (cf chapter 5.7, page 84). 

The Extremes can be read at the end of the list for each location x. The list is concluded by 
the overall maximum shear stresses Σ v of all locations x. 

 
Figure 7.8: Table 3.2 Shear stresses 

Element Number 
For every location x, the shear stresses are listed by element numbers. Stresses in point ele-
ments are not covered by the analysis. 

Node Number 

The shear stresses are listed at the start and end nodes of each element. Additionally, the 
values of the following columns are also shown for all element centers. 

Distance s 

This value indicates the distance of a particular location from the start node of the element. 

LC Number 

In this column, the number of the respective load case is shown. 

vVu 

*tI

QV

v

vu
Vu ⋅

⋅
−=v  

Equation 7.56 

where Vu Shear force in direction u 

 Qv Statical moment (1st moment of area) related to axis v 

 Iv Principal moment of inertia (2nd moment of area) about axis v 

 t* Effective element thickness for shear transfer 
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vVv 

*tI

QV

u

uv
Vv ⋅

⋅
−=v  

Equation 7.57 

where Vv Shear force in direction v 

 Qu Statical moment (1st moment of area) related to axis u 

 Iu Principal moment of inertia (2nd moment of area) about axis u 

 t* Effective element thickness for shear transfer 

For the shear stresses of non-coherent shear wall sections, see equation Equation 7.78 in 
chapter 7.9 on page 126. 

vMxp,St.Venant 

To determine the shear stresses due to primary torsion, the torsional moment Mxp is split up 
into its St. Venant component Mxp,St.Ven. and its Bredt component Mxp,Bredt. 

J

J
MM .Ven.St

xp.Ven.St,xp ⋅=   
J

J
MM Bredt

xpBredt,xp ⋅=  

Equation 7.58 

where Mxp Primary torsional moment 

 JSt.Ven. St. Venant torsional constant 

 JBredt Bredt torsional constant 

 J Total torsional constant (i.e. sum of JSt.Ven. and JBredt) 

For thin-walled sections, the torsional shear stress due to St. Venant’s theory are linearly 
variable over the element thickness, i.e. zero in the element center line to the extremum at 
the element edge. In these table columns, only the extrema of the shear stresses at the ele-
ment edges are listed. 

*t
J

M

.Ven.St

.Ven.St,xp
.Ven.St,Mxp ⋅=τ  

Equation 7.59 

where Mxp,St.Ven.  St. Venant component of the primary torsional moment 

 JSt.Ven.  St. Venant torsional constant 

 t*  Effective element thickness for shear transfer 

vMxp,Bredt 
Concerning closed sectional parts with cells, the torsional shear stresses due to Bredt’s the-
ory are calculated as follows. 

*tA2

M

m

Bredt,xp
Bredt,Mxp ⋅⋅

=τ  

Equation 7.60 

where Mxp,Bredt  Bredt component of the primary torsional moment 

 Am  Cell area bounded by center lines of surrounding elements 

 t*  Effective element thickness for shear transfer 
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For sections that consist of several cells, the torsional moment is allocated as follows. 

m

i,m
xpi,xp A

A
MM ⋅=  

Equation 7.61 

If an element represents the web between two neighboring cells, the shear flow directions 
of the respective cells sharing the common element are opposed when the section is sub-
jected to a torsional moment. Thus, the shear stresses due to torsion are rather small there. 

vMxs 

The shear stresses due to the secondary torsional moment Mxs are determined as follows. 

*tI

QM

M,

M,xs
Mxs ⋅

⋅
−=τ

ω

ω  

Equation 7.62 

where Mxs Secondary torsional moment 

 Qω,M Warping statical moment (cf chapter 7.2, page 106) 

 Iω,M Warping constant about shear center M (cf chapter 7.1, page 99) 

 t* Effective element thickness for shear transfer 

If there is a lateral restraint, the shear stresses about the point of rotation D are listed. 
Those are determined with the values of Qω,D and Iω,D. 

For the shear stresses of non-coherent shear wall sections, see Equation 7.78 in chapter 7.9 
on page 126. 

Σ v  
In this column, the individual components of the shear stresses are added. As for the share 
of St. Venant torsional stresses, the sign will be applied that increases the absolute value of 
the sum. 

MxsBredt,Mxp.Ven.St,MxpVvVu v+v+v±v+v=v∑  

Equation 7.63 

Limit v 

This column lists the allowable shear stresses of each material as defined e.g. in column G 
of table 1.2 (cf Figure 5.10, page 68). 

Stress Ratio 
In this column, the ratios of existing stresses to limit stresses are listed. Thus, the user is able 
to quickly check on the utilizations at the various locations x of the section. 

Shear Force V 
The last column contains the integrals of the shear forces in all elements due to the shear 
stresses. The resulting shear forces of each element are determined as follows: 

l*tV ⋅⋅τ=  

Equation 7.64 

where v Shear stresses in element 

 t* Effective element thickness 

 l Element length 
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In the graphics, these integrals of each element can be activated via menu 

Results → Shear forces. 

 
Figure 7.9: Shear stresses (left) and shear forces as integrals (right) 

The shear stresses due to the primary torsional moment Mxp,St.Ven. are not considered in this 
integration for open cross-sections, however. It would result in zero values when integrat-
ing over both the element lengths and element thicknesses. 

Via the button [Show columns], the shear tresses due to the corresponding forces Vy and Vz 
(resp. Vu and Vv) can be activated. In a specific dialog box, the transformed shear forces are 
also accessible. 

 
Figure 7.10: Dialog box Show columns 

vVy / vVz 

  

Equation 7.65 

where Vy / Vz Shear force in section-related global direction y resp. z 

 Qz / Qy Statical moment (1st moment of area) related to axis z resp. y 

 Iz / Iy Principal moment of inertia (2nd moment of area) about axis z resp. y 

 t* Effective element thickness for shear transfer 
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Composite Sections 

 
It is possible to select specific results via the filter function. The button as seen to the left 
calls up the dialog box Display Table Rows (cf Figure 7.7, page 109). 

If the elements of the section feature different materials, the stresses are independent of 
the selected reference material. Internally, this is effectuated by multiplying the shear 
stresses of element i by Gi / Gref, i.e. the ratio of the shear moduli of element i and of the 
reference material. 

7.5 Equivalent Stresses σeqv 
In this table, the equivalent stresses σeqv and stress ratios are listed for every Location x that 
has been defined in table 1.7 Forces and moments. 

The Extremes can be read at the end of the list for each location x. The list is concluded by 
the overall maximum stresses σeqv of all locations x. 

 
Figure 7.11: Table 3.3 Equivalent stresses 

Element Number 

For every location x, the stresses are listed by element numbers. Stresses in point elements 
are not covered by the analysis. 

Node Number 

The stresses are listed at the start and end nodes of each element and at all element 
centers. 

Distance s 

This value indicates the distance of a particular location from the start node of the element. 

LC Number 

In this column, the number of the respective load case is shown. 

Σ σx 
This column represents the sums of all normal stresses as shown in column H of table 3.1 
Normal stresses (cf Figure 7.5, page 107). 
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Σ v  
This column represents the absolute values of the sums from all shear stresses as they are 
listed in column I of table 3.2 Shear stresses (cf Figure 7.8, page 110). 

σeqv 

The equivalent stresses are determined with consideration of the yield criteria specified in 
the Details tab of the General Data dialog box (cf chapter 4.4.2.2, page 57). 

 

Equation 7.66 

where f Factor to account for shear stresses 

For the weld design, please note that SHAPE covers the planar state of stresses. Thus, the 
shear stresses of longitudinal seams of welds v have to be taken into account additionally. 

Limit σeqv 
In this column, the existing equivalent stresses are compared to the allowable equivalent 
stress of the material as defined e.g. in column H of table 1.2 (cf Figure 5.10, page 68). 

Stress Ratio 
The last column contains the ratios of existing stresses to limit stresses. Thus, the user is 
able to quickly check on the utilizations at the various locations x of the section. 

Via the button [Show columns], the transformed moments My and Mz (resp. Mu and Mv) 
and shear forces Vy and Vz (resp. Vu and Vv) can be activated in a specific dialog box. 

 
Figure 7.12: Dialog box Show columns 

It is possible to select specific results via the filter function. The button as seen to the left 
calls up the dialog box Display Table Rows (cf Figure 7.7, page 109). 
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7.6 Plastic Capacity 
If the plastic capacity design has been enabled in the General Data dialog box, the results 
table 4.1 Plastic capacity is presented after the analysis. 

Column J with the enlargement factor αplastic represents the most important column of this 
table. If all values are greater than 1.0, the plastic design is verified. 

 
Figure 7.13: Table 4.1 Plastic capacity 

LC Number 

The results of the plastic capacity design are listed by load cases. 

Location x 
The results are stated for the combined loading conditions of every Location x that has been 
defined in table 1.7 Forces and moments (cf chapter 5.7, page 84). 

Internal Forces N / Vu / Vv / Mxp / Mxs / Mu / Mv / Mω 

In these eight columns, the internal forces and moments are imported from table 1.7 Forces 
and moments (cf chapter 5.7, page 84). 

Enlargement Factor αplastic 

The enlargement factor α implies that the plastic capacity of the section is attained if all in-
ternal forces and moments of the respective location x are uniformly multiplied with it. 

Any combination of internal forces as a result of the plastic analysis can be described by the 
following vector. 

{ }xsxpvuvu M,M,V,V,M,M,M,NF ω=  

Equation 7.67 

For the plastic design of this vector, a constant relationship of its components is assumed. 
Thus, the vector F of the internal forces is extended to the yield area by the enlargement 
factor α. This factor is determined as the maximum of a linear optimization using a revised 
simplex algorithm. Depending on the yield criteria (cf chapter 4.4.2.2, page 57), the equa-
tion for the equivalent stress (cf Equation 7.66) results in an ellipse which can be approxi-
mated by an octagon during a linear optimization process. 

 



7  Results 

 117 Program SHAPE-THIN © 2012 by Ing. Software Dlubal 

 

 
Figure 7.14: Linear optimization of the yield criteria 

The section is discretized in small sub-elements. When the integration over the section to 
determine the internal forces is replaced by the addition over discrete values, the equilibri-
um conditions for the normal stresses σx can be described as follows. 

( ) 0NArr,x =⋅α−⋅σ∑  

( ) 0MeA ur,vrr,x =⋅α−⋅⋅u∑  

( ) 0MeA vr,urr,x =⋅α+⋅⋅u∑  

( ) 0MA rrr,x =⋅α+ω⋅⋅σ∑ ω  

Equation 7.68 

where σx,r   Normal stress in sub-element r 

 Ar   Area of sub-element r 

 ev,r  / eu,r   Centroid coordinate of sub-element r related to the principal axes 

 ωr   Warping constant of the sub-element about shear center M 

 α   Enlargement factor as variable for optimization 

 N / Mu / Mv / Mω Internal forces as specified in table 1.7 Forces and moments 

The shear stresses are imported from the previous elastic design (cf chapter 7.4, page 110). 
Thus, the shear stresses v in the centroids of the sub-elements represent input parameters 
of the linear optimization, whereas the enlargement factor α and the normal stresses σx,r in 
the centroids of the sub-elements are explicit variables for the optimization. 

The further conditions of the optimization task can be set for each sub-element. They are 
dependent on the yield criteria and take into account the assumed linearization of the yield 
criteria (cf Figure 7.14). According to the yield criteria of VON MISES, the following interaction 
formulae are applied. 

( ) d,yrr,x f312 ≤⋅−⋅τ⋅α+σ  

( ) d,yrr,x f312 ≤⋅−⋅τ⋅α+σ−  

( ) d,yrr,x f312 ≤⋅τ⋅α+−⋅σ  

( ) d,yrr,x f312 ≤⋅τ⋅α+−⋅σ−  

Equation 7.69 
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According to the yield criteria of TRESCA, the interaction formulae are as follows. 

( ) d,yrr,x f212 ≤⋅−⋅τ⋅α+σ  

( ) d,yrr,x f212 ≤⋅−⋅τ⋅α+σ−  

( ) d,yrr,x f212 ≤⋅τ⋅α+−⋅σ  

( ) d,yrr,x f212 ≤⋅τ⋅α+−⋅σ−  

Equation 7.70 

where σx,r  Normal stress in sub-element r 

 vr  Shear stress in sub-element r 

 α  Enlargement factor as variable for optimization 

 fy,d  Design value of yield stress (cf chapter 5.2, page 69) 

Thus, Equation 7.68 and Equation 7.69 resp. Equation 7.70 represent the linear auxiliary 
conditions for a linear optimization process with the following target function. 

( ) MaximumT =α=α  

Equation 7.71 

As a result of the linear optimization, the factor α (which determines the plastic capacity of 
the section as the product of α · F) and the plastic stresses in every sub-element r are deter-
mined. 

The plastic normal stress σx,pl,r represents precisely the normal stress σx,r that turns out as the 
explicit optimization variable for the sub-element r. 

r,xr,pl,x σ=σ  

Equation 7.72 

The plastic shear stress vpl,r is the product of the enlargement factor α and the elastic shear 
stress vr (i.e. the result of the previous elastic design) in the centroid of the sub-element r. 

rr,pl τ⋅α=τ  

Equation 7.73 

The plastic equivalent stress σeqv,pl,r is dependent on the selected yield criteria. According to 
the theory of VON MISES, it is determined for the sub-element r as follows. 
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Equation 7.74 
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According to the yield criteria of TRESCA, the following investigation is applied. 
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Equation 7.75 

Unutilized Reserve 
In the last column, the percentaged share of those sectional parts is shown that do not 
plastify completely, i.e. the Simplex elements in which the yield stress is not reached for the 
combined loading condition in question. 
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7.7 Check of c/t Zones  
If the comparison with the limiting c/t zones according to DIN 18800 has been enabled in 
the General Data dialog box, the table 5.1 Check of c/t zones is presented after the analysis. 
The results are listed for every Location x as defined in table 1.7 Forces and moments (cf 
chapter 5.7, page 84). 

The Governing values of all load cases and locations x can be read at the end of the list. 

 
Figure 7.15: Table 5.1 Check of c/t zones 

Zone Number 
For every location x, the c/t ratios are listed by numbers of the c/t zones. The zones are 
made up of elements connected in a definable ‘straight’ line. In the General data dialog 
box, the settings when to create end restraints of the c/t zones can be controlled (cf Figure 
4.43, page 60). 

LC Number 
In this column, the number of the respective load case is shown. 

Elements 
This column lists all elements that belong to each c/t zone. 

Restraint Type 
This column gives information on the restraints of each c/t zone as per definition in table 
1.6 c/t Zones (cf chapter 5.6, page 82). They can be supported on one side only (outstand 
flange) or on both sides (internal compression part). 

Subtracted Length ∆Start / ∆End 

In these two columns, the distances of the restraint from the start resp. end nodes of the 
relevant elements are listed. Those values correspond to the lengths as defined in columns E 
and F of table 1.6 c/t Zones (cf chapter 5.6, page 82). 

Width c 

The total width of a c/t zone is made up of the lengths of all contained elements which is 
reduced by the subtracted lengths at the start and end of this zone. 
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Thickness t 
The thickness is defined as the smallest thickness of all elements which are integral parts of 
the c/t zone. 

Existing c/t 
In this column, the resulting width-to-thickness ratios are listed. If the c/t zone is subject to 
tensile stresses, the remark No compression is indicated instead. 

Limiting c/t 
This column gives information on the limiting value of the c/t ratio which depends on the 
selected design method (cf chapter 4.4.2.4, page 60). The limiting values are determined 
according to the following tables of DIN 18800 Part 1. 

• Elastic-Elastic: Tables 12, 13 and 14 

• Elastic-Plastic: Table 15 

• Plastic-Plastic: Table 18 

Ratio 
By dividing the values of the existing c/t ratio by the limiting c/t ratio, the overall utilization 
ratio of every c/t zone is determined. 

σx,Start / σx,End 
These two columns are only presented for the Elastic-Elastic design method. They give in-
formation on the elastic normal stresses at the start resp. end nodes of each c/t zone. 

ψ 
This column contains the ratio of the values from the two previous columns. If there are 
tensile stresses at both ends, no values of the stress ratio are determined. 

kσ 

As before, this column is only presented for the Elastic-Elastic design method. It includes 
the auxiliary values for further analyses that are based on the ratio ψ of each c/t zone with 
compressive stresses. 

v 
This column is only available for the Elastic-Elastic design method with consideration of the 
shear stresses according to the BEUTH comment. It gives information on the maximum shear 
stresses of each c/t zone. 

Qu,m / Qv,m 
These columns are also only available for the Elastic-Elastic design method with considera-
tion of the shear stresses according to the BEUTH comment. They contain the mean statical 
moments (absolute values) related the principal axes u and v of each c/t zone. 

α 
This column is only presented if the Elastic-Plastic or Plastic-Plastic design method has been 
chosen (cf chapter 4.4.2.4, page 60). It gives information on the compression zone factor of 
each c/t zone, i.e. the ratio of compressive width to total width. 
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7.8 Shear Wall Section Properties 
This results table lists the sectional characteristics for the constituent components of a shear 
wall section. 

 
Figure 7.16: Table 6.1 Shear wall section properties 

Before the analysis, SHAPE checks whether all elements of the section are rigidly connected 
to each other and thus constitute an interconnecting cross-section. If this is not the case, a 
warning appears (cf Figure 6.3, page 91) and asks whether the calculation should be done 
according to the theory of stiffening shear walls. According to this approach, the individual 
shear walls (braced panels) are assumed as shear-flexible which are tied to each other via 
floors or beams. The sectional properties and stresses are calculated in a different manner 
than for coherent sections. 

The analytical approach of shear wall systems can also be applied for sectional parts that 
feature different materials and are combined without the facility to transfer shear forces. 
The design of those shear-flexible composite sections results in the ideal section properties 
with the proportionate stresses. 

 
Figure 7.17: Ideal section properties and normal stresses of shear-flexible composite section 
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If the non-coherent section consists of elements with different materials, the header of ta-
ble 2.1 reads “Ideal Section Properties” inclusive of the reference material which has been 
defined in the Details tab of the General Data dialog box (cf chapter 4.4.2.2, page 56). 

Shear Wall Number 
A shear wall can be comprised of a single element or of several interconnected elements. 
Each shear wall is assigned a number whose Constituent Elements are shown in the final 
column. 

Shear Center yM,0 / zM,0 

In these two columns, the shear center coordinates of each shear wall are listed which are 
related to the global origin (0/0). In the graphics, the individual shear centers are labeled as 
M1, M2 etc. 

Moments of Inertia Iy / Iz / Iyz 

The 2nd moments of area and the centrifugal moment are presented individually for each 
shear wall of the non-connecting section. The moments of inertia refer to the section-
related axis system y,z which lies parallel to the global system y0,z0 through the centroid C. 
This table does not provide any principal 2nd moments of area for each shear wall section. 

Please note that the sum of the moments of inertia is determined without the parallel axis 
theorem component Ai · ei

2. 

Torsional Constants JSt.Venant / JBredt 
In these two columns, the torsional constants due to ST. VENANT (open sectional parts) and 
BREDT (closed cells) are listed for each shear wall. The last line presents the sums of all indi-
vidual values. 

Warping Constant Iω 

For each shear wall, the warping constant is displayed which is related to the shear center 
Mi of every individual shear wall. 

Contained Elements 
In the last column, all elements are listed that set up the respective shear wall. 

 



7  Results 

 

 

124 Program SHAPE-THIN © 2012 by Ing. Software Dlubal 

7.9 Shear Forces 
The shear forces that are listed in this table are related to the individual parts of the non-
coherent section. They are used to determine the shear stresses due to the internal forces of 
every Location x that has been defined in table 1.7 Forces and moments. 

 
Figure 7.18: Table 6.2 Shear wall shear forces 

Shear Wall Number 
The shear forces of the following columns are listed by the shear wall numbers of table 6.1 
Shear wall section properties. The Contained Elements of each shear wall are shown in the 
final column. 

Load Case Number 

In this column, the number of the respective load case is shown. 

Forces due to Bending Vy / Vz 
The force of every shear wall i due to the shear force that acts in direction of the centroidal 
axis y or z is determined as follows. 
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Equation 7.76 

where Vy / Vz Shear forces in direction of global centroidal axes y or z (transformed 
if entered in directions of principal axes u or v) acting on total section 

 Vy,i / Vz,i Shear forces of shear wall i in directions y or z 

 Iy,i / Iz,i / Iyz,i 2nd moments of area of shear wall I, related to global axes in centroid 
of shear wall Ci 

 Iy / Iz 2nd moments of area about axes y or z, related to total center of grav-
ity C 

This table does not provide any forces that are related to the prinicipal axes u and v. 



7  Results 

 125 Program SHAPE-THIN © 2012 by Ing. Software Dlubal 

 

Composite Sections 

Forces due to Torsion Vy / Vz 
In these two columns, the torsional constants due to ST. VENANT (open sectional parts) and 
BREDT (closed cells) are listed for each shear wall. The last line presents the sums of all indi-
vidual values. 
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Equation 7.77 

where Mxs  Total secondary torsional moment 

 Vy,i resp. Vz,i Shear force of shear wall i in direction y resp. z 

 Iy,i / Iz,i / Iyz,i 2nd moments of area of shear wall i related to the global axes in 
centroid Ci of shear wall i  

 Iω,i Warping constant of shear wall i related to shear center Mi of shear 
wall i 

 yM,i resp. zM,i Global coordinate of shear center Mi of shear wall i 
 yM resp. zM Global coordinate of overall shear center M 

 n  Number of shear walls in overall section 

Usually, there are large distances between the individual shear wall components. Thus, the 
warping torsion assumes the much larger portion of the total torsional moment. Although 
the forces due to the primary torsional moment are calculated internally, they are not listed 
in this table. Strictly speaking, those results are rather torsional moments than forces. This 
means that the primary torsional moment accordingly causes the primary torsional moment 
Mxp,i in each section wall i (split into the ST. VENANT and BREDT components) and, therefore, 
no shear forces Vy,i resp. Vz,i. 

If the elements of the section feature different materials, the 2nd moments of area and the 
warping constant are replaced by the products of the 2nd moments of area resp. warping 
constant and the respective elastic moduli (Equation 7.76 and Equation 7.77). 

Forces due to Bending and Torsion Vy / Vz 
In these two columns, the sums of the shear forces due to bending and torsion are shown. 
They are provided for each shear wall component in the respective y and z directions. 

Contained Elements 
In the last column, all elements are listed that set up the respective shear wall. 
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Shear Stress Design of Shear Walls 
The shear forces Vy,i and Vz,i are related to the shear center Mi of every individual shear wall 
component i. With those shear forces, the shear stresses v are determined for every shear 
wall as follows. 

*tI
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i,z

i,zi,y
i,Vy ⋅

⋅
−=τ    

*tI

QV

i,y

i,yi,z
i,Vz ⋅

⋅
−=τ  

Equation 7.78 

where Vy,i / Vz,i  Shear force of shear wall i in direction y resp. z 

 Qz,i / Qy,i 1st moments of area of shear wall i related to the global axes in 
centroid Ci of shear wall i  

 Iy,i / Iz,i 2nd moments of area of shear wall i related to the global axes in 
centroid Ci of shear wall i 

 t*  Effective element thickness for shear transfer 

As for the primary torsional moment Mxp, the ST. VENANT and BREDT components are allocat-
ed to each shear wall according to the torsional stiffnesses. 

J

J
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Equation 7.79 

The shear stresses v can then be determined for each shear wall i and for the entire section. 
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i,Venant.St,Mxp ⋅=τ  

Equation 7.80 

where Mxp,St.Venant,i St. Venant torsional moment of shear wall i 

 JSt.Venant,i St. Venant torsional constant of shear wall i 

 t* Effective element thickness for shear transfer 

 Mxp St. Venant torsional moment of overall shear wall section 

 J St. Venant torsional constant of overall section (i.e. sum of 
St. Venant and Bredt components of all shear walls) 

Concerning closed sectional parts with cells of a shear wall, the torsional shear stresses due 
to Bredt’s theory are calculated as follows. 

*tA2
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i,Bredt,xp
i,Bredt,Mxp ⋅⋅
=τ  

Equation 7.81 

where Mxp,Bredt,i   Bredt component of the primary torsional moment of shear wall i 

 Am,i   Cell area bounded by center lines of shear wall i 

 t*   Effective element thickness for shear transfer 
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7.10 Classification 
The results table 5.1 Classification of the Cross-Section is displayed if the calculation of the 
effective cross-sections has been carried out according to the EN 1993-1 standard. In this 
table, the results of the current Load Case at the selected Location x are shown, i.e. the load 
case and location which are set in the menu bar. Those can be changed via the lists or the 
buttons [] in the toolbar as seen to left. 

If the effective cross-section properties have been analyzed according to DIN 18800, the re-
sults table 5.1 Check of c/t zones is displayed instead of the Classification table. This table is 
described in chapter 7.7 on page 120. 

 
Figure 7.19: Table 5.1 Classification of the Cross-Section 

Zone No. 
The results are listed by zone numbers, i.e. elements connected in a definable ‘straight’ line. 
In the General data dialog box, the settings when to create end restraints of the c/t zones 
can be controlled (cf Figure 4.44, page 61). 

Elements 
All elements that belong to the c/t zone are listed in this input field of the dialog box or 
table. 

Restraint Type 
This column gives information on the restraints of each c/t zone as per definition in table 
1.6 c/t Zones (cf chapter 5.6, page 82). They can be supported on one side only (outstand 
flange) or on both sides (internal compression part). 

Subtracted Length ∆Start / ∆End 
In these two columns, the distances of the restraint from the start resp. end nodes of the 
relevant elements are listed. Those values correspond to the lengths as defined in columns E 
and F of table 1.6 c/t Zones (cf chapter 5.6, page 82). 

Width c 
The total width of a c/t zone is made up of the lengths of all contained elements which is 
reduced by the subtracted lengths at the start and end of this zone (e.g. fillets). 
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Thickness t 
The thickness is defined as the smallest thickness of all elements which are integral parts of 
the c/t zone. 

Description 
In this column, the various parameters are listed that are essential to classify the cross-
section. 

Normal Stresses σx,Start / σx,End 
These two lines give information on the normal stresses at the start resp. end nodes of each 
c/t zone. Please note that those are the stresses of the original cross-section. Tensile stresses 
are positive, compressive stresses negative (i.e. inverse to the definition in EN 1993-1-1). 

Boundary Stresses σ1 / σ2 
These stresses are determined from the normal stresses. σ1 is the maximum value of stress 
at either the start node or the end node of the c/t zone. Accordingly, σ2 represents the min-
imum value of both stresses. 

Stress Ratio ψ 
This line contains the ratio of the values from the two previous lines. If there are tensile 
stresses at both ends, no values of the stress ratio are determined. 

Material Factor ε Dependent on fy 
According to Table 5.2 in EN 1993-1-1, the material factor is determined as follows: 

yf
235

=ε  

Equation 7.82 

Compression Zone Factor α 
The compression zone factor describes the ratio of compressive width to total width of each 
c/t zone. 

c/t Zone Values c/t 
In this line, the resulting width-to-thickness ratios are listed. If the c/t zone is subject to ten-
sile stresses, the remark No compression is shown instead. 

Limiting Proportions λ1 / λ2 / λ3 
The limiting proportions of each c/t zone depend on the restraint type (internal compression 
part or outstand flange) and on the stress distribution (bending or/and compression). In the 
respective equations of Table 5.2 in EN 1993-1-1, the parameters ε, α and ψ are considered 
accordingly. 

λ1 represents the limit value for Class 1 cross-sections, λ2 the limit value for Class 2 cross-
sections and λ3 the limit value for Class 3 cross-sections. 
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Figure 7.20: Table 5.2 in EN 1993-1-1 

Symbol 
This column lists the symbols that are associated with the previous descriptions of the pa-
rameters. 

Value 
In this column, the values of the various parameters are listed. 

Unit 
This column contains the units of all relevant values. 

Class of the Element 
In consideration of the limiting proportions λ, the elements of each zone are allcocated to 
Class 1, 2 , 3 or 4. 

Class of the Cross-Section 
According to EN 1993-1-1, 5.5.2 (6), the cross-section is classified in accordance with the 
least favorable class of its compression parts. 
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7.11 Effective Widths 
During the analysis, a new effective cross-section is created from the initial cross-section. 
This is carried out separately for every location x of every load case. New nodes and ele-
ments are created for every effective cross-section. Those are numbered independently of 
the node or element numbering of the original section. The new elements lie either entirely 
or only partially on the center lines of the original elements. 

After the analysis the cross-section properties, the statical moments, warping ordinates and 
stresses are listed in the respective results tables with reference to the current effective 
cross-section, i.e. location x of the active load case. Creating the effective cross-section, 
however, does not affect the input tables 1.1 to 1.7. They contain only the data that are 
related to original cross-section. 

The analysis of the effective cross-section takes no notice of section properties that would 
not make sense on the basis of this model, e.g. the “effective“ cross-section weight or pe-
rimeter. In the same way, no plastic cross-section properties are determined when analyzing 
the effective cross-sections. 

You can activate the Load Case or Location x whose results are to be displayed via the two 
lists in the toolbar or by using the buttons []. 

The layout of this results table depends on the standard which has been selected in the 
General Data dialog box (cf Figure 4.44, page 61). 

Via the button [Show columns], the various table items can be selected in a specific dialog 
box. 

7.11.1 DIN 18800 
The analysis of the effective cross-section properties according to DIN 18800 also implies to 
check the c/t ratios. Thus, it is recommended to consider the previous table 5.1 Check of c/t 
zones as well. This table is described in chapter 7.7 on page 120. 

 
Figure 7.21: Table 5.2 Effective Widths according to DIN 18800 

Zone No. 
The results are listed by zone numbers, i.e. elements connected in a definable ‘straight’ line. 
In the General data dialog box, the settings when to create end restraints of the c/t zones 
can be controlled (cf Figure 4.44, page 61). 
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Elements 
All elements that belong to the c/t zone are listed in this input field. 

Restraint Type 
This column gives information on the restraints of each c/t zone as per definition in table 
1.6 c/t Zones (cf chapter 5.6, page 82). They can be supported on one side only (outstand 
flange) or on both sides (internal compression part). 

Subtracted Length ∆Start / ∆End 
In these two columns, the distances of the restraint from the start resp. end nodes of the 
relevant elements are listed. Those values correspond to the lengths as defined in columns E 
and F of table 1.6 c/t Zones (cf chapter 5.6, page 82). 

Width c 
The total width of a c/t zone is made up of the lengths of all contained elements which is 
reduced by the subtracted lengths at the start and end of this zone. 

Thickness t 
The thickness is defined as the smallest thickness of all elements which are integral parts of 
the c/t zone. 

Description 
In this column, the various parameters are listed that are essential to determine the effec-
tive widths. If the c/t zone is subject to tensile stresses, the remark No compression is indi-
cated instead. 

Normal Stresses σx,Start / σx,End 
These two lines give information on the normal stresses at the start resp. end nodes of each 
c/t zone. Please note that those are the stresses of the gross cross-section. Tensile stresses 
are positive, compressive stresses negative. 

Boundary Stresses σ1 / σ2 
These stresses are determined from the normal stresses. σ1 is the maximum value of stress 
at either the start node or the end node of the c/t zone. Accordingly, σ2 represents the min-
imum value of both stresses. Additionally, the signs are reversed,i.e. compressive stresses 
are set positive and tensile stresses are set negative. 

Stress Ratio ψ 
This line contains the ratio of the values from the two previous lines. If there are tensile 
stresses at both ends, no values of the stress ratio are determined. 

Buckling Factor kσ 
The buckling factor is specified in DIN 18800 Part 2, Table 26. To determine kσ in this table, 
the restraint type and the stress ratio have to be considered. 

Euler Relative Stress σe 

This value is necessary to determine the plate slenderness. It is calculated according to the 
following equation: 
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189800 2
2

e 





⋅=σ  

Equation 7.83 

Maximum Compressive Stress σ 
In this line, the maximum value of the compression stress is specified. 
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Plate Slenderness λP,σ 
The related plate slenderness of the metal sheet for buckling is determined according to the 
following equation: 

e

M
,P k σ⋅

γ⋅σ
=λ

σ
σ  

Equation 7.84 

Reduction Factor ρ 
Different reduction factors have to be considered for either internal compression parts or 
outstand flanges. 

• Internal compression elements 
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Equation 7.85 

• Outstand compression elements 

σλ
=ρ

,P

7.0
 

Equation 7.86 

Effective Width c’ / c’1 / c’2 

The effective widths are determined as follows (cf DIN 18800 Part 2, Table 27). 

• Internal compression elements 

c'c =  for 673.0,P ≤λ σ  

c'c ⋅ρ=  for 673.0,P >λ σ  

Equation 7.87 

The effective width c’ is then distributed into its components c’1 and c’2. 

11 kc'c ⋅⋅ρ=  for 42.012.004.0k 2
1 +ψ⋅+ψ⋅−=  

22 kc'c ⋅⋅ρ=  for 58.012.004.0k 2
2 +ψ⋅−ψ⋅=  

Equation 7.88 

• Outstand compression elements 

cc'c ≤⋅ρ=  for 673.0,P >λ σ  

Equation 7.89 

Dependent on the stress distribution, the effective width c’ is allocated as follows. 

'c  for 0≥ψ  

'c  + Tensc  for 0<ψ  and tensile stresses at unrestrained edge 

'c  + Tensc  for 0<ψ  and tensile stresses at restrained edge (c‘ has to be meas-
ured from the zero-crossing towards the unrestrained edge) 

 where cTens zone width with tensile stresses 

Equation 7.90 
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Symbol 
This column lists the symbols that are associated with the previous descriptions of the 
parameters. 

Value 
In this column, the values of the various parameters are listed. 

Unit 
This column contains the units of all relevant values. 

7.11.2 EN 1993-1 
The analysis of the effective widths makes only sense for Class 4 cross-sections. In table 5.2 
of the EN 1993-1-1 standard, the maximimum width-to-thickness ratios for compression 
parts are specified (cf Figure 7.20, page 130). 

The Class of the Cross-Section is specified in the last line of this table. 

 
Figure 7.22: Table 5.1 Effective Widths according to EN 1993-1 

Zone Number 
The results of the effective width design are listed by numbers of the c/t zones. 

Elements 
This column lists all elements that belong to each c/t zone. 

Restraint Type 
This column gives information on the restraints of each c/t zone as per definition in table 
1.6 c/t Zones (cf 5.6, page 82). They can be supported on one side only (outstand flange) or 
on both sides (internal compression part). 

Subtracted Length ∆Start / ∆End 

In these two columns, the distances of the restraint from the start resp. end nodes of the 
relevant elements are listed. Those values correspond to the lengths as defined in columns E 
and F of table 1.6 c/t Zones (cf 5.6, page 82). 
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Width c 
The total width of a c/t zone is made up of the lengths of all contained elements which is 
reduced by the subtracted lengths at the start and end of this zone. 

Thickness t 

The thickness is defined as the smallest thickness of all elements which are integral parts of 
the c/t zone. 

Description  
In this column, the various parameters are listed that are essential to determine the effec-
tive widths. If the c/t zone is subject to tensile stresses, the remark No compression is indi-
cated instead. 

Normal Stresses σx,Start / σx,End 
These two lines give information on the normal stresses at the start resp. end nodes of each 
c/t zone. Please note that those are the stresses of the gross cross-section. Tensile stresses 
are positive, compressive stresses negative. 

Boundary Stresses σ1 / σ2 
These stresses are determined from the normal stresses. σ1 is the maximum value of the 
compressive stress at either the start node or the end node of the c/t zone. Accordingly, σ2 
represents the minimum value of both stresses. Additionally, the signs are reversed,i.e. 
compressive stresses are set positive and tensile stresses are set negative. 

Stress Ratio ψ 
This line contains the ratio of the values from the two previous lines. If there are tensile 
stresses at both ends, no values of the stress ratio are determined. 

Buckling Factor kσ 
The buckling factor is specified in EN 1993-1-5, Table 4.1 and Table 4.2 (cf Figure 7.23, 
page 137). To determine kσ in these tables, the restraint type and the stress ratio have to  
be considered. 

Euler Relative Stress σe 

This value is calculated according to the following equation: 

]mm/N[
c
t

189800 2
2

e 





⋅=σ  

Equation 7.91 

Maximum Compressive Stress σ 
In this line, the maximum value of the compression stress is specified. 

Plate Slenderness λP,σ 
The related plate slenderness of the metal sheet for buckling is determined according to 
EN 1993-1-5, section 4.4: 

σ
σ ⋅

⋅
⋅
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k235

f

t4.28
c y

,P   fy in [N/mm2] 

Equation 7.92 
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Reduction Factor ρ 
Different reduction factors have to be considered for either internal compression parts or 
outstand flanges (cf EN 1993-1-5, section 4.4). 

• Internal compression elements 

0.1=ρ    for 673.0,p ≤λ σ  

( )
0.1

3055.0
2

,p

,p ≤
λ

ψ+⋅−λ
=ρ

σ

σ  for 673.0,p >λ σ  and ( ) 03 ≥ψ+  

Equation 7.93 

• Outstand compression elements 

0.1=ρ    for 748.0,p ≤λ σ  

0.1
188.0
2

,p

,p ≤
λ

−λ
=ρ

σ

σ   for 748.0,p >λ σ  

Equation 7.94 

Effective Width beff / be1 / be2 

The effective widths are determined as specified in EN 1993-1-5, Table 4.1 and Table 4.2. 
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Figure 7.23: Effective Widths according to EN 1993-1-5 

Symbol 
This column lists the symbols that are associated with the previous descriptions of the 
parameters. 

Value 
In this column, the numerical values of the various output parameters are listed. 

Unit 
This column contains the respective units of all output parameters. 
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8. Results Evaluation 
 

8.1 Results Selection 
After the calculation, the numerical output is presented in the various results tables that are 
described in chapter 7 Results. The results can also be evaluated graphically via the Results 
menu or the corresponding buttons in the Results toolbar. 

 
Figure 8.1: Results menu 

 
Figure 8.2: Results toolbar 

The button [Display results] switches the graphical results on or off, the [Values] button 
(next the list of locations x) controls the display of the results values in the diagrams. 

The load case or location x can be selected from the list in the toolbar. The graphics and – if 
applicable – the tables are updated automatically. 
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8.2 Results Display 
As described in the previous chapter, the selection of the results can be controlled via the 
Results menu or the Results toolbar. 

The diagrams of the section characteristics or stresses are displayed two colored by default. 
This type of display can be advantageous for printing. Positive results are drawn as cyan 
lines, and negative ones as red lines. 

If the result diagrams overlap for many elements, the lines can also be arranged orthogo-
nally to the elements via the button as seen to the left. Thus, the view of the results can be 
improved for certain sections. 

The parameters of the diagrams can be controlled in the Settings dialog box, tab Results. 
This dialog box is called up via menu 

Options → Viewing Options 

or the global context menu which can be activated by a right-mouse click in the work area. 

 
Figure 8.3: Dialog box Settings, Results tab 

The editing options include the colors, line thickness and fonts of the results display which 
allow for a user-defined tuning of the results graphics. 

It is also possible to apply a multi-color display of the results that can be activated via menu 

Results → Color spectrum 

or the corresponding button in the toolbar. 

The colors of the lines are then allocated according to the spectrum of the control panel. 
Details on how to adjust this color spectrum can be found in chapter 4.3.6 on page 40. 

As can be seen in the following image, there are two options available in the control panel. 
For the Distribution of the results diagrams, eleven colors are utilized for the lines instead of 
two. The option Isosurfaces, however, transfers the graphical results on the element thick-
nesses of the section. 
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Figure 8.4: Multi-color results as Isosurfaces and color spectrum 

For the two- or multi-color line display, the scaling of the results diagrams can be controlled 
via the [Display factor] button. This function is also accessible in the Results menu. It calls 
up a dialog box which allows for a user-defined scaling of the diagrams. 

 
Figure 8.5: Dialog box Results Diagrams Display Factor 

The Filter tab of the control panel can be used to select specific elements whose results are 
to be displayed exclusively. For details, see chapter 4.3.6 on page 42. 

As usual, the items that are to be displayed can be controlled in the Display dialog box 
which is called up via menu 

View → Display. 

Activate the category Results for a detailed selection of the objects among this Subcategory 
that are to be shown in the results graphics. 

 
Figure 8.6: Dialog box Display, category Results 
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8.3 Results Values 
The [Values] button, located next the list of locations x, controls the display of the results 
values in the diagrams. 

The viewing options of the Settings dialog box control the locations of the results values 
and their display (cf Figure 8.3, page 139). Via the [Define font] button in this dialog box, 
the fonts, font styles and sizes of the values can be modified. 

It is also possible to directly read various object or results data by placing the mouse pointer 
on the desired object or location of the element. After a short while, the tooltip appears. 

 
Figure 8.7: Tooltip of an element (stresses σx displayed as isosurfaces) 

In the tooltip shown above, the parameter s represents the distance from the element start, 
h the distance from the center line of the element. 

Detailed information on specific elements can be obtained via the Element Info function. It 
is activated via menu 

Extras → Element info 

or the corresponding button in the toolbar. 

The Element results dialog box appears. When the mouse pointer is placed on an element, 
essential data on the element and its results can be read. 

 
Figure 8.8: Dialog box Element results showing normal stresses of specific element 

The results are listed of the start (S) and end (E) nodes of the element. Additionally, the 
result value of the element center (C) is indicated. 
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If plastic stresses are displayed in the graphics, the Particle info dialog box is called up in-
stead. There, the characteristics of the Simplex element are listed that is identified by the  
location of mouse pointer. 

 
Figure 8.9: Dialog box Particle Info showing characteristics of specific Simplex element 

8.4 Multiple Windows View 
Several windows can be viewed together with different section characteristics or stresses at 
the same time. This option can be activated via menu 

Results → Arrange results windows 

or the corresponding button in the toolbar. 

A dialog box opens where the different types of results can be selected. 

 
Figure 8.10: Dialog box Results - Display options 

The multiple window view can also be used for the printout (cf chapter 9.2 on page 162). 
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8.5 Filter Results 
There are several filter options for a better overview over the results. They can also be suited 
for the following documentation of the results. 

Groupings 
With groupings, it is possible to split the section into components graphically. The partial 
view functions are available in menu 

View → Create grouping etc. 

or the corresponding button in the toolbar. 

 
Figure 8.11: Menu View → Groupings 

Create Grouping 
If you have selected certain objects, you can save them as a so-called Grouping. 

 
Figure 8.12: Dialog box Create grouping 
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In the dialog box, you have to define the Name of the partial view before this group of ob-
jects can be stored. 

The menu function Edit → Select → Special can be useful to select objects. In a dialog box, 
detailed settings for the selection are possible (cf chapter 10.1.2, page 167). 

Select Grouping 
All defined partial views will be listed. SHAPE automatically creates partial views arranged 
by sections and materials. 

 
Figure 8.13: Dialog box Select Grouping 

Grouping via Window 
Partial views can also be created via the mouse by pulling up a window. 

If you pull up the window from the left to the right, the partial view contains only objects 
that are completely within this window. If you pull up the window from the right to the 
left, the partial view contains also those objects that are cut by the window. 

Grouping via Number 
The numbers of objects for the partial view can be defined in a dialog box. 

 
Figure 8.14: Dialog box Select with number 

Exit Partial View Mode 
This function restores the view of all objects. 

Sections 
Sections can be useful to filter results. They are also included in the list of groupings. Details 
on the sections can be found in chapter 5.3 (p. 73) and in chapter 10.1.8 (p. 171). 

Filter Functions 
The filter options shown above refer to the objects of the cross-section. It is also possible to 
use the section characteristics or stresses as selection criteria.  
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Filter Stresses 
The panel has to be displayed to filter the internal forces in a structure. If it is not shown, 
activate it via menu Results → Color Spectrum or the button as seen to the left. 

Details on the control panel can be found in chapter 4.3.6 on page 40. The filter settings for 
the results have to be done in the Color Spectrum tab. It can be defined that e.g. shear 
stresses exceeding 50 N/mm2 or normal stresses within the interval of ±20 N/mm2 are to be 
displayed in detail (cf Figure 4.14 on page 41). 

In the following example, the equivalent stresses between 120 N/mm2 and 220 N/mm2 are 
displayed exclusively. The spectrum has also been modified in a way that one color range 
covers exactly 10 N/mm2. Stresses that do not fulfill these conditions will not be shown. 

 
Figure 8.15: Filtering equivalent stresses with adjusted color spectrum 

Filter Elements 
In the Filter tab of the control panel, you can define the numbers of those elements whose 
results are to be shown exclusively in the graphics. Details on these functions can be found 
in chapter 4.3.6 on page 42. 

Unlike the Grouping function, the section is shown completely. The following image shows 
the normal stresses of the flanges. The webs are displayed, too, but without any stresses. 

 
Figure 8.16: Filtering Elements: Normal stresses of the flanges 
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9. Printout 
 

9.1 Printout Report 
Instead of sending the data directly to the printer, it is recommended to create a so-called 
printout report from the input and results data first. It can be supplemented with graphics, 
explainations, scans, and other elements. In this printout report, you can also define which 
sectional data is to be included in the final printout. 

For every section, several printout reports can be created. It is possible to create different 
printout reports for a SHAPE section. Depending on which data is needed, e.g. the design 
engineer and the detailer might receive different printout reports. 

A printout report can only be called up if a default printer has been installed in Windows. 
The preview in the printout report uses this printer driver. 

9.1.1 Create or Open Printout Report 
A new printout report can be created via menu 

File → Printout report, 

the button in the toolbar, or the context menu in the navigator. 

 
Figure 9.1: Button and context menu Printout report 

The following dialog box is opened. 

 
Figure 9.2: Dialog box New Printout Report 

The number of the report is preset by the program but can be modified in the No. input 
field. In the input field Description, you can enter a name for the report which makes the 
selection in the lists easier. This description will not be printed. 
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From the list under Adopt from printout report template, you can select a specific report 
template. Details on the templates can be found in chapter 9.1.7 on page 157. 

The buttons in this dialog box have the following functions: 

 A new report template can be created. 

 The selection of report can be changed ( chapter 9.1.3, page 149). 

Table 9.1: Buttons in dialog box New Printout Report 

If a printout report has already been defined, it can be opened via menu 

File → Printout Report, 

the corresponding button in the toolbar, or by double-clicking it in the navigator. 

9.1.2 Work in Printout Report 

 
Figure 9.3: Printout report with context menu 

If the printout report has been created, a navigator is shown on the left. On the right, the 
preview of the printout is presented. 

The individual chapters can be moved in the navigator to any place by drag & drop. 

The context menu offers additional options for the printout report. As usual for Windows 
applications, multiple selections are possible. 
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Remove from Printout Report 
The selected chapter will be deleted. The global selection makes it possible to reinsert this 
chapter again (menu Edit → Global Selection). 

Start with New Page 
The selected chapter starts on a new page. It is marked by a red pin in the navigator. 

Selection 
The global selection dialog box opens (see following pages) where the selected chapter will 
be set by default. 

Properties 
The general properties of a chapter can be modified as shown in the following figure. 

 
Figure 9.4: Dialog box Properties 

Here you can change the Title of the chapter and enter an Additional Explanation which will 
then be displayed on the left margin of the report. This additional text as well as the accom-
panying Graphic Scheme (informative picture of cross-section or stress distribution) can be 
hidden. The check box Show List controls whether the number list of reduced chapter data 
(e.g. selected elements) will be displayed in the navigator and in the table of contents. 

Navigation in the Printout Report 
The easiest way to navigate to a specific page of the printout report is by clicking on the 
relevant chapter in the navigator. In the View menu, you have additional functions which 
can also be opened with the following buttons. 

   Go to previous page in the preview 

   Go to next page 

   Go to first page 

   Go to last page 

   Enter page number that is to be displayed 

   Switch between one sided and double sided view 

   Zoom in 

   Zoom out 
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   Selection Mode: Mouse clicks selects a chapter and open the selection dialog box 

   Zoom Mode: Mouse click zooms in on selected chapter 

 Redraw the view of the printout report 

Table 9.2: Navigation buttons in the printout report toolbar View 

9.1.3 Define Contents of Printout Report 
In the global selection, the chapters are selected that are to be contained in the printout 
report. This function can be called up via menu 

Edit → Global Selection, 

the corresponding button in the toolbar, or the Contents context menu. 

 
Figure 9.5: Opening the global selection via the Contents context menu. 

The following dialog box will be displayed. 

 
Figure 9.6: Dialog box Printout report selection, Main selection tab 

The Main Selection tab controls the main chapters of the printout report. If a check box is 
deactivated there, the tab with its details will disappear, too. 

A full-page Cross-section image incl. dimension lines and principal axes will be inserted in 
front of the sectional data if the respective check box is activated. 



9  Printout 

 

 

150 Program SHAPE-THIN © 2012 by Ing. Software Dlubal 

 

9.1.3.1 Select Section Data 

 
Figure 9.7: Dialog box Printout report selection, Input data tab 

The Display column controls whether a chapter is to be included in the printout report.  

The printout report is based on the input tables (cf chapter 5). The Selection column con-
trols which table lines are to be included. By default, All objects are listed in the printout 
report. For a specific numerical selection, click the [] button at the end of the relevant in-
put field to open a new, empty line. Then activate this line by a mouse click and insert the 
numbers of the specific objects. 

9.1.3.2 Select Load Data 

 
Figure 9.8: Dialog box Printout report selection, Load cases tab 

The same procedure as for the selection of the sectional input data applies to these tables. 



9  Printout 

 151 Program SHAPE-THIN © 2012 by Ing. Software Dlubal 

 

 

 
 

 

 

If the Locations x are set active, the input data of table 1.7 Forces and moments will be in-
cluded in the printout report. 

The check box Display all load cases controls whether the internal forces of all or only of 
specific load cases are to be printed. If you deactivate this option, you can select the rele-
vant load cases via the two [Add] buttons beneath the list of Available load cases. Those 
will be transferred to the dialog section Load cases to display. It is also possible to select 
(and to deselect) a load case by double-clicking it. 

9.1.3.3 Select Results 

 
Figure 9.9: Dialog box Printout Report Selection, Results tab 

Selecting the results data is similar to choosing the sectional input or load data. The table 
lines of the respective results tables (cf chapter 7) can be selected in the same way as those 
of the input data: For a specific numerical Selection, click the [] button at the end of the 
relevant input field to open a new, empty line. Then you can insert the numbers of the rele-
vant objects.  

For the stresses and c/t zones, the [Details] button allows for a specific control on the re-
sults data. 

 
Figure 9.10: Dialog box Details - Stresses 

Here you can choose whether all stresses of the locations x and/or only the maximum and 
minimum results are to be printed. The same applies to the c/t zones: It can be defined 
whether all c/t zones or only the decisive ones are to be included, which allows for reducing 
the printed contents. 
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In the dialog section Load cases to display, the printout can be confined to the results of 
specific load cases. If you deactivate the option Display all load cases, the relevant load cas-
es can be selected via the two [Add] buttons beneath the list of Available load cases. Those 
will be transferred to the dialog section Load cases to display. It is also possible to select 
(and to deselect) a load case by double-clicking it. 

9.1.4 Adjust Printout Report Header 
Already during the installation, SHAPE creates a print header from the customer data. This 
default header can be changed via the printout report menu 

Settings → Header 

or the corresponding button in the toolbar of the printout report. 

 
Figure 9.11: Button Show header 

In the following dialog box, all settings for the printout header can be defined. 

 
Figure 9.12: Dialog box Print Report Header 

The dialog section Show specifies which elements of the header are shown and which Date 
is to be printed. 

The option Info Row below the Header includes the general project and sectional data to-
gether with the date. 

The Project Description is managed in the Project Manager among the general data of the 
project where it can be edited (cf chapter 4.4.1.1, page 49). The Section Description can be 
edited in the general data of the section (cf chapter 4.4.2.1, page 54). 

The numbering can be adjusted in section Page and Sheet Numbering. If Page and Sheet 
have the same initial number, there is no difference in the numbering. But if you e.g. want 
to assign all pages to one sheet, then the sheet numbering is to be deactivated. 
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The check box Continuous defines whether the numbering is to be automatically increasing. 
The first number of the page and sheet numbering can be defined manually. The check box 
Last page number controls whether the number of the final page is added (e.g. Page: 4/17). 

The section Company Address in the Header dialog box contains the customer data which 
can be edited here. There are three input fields available, one for each header line. Via the 
button [A], you can define the font for the selected line. The Alignment of the lines can also 
be defined individually. 

You can also include the company logo as a graphical object in the left area of the header. 
This image must be a bitmap file. With graphics programs like e.g. MS Paint, you can save 
every image as a *.bmp file. 

If you want to save the edited print header, click the [Set Header as Default] button that is 
located beneath the Header Default section. The dialog box Header Template Name appears 
where a name can be entered. This print header will then be the default setting in the list. 

The [Header Library] button is recommended if you want to store or manage different print 
headers. It calls up following dialog box. 

 
Figure 9.13: Dialog box Header Library 

This dialog box is used to create, edit or delete the print header template. The functions of 
the buttons are as follows: 

 A new header can be created. An additional dialog box allows for the data input. 

 The selected header can be edited. 

 The selected header will be deleted. 

Table 9.3: Buttons in Header Library dialog box 

If several headers are available, one of these can be selected in the Header Default dialog 
section. The button [Set as Default] applies this header to the printout reports of subse-
quent cross-sections. 

The print headers are stored in the file DlubalProtocolConfig.cfg which is located in the 
common data file (e.g. C:\Program Files\Dlubal\Stammdat). Although this file is not over-
written by the installation routine, a backup copy might be advisable. 
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9.1.5 Insert Section Images 
Every sectional image can be included in the printout report. The current SHAPE graphics is 
printed via menu 

File → Print  

or the corresponding button in the toolbar. 

 
Figure 9.14: Button Print in the toolbar of the main window 

The following dialog box is displayed: 

 
Figure 9.15: Dialog box Print Image, Image tab 

In the Print Image dialog box, the option To printout report is to be selected. If more than 
one printout report exist, you can choose the number of the relevant report from the list 
next to the selection field. 

For the printout report, dynamical images will be generated. This means that the graphics 
in the printout will be updated automatically according to changes in the section or results. 

When the dialog box is closed with [OK], the printout report will be opened. In some cases 
this may not be desirable, e.g. when you want to print several images one after another. By 
deactivating the check box Show printout report on [OK], it is possible to prevent the report 
from being opened. 

Details on the remaining functions (e.g. the Short form printout option) in this dialog box 
can be found in chapter 9.2 on page 161. 
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9.1.6 Insert Graphics and Texts 
There are various options to include any kind of images and texts in the printout report. 

Insert Graphics 
If you want to add an image that is not a SHAPE picture itself, you first need to open this 
graphic file in an image editor (e.g. MS Paint). There the image has to be copied to the clip-
board via [Ctrl]+[C]. 

The image can then be inserted via the printout report menu 

Insert → Picture from Clipboard. 

Before it will be included, the chapter name is to be entered. 

 
Figure 9.16: Dialog box Insert Graphic from Clipboard 

This image will appear as a single chapter in the printout report. 

Insert Texts 
Short notes can also be added to the printout. This function is activated via menu 

Insert → Text. 

The following dialog box will be displayed. 

 
Figure 9.17: Dialog box Insert Text 

Enter here a Title and the Text. With the [Enter] key you can define a manual word-wrap in 
this text. 

After [OK], the chapter will be added to the printout report. You can move it to the desired 
position by Drag & Drop. 

In the selection mode, the text can be modified by double-clicking it or by right-mouse-
clicking its header in the navigator and then selecting Properties in the context menu. 



9  Printout 

 

 

156 Program SHAPE-THIN © 2012 by Ing. Software Dlubal 

 

Insert Texts from Text Files 
You can also insert text files in the printout report. Recurrent texts can be stored in a file 
and in this way be used for the report. With this function, you can also integrate data of 
other programs, provided that these are ASCII text files. 

Text files are imported via the printout report menu 

Insert → ASCII File. 

In the Windows dialog box Open, you first select the file. Before the file contents will be 
imported, an extra dialog box appears. 

 
Figure 9.18: Dialog box Insert Text 

You can still adjust the Text here and define a chapter Title. 

After [OK], the chapter will be added to the printout report. You can move it to the desired 
position by Drag & Drop. 

In the selection mode, the text can be edited by double-clicking it. 

Insert Texts from RTF Files 
The previously described option allows for inserting recurrent texts in the printout report. 
ASCII files, however, are not formatted texts. 

The import of RTF files enables you to integrate formatted texts with embedded graphics in 
the report. This function can be activated via menu 

Insert → RTF File. 

In the Windows dialog box Open, you can select the *.rtf file. Before it can be included in 
the printout report, you still have to enter the chapter name. 

After [OK], the chapter will be added to the printout report. You can move it to the desired 
position by Drag & Drop. 
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9.1.7 Printout Report Template 
The selection as it is described in chapter 9.1.3 may be time-consuming. You can store the 
selection including images as a report template to reuse it later for different sections, which 
makes the creation of printout reports more efficient. 

An existing report can be also used as a template subsequently. 

Create New Template 
A new template can be defined via these menus of the printout report: 

• Settings → Printout Report Template → New 

• Settings → Printout Report Template → New from Current Printout Report 

New 
First, the Printout Report Selection dialog box is called up (cf Figure 9.6, page 149) where 
you can select the contents to be printed. When you then close this selection with [OK], you 
can enter a Description for this new report template. 

 
Figure 9.19: Dialog box New Printout Report Template 

New from Current Printout Report 
The selection of the current printout report will be used for the selection of the new tem-
plate. You only have to enter the Description of the report template. 

Apply Template 
If a printout report has been already opened, the selection of a specific template can be 
applied to the current report via menu 

Settings → Printout Report Template → Select. 

In the following dialog box, the relevant report template can be chosen from the list of 
Available Printout Report Templates. 

 
Figure 9.20: Dialog box Printout Report Template 

After [OK] and confirming again, the current selection will be overwritten by the template. 

If a new printout report is created (cf Figure 9.2, page 146), you can select a template from 
the list Adopt from printout report template whose settings are to be applied for the new 
printout report. 

Details on the buttons of this dialog box can be found in Table 9.4. 
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Manage Templates 
The templates are managed in the Printout Report Template dialog box (cf Figure 9.20) 
which is called up via the printout report menu 

Settings → Printout Report Template → Select. 

The buttons in this dialog box have the following functions. 

 The name of the selected template can be changed. 

 The selected template will be deleted. 

Table 9.4: Buttons in dialog box Printout Report Template 

These functions can be applied to user-defined templates only. 

You can save your printout report templates before installing an update. These templates 
are stored in the file DuenqProtocolConfig.cfg which is located in the common data folder 
of SHAPE (e.g. C:\Program Files\Dlubal\DUENQ7\Stammdat). Although this file is not over-
written by the installation routine, a backup copy might be advisable. 

9.1.8 Adjust Layout 
The layout of a printout report can be adjusted with regard to the fonts and font colors, 
margin settings and table design. 

This dialog box can be activated via the printout report menu 

Edit → Page Setup. 

 
Figure 9.21: Dialog box Page Setup 

The default fonts of the table contents and the table headers are relatively small. However, 
you should be careful when changing the default Arial 8. Larger fonts do not always fit in 
the columns. 

9.1.9 Print Printout Report 
The actual printing process is started via the printout report menu 

File → Print 

or the corresponding button in the toolbar of the printout report. 

 
Figure 9.22: Button Print printout report 
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The default printer dialog box opens where the printer and the pages can be defined. 

 
Figure 9.23: Dialog box Print 

If you do not use the default printer, the page break and, therefore, the page numbers 
might be different from the print preview. 

The option Print to File creates a file in the PRN format which can be sent to the printer via 
the copy command. 

9.1.10 Export Printout Report 
You can directly export the printout report as an RTF file and to the spreadsheet application 
BauText. 

RTF Export 
The RTF format can be read by all common word processing programs. The printout report 
will be exported together with the graphics. 

The export to an RTF document can be started via the printout report menu 

File → Export to RTF File or BauText. 

The following dialog box appears. 

 
Figure 9.24: Dialog box Export Printout Report to RTF Format 

The folder and file name of the RTF file have to be defined. When the check box Export of 
selected data only is activated, the selected chapters will be exported instead of the entire 
report. 

BauText Export 
BauText is a word processing program with specific extras for structural calculations. 

The export to BauText can be started via menu 

File → Export to RTF File or BauText 

or the corresponding button in the toolbar of the printout report. 
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Figure 9.25: Button BauText 

The dialog box as seen in Figure 9.24 is called up where the check box Direct Export to 
BauText can be activated. It is not necessary to enter a file name, but BauText should al-
ready be running. After [OK], the BauText import module will be started. 

PDF Export 
The direct export of the printout report to a PDF document is not possible. However, if you 
have installed the Adobe Acrobat or a similar product, then you have a virtual printer in 
the Print dialog box to create a PDF document. 

There are also freeware tools to create PDF files, e.g. Ghostscript or Win2PDF. A printer has 
to be installed, too, that can print PostScript, e.g. HP Color LaserJet 5/5M PS. If this printer 
is set that it will print to a file, you can generate a PostScript file from every printout report 
that can be finally converted into a PDF file by e.g. GhostScript. 

ASCII File 
SHAPE also supports printing to an ASCII file. If you need the data in this format, you can 
either use the Export to MS Excel function in the input and output tables (cf chapter 10.3.6, 
page 188) or the general SHAPE menu 

File → Export. 

It calls up the Windows Save as dialog box which is explained in chapter 11.1 on page 198. 

9.1.11 Language Settings 
The language settings in the printout report are independent of the language that is set for 
the SHAPE user interface. In this way, you can create a German printout report with the 
English version of SHAPE and vice versa. 

Change Language of Printout Report 
The language of the printout report can be changed via the printout report menu 

Settings → Language. 

In the following dialog box, the desired language can be selected from the list. 

 
Figure 9.26: Dialog box Languages 
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9.2 Direct Graphic Printout 
Every image of the section can be printed directly. This means that you do not need to 
integrate this picture in the printout report (cf chapter 9.1.5, page 154) to print it. 

The current SHAPE image can be printed via menu 

File → Print 

or the corresponding button in the toolbar. 

 
Figure 9.27: Button Print in the toolbar 

A dialog box is displayed that is split into two (or three) tabs. These are described in the 
following chapters. 

9.2.1 Image 

 
Figure 9.28: Dialog box Print Image, Image tab 

Print 
Several graphic windows can be displayed simultaneously in SHAPE (see following image). 
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Figure 9.29: Two windows side by side 

This dialog section is applicable for multiple windows settings in the printout. The option 
Current window only prints the window in focus, e.g. the left-hand window in Figure 9.29. 

When All windows has been selected, the [Window arrangement] button becomes accessi-
ble to define the layout of the images on the page. The following dialog box opens. 

 
Figure 9.30: Dialog box Window Arrangement 

Print Destination 
Here you can choose between three options for the output of the image: 

• Directly to printer 

• To printout report (cf chapter 9.1.5, page 154) 

• To clipboard 

The option Directly to Printer is used for the direct printout. In this case, you can adjust the 
printed headlines via the [Header] button. The Print Report Header dialog box will be 
opened which is described in chapter 9.1.4 on page 152. 

If you select the Short form printout, the most relevant sectional characteristics will be con-
densed on a single page next to the current image(s) of the section (cf Figure 9.31). 
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When you copy to the clipboard, the picture will be available also for other programs. 
There, you can import it via menu Edit → Insert. 

Image Title 
In this input field, a header is preset when calling up the dialog box. It can be modified 
here. 

Image Size 
This dialog section defines the scale of the image on the paper.  

As screen view arranges the window on the sheet according to the displayed size on the 
monitor. Hence, the image on the page will then be wider than high. By means of the op-
tion Window filling, the entire sheet will be used instead. 

If the same size of the image as on the monitor is desired, select the option As screen view. 
With this, zoomed areas or special displays can be printed. With the option Window filling, 
the complete section will be shown on the paper, however. The section is then displayed in 
the defined Vertical size of the image (see below). 

The third option To scale prints the image to a definable scale. 

Page Settings 
In this dialog section, the size of the image on the sheet can be defined. These settings are 
not accessible for short form prints, however. 

If the check box Use whole page has been activated, a page-filling image will be printed. 

Unless the entire vertical size is to be used for the print, the Vertical size of the image can 
be defined as percentage of the page. 
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Figure 9.31: Graphic short form printout 
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9.2.2 Print Quality 

 
Figure 9.32: Dialog box Print Image, Print quality tab 

Print Color 
If the printing is to be directed to a black and white printer, the image can be printed 
Monochrome to improve the readability. 

The conversion of the colored isosurfaces into gray scales is always managed by the printer 
and can therefore not be controlled in SHAPE. 

Frame 
A frame can be optionally printed around the image. 
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9.2.3 Color Spectrum 

 
Figure 9.33: Dialog box Print Image, Color spectrum tab 

This tab is presented additionally when the results are shown in multicolor display (cf chap-
ter 8.2, page 139). 

By default, the color scale of the control panel is printed, too. If this is not intended, the 
check box No Color Spectrum is to be activated. 

If Overlapping has been selected for the position of the color spectrum, it will be placed in-
side the area of the sectional image. Dock at the edge reserves some part of the graphic 
window for the color spectrum. 

Furthermore, it is possible to define the Position of the color spectrum in detail: It can be 
located in one of the four corners or arranged at a user-defined Distance. 

The Size of the color spectrum can be specified in Absolute dimensions or Proportional to 
the picture size. 
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10. Tools 
This chapter presents the different functions for the graphical and tabular input. They in-
clude the editing options for selected objects, the CAD functions to construct new sectional 
objects and the table operations. At the end of this chapter, a brief listing of the sectional 
generators is included. 

10.1 Edit Objects 
Objects that have been selected in the graphics can be modified by means of the graphical 
editing functions. The selected objects can be 

• moved, 

• copied, 

• rotated, 

• mirrored, 

• divided or 

• split up by an opening. 

CAD tools, by contrast, require no previous selection. They facilitate the construction of new 
objects. 

10.1.1 Graphic Selection 
By selecting objects, specific elements are chosen to be manipulated. Those objects can be 
e.g. nodes, elements and point elements or auxiliary elements such as comments. 

Objects can be selected by a mouse click and are then highlighted in the selection color 
(e.g. yellow or red). Only the currently highlighted object remains selected. If several objects 
are to be selected successively, use the [Ctrl] key when clicking on each object. 

With the window selection, many objects can be selected in a single step. Draw a window 
around several objects to select them simultaneously. If the window is drawn from left to 
right, then all objects will be selected which are thoroughly located within this area. If this 
window is drawn inversely from right to left, also objects will be selected that are only par-
tially within this area. 

If the selection via a rectangular window turns out to be a bit difficult, the function 
Selection with Rhomboid can be used instead which is started via menu 

Edit → Select → Select with Rhomboid. 

10.1.2 Special Selection 
Objects can be selected according to specific criteria. With this tool, objects can also be 
added to or removed from an existing selection.  

The special selection can be started via menu 

Edit → Select → Special. 

The following dialog box appears. 
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Figure 10.1: Dialog box Special selection 

Certain types of objects are listed in dialog section Select. In the right part of this dialog 
box, a selection criterion can be defined and specified in detail with additional data. 

The dialog section Mode controls whether the objects are to be added to or removed from 
the current selection. 

When selecting parallel elements, it is possible to [Pick] the template element graphically. 

10.1.3 Move and Copy 
Selected objects can be moved or copied via menu 

Edit → Move/Copy 

or the corresponding button in the toolbar. 

 
Figure 10.2: Button Move and/or Copy 

The following dialog box appears. 

 
Figure 10.3: Dialog box Move - Copy 

If the Number of copies is zero, the selected objects will be moved. Otherwise, the defined 
number of copies will be created. 

The Displacement vector can be determined numerically by the coordinates y' and z' or de-
fined graphically by picking two nodes or grid points. 

Copies can also be quickly created via Drag & Drop of selected objects, while the [Ctrl] key is 
kept pressed.  
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10.1.4 Rotate 
Selected objects can be rotated about a specific point of rotation via menu 

Edit → Rotate 

or the corresponding button in the toolbar. 

 
Figure 10.4: Button Rotate 

The following dialog box will be displayed. 

 
Figure 10.5: Dialog box Rotate, Copy 

If the Number of copies is zero, the selected objects will be rotated. Otherwise, the defined 
number of copies will be created. 

The Angle of rotation is related to a clockwise coordinate system. It can be defined either 
manually or also graphically after having selected the Center of rotation by a mouse click. 

10.1.5 Mirror 
Selected objects can be mirrored via menu 

Edit → Mirror 

or the corresponding button in the toolbar. 

 
Figure 10.6: Button Mirror 

The following dialog box appears. 

 
Figure 10.7: Dialog box Mirror - Copy 

If the original objects are to be maintained, activate the check box Create Copy. 
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The mirroring axis can be defined in two ways:  

• If it is parallel to one of the global axes y or z, it can be selected from the list after 
having activated the first selection field. Additionally, one Point is to be specified that 
lies on this axis. 

• If the mirroring axis is oriented arbitrarily, the second selection field 2 Points has to 
be activated. The axis can then be defined by entering the coordinates of two points 
or by picking them in the graphics. 

10.1.6 Divide 
An element can be divided by right-mouse clicking it and choosing Divide elements in the 
context menu. Alternatively, one of the two options of menu 

Edit → Divide Elements 

can be used. 

 
Figure 10.8: Context menu Divide elements 

There are two options to divide the selected element. 

n Nodes 

 
Figure 10.9: Dialog box Divide element through n nodes 

This function divides the selected element equally into several new elements. The preferred 
way of division can be specified in the input field Number of intermediate nodes. 

Distance 

 
Figure 10.10: Dialog box Divide element through a distance 
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Element context menu 

This function creates a division node at a definable location of the selected element. The de-
fined Distance between the new node can refer to the Start or End node of the element. 
The right-hand interactive image in this dialog box gives information on the element direc-
tion which is essential when defining the distance. 

10.1.7 Insert Opening 
With this function, an opening is created within an element. An example of this feature can 
be found in the introductory example in chapter 3 of this manual on page 20. 

To apply this function, right-mouse click the element and then choose Insert opening in the 
context menu. Alternatively, you can use the menu 

Edit → Insert opening in element. 

 
Figure 10.11: Dialog box Insert Opening in Element 

If the element has not been selected before the dialog box was called up, you can choose it 
in the graphics via the [Pick] button. 

Beneath the Element length which is indicated for information, the Opening length can be 
entered. The defined Distance from the opening can refer to the start or end node of the 
element. The right-hand interactive image in this dialog box gives information on the ele-
ment direction which is essential when defining the distance. 

If there is a centric opening, its input can be facilitated via the respective check box. The 
two input fields of the distances then become inaccessible. 

By default, the opening is inserted as dummy element, which means that a zero element is 
created between the two element ends so that the shear flow is not interrupted. If no shear 
transfer is desired, however, the last check box has to be deactivated. 

10.1.8 Create and Reduce Section 

Create Section from Sectional Parts 
It may be useful to classify certain areas of the section as a sectional unit, e.g. for composite 
sections. These will then be added to the list of sections in table 1.3 Sections. 

Select the relevant elements and point elements with the mouse and the pressed [Shift] key 
or by pulling up a window over the relevant objects. Then call up menu 

Edit → Additional tools → Create section from selected elements. 

This function is also included in the element context menu which can be called up by right-
mouse clicking one of the selected elements (cf Figure 10.8, page 170). 

The following dialog box appears. 
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Figure 10.12: Dialog box Create section from selected elements 

Enter the Section description to allocate a specific name for this user-defined sectional part. 
The selected elements are shown in the right-hand image which also displays the centroid C 
and the shear center M of this new section. 

In this dialog box, all Section properties of the selected set of elements are listed in detail. 
The layout of this list corresponds to table 2.1 Section properties. If different materials are 
used in this section, the ideal section properties are presented. 

After [OK], the new section will be added to the list in table 1.3 Section. 

Reduce Section into Components 
A section (cf chapter 5.3) has to be dismantled into its elements and point elements before 
its components can be edited, e.g. cutting off or adjusting elements. 

To reduce a section into its components, click this section to select it and call up menu 

Extras → Reduce section into elements. 

Alternatively, this function can be activated by right-mouse clicking the section. Then 
choose the context menu option Reduce section into elements. 

The following message appears after the section has been dismantled. 

 
Figure 10.13: Message when reducing section into its components 
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10.1.9 Scale Elements 
The size of selected elements and point elements can be modified via menu 

Edit → Additional tools → Scale. 

The following dialog box opens. 

 
Figure 10.14: Dialog box Change size 

If no Elements or Point elements have been selected yet, their numbers can be defined in 
the two input fields. Alternatively, you can [Pick] them in the graphics. 

The New size of the selected elements can be defined by entering the Absolute values of 
the New width (size in direction y0) or New depth (size in direction z0). Alternatively, the 
scaling can be Relative via the percentaged factor. 

The Reference point which is to represent the origin for the scaling can be defined by its 
coordinates y0 and z0. You can also [Pick] it in the graphics. If the [Center] is selected, the 
scaling will be related to the centroid of all selected elements and point elements. 
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10.2 CAD Tools 
The CAD tools facilitate the graphical input of objects, e.g. by means of grid options and 
features to create or combine elements. 

10.2.1 Grid 
Grid points are useful to define objects in the graphics. When setting elements, the cursor 
snaps on the grid points. The grid is switched on or off with the button as seen to the left. 

The features of the grid are defined in the Grid Settings dialog box. It is called up via menu 

Options → Grid 

or the corresponding button in the toolbar.  

 
Figure 10.15: Button Set grid 

The following dialog box is called up. 

 
Figure 10.16: Dialog box Grid settings 

Activate 
The check box Grid switches the grid on or off. The snap function can be switched on or off 
via the check box Snap. The snap function also acts on the grid points of an invisible grid. 

Type 
The grid points can be arranged with reference to the Cartesian or polar coordinate system 
(cf chapter 5.1, page 66). This choice also controls the parameters of the grid point spacing. 

Grid Origin 
The origin of the grid is defined by its coordinates y0 and z0. It can also be determined 
graphically with the [Pick] button. 

Without the necessity to call up the Grid Settings dialog box, the button [Select grid origin] 
in the toolbar allows for a quick choice of the origin. 

Grid Point Spacing 
In the case of a Cartesian grid, the spacing of the grid points can be separately defined for 
the Width (b in the dialog box image) and the Depth (h in the image). 

For the polar grid, the radial spacing R of the concentric circles can be determined. The an-
gle α defines the grid point spacing on the circles. 

Grid Rotation 
Optionally, both the Cartesian and the polar grid can be rotated by the angle β. 
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10.2.2 Smoothen Corners 
The section properties and stresses may not be accurately calculated where elements meet 
at an angle on a common node. To adjust those elements, activate menu 

Edit → Smoothen corners 

or click the corresponding button in the toolbar. 

The mouse pointer then features an additional angle. Click into the intersecting area of 
both elements that has to be adjusted. 

 
Figure 10.17: Smoothen corners – before and after 

As a result, the selected element side is shortened, and the adjacent side is lengthened by 
adding a new element. Additionally, a dummy element is created so that the shear flow is 
not interrupted. 

10.2.3 Round off Corners 
Elements with a shared node can be connected by an arc element. Even non-connecting 
elements can be connected with this function.  

To realistically model corners with a rounding radius, open menu 

Edit → Round off corners 

or click the corresponding button in the toolbar. The following dialog box opens. 

 
Figure 10.18: Dialog box Round off Corners 

In this dialog box, it is recommended to determine the Center line radius r of the arc ele-
ment first. The Material can be selected from the list. 

If both elements do not have the same thickness, the arc can be divided into several elements 
with a continuous adjustment of the thicknesses. The Number of the divisions defines how 
many elements are to be created. If a Uniform transition with interpolated thicknesses is in-
appropriate, deactivate the check box and then define the Thickness t for all elements. 
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Now click the two elements successively that are to be connected by an arc. The element 
numbers of the current mouse pointer location will be shown in the two input fields 
Corners rounded off between elements. 

 
Figure 10.19: Round corners – before and after 

10.2.4 Connect Elements 
This function connects elements whose center lines cross without a common node. 
To adjust those elements, activate menu 

Edit → Connect elements 

or click the corresponding button in the toolbar. 

The mouse pointer then features an additional rectangle. Pull up a window over the inter-
section area to call up the following dialog box. 

 
Figure 10.20: Dialog box Connect crossing elements 

There are three options how to treat the selected elements:  

• SHAPE can divide the elements and create new nodes at the intersection points of the 
center lines. 

• The elements can be divided and joined at the element edges instead at the centers. 
Dummy elements are then used to connect the element edges to the center lines. 

• It is also possible to apply no division or connections. 

If several elements are to be connected at the same time, the selected option can be applied 
either to all elements or individually with extra queries for each action. 
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Figure 10.21: Connect elements with dummy elements – before and after 

10.2.5 Connect Node and Element 
Contrary to connecting elements, this function does not require a common intersection 
point to connect elements. A start or end node of an element is connected to another ele-
ment by a dummy element. Thus, a rigid connection can be created between two elements 
that neither meet nor intersect. 

If the connection is to be applied to the prolongation of the element, the function Extend 
Element is recommended (see next chapter). 

The function is called up via menu 

Edit → Connect node and element 

or the corresponding button in the toolbar. The following dialog box appears. 

 
Figure 10.22: Dialog box Connect node and element 

Define the Node number of the element that is to be connected or click the node in the 
graphics. Then define the number of the element that this node is to be joined with, which 
can be also done graphically. A dummy element will be created, using the shortest distance. 

10.2.6 Extend Element to Element 
This function adjusts the length of an element in general or extends it to another element. 

It can be called up via menu 

Edit → Extend element to element 

or the corresponding button in the toolbar. 

The following dialog box appears. 
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Figure 10.23: Dialog box Extend element to element 

There are two options how the connection is to be realized: 

• The first element can be extended to the element edge of the second element and then 
be connected by a dummy element to its center line. 

• SHAPE can extend the element to the center line of the target element. 

Define the numbers of both elements or simply click on them in the graphics. 

 
Figure 10.24: Extend element to element and connect with dummy element – before and after 

10.2.7 Change Element Length 
This function is useful to adjust the length of an element in general. It is called up via menu 

Edit → Change element length. 

The following dialog box appears. 

 
Figure 10.25: Dialog box Change element length 

The modification can applied to One element end or at Both element ends simultaneously. 

Before selecting the respective element resp. element end by a mouse click in the graphics, 
the Change of element length has to be defined. There are three selection fields available 
which allow for the specification of the absolute or relative new length of the element. 
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10.2.8 Set Parallel Elements 
With this function, parallel elements can be set. It is called up via menu 

Edit → Set parallel elements. 

The following dialog box is opened. 

 
Figure 10.26: Dialog box Create Parallel Elements 

Define the Number of copies and the Spacing d which represents the distances between the 
parallel elements. They are related to the center lines of the elements. 

The Side refers to the element orientation, i.e. the order of the start and end nodes of the 
element that is to be copied. The parallel elements are then created by a mouse click on the 
specific element. 

Parallel elements can also be quickly created via Drag & Drop of selected elements, while 
the [Ctrl] key is kept pressed. 

10.2.9 Create Rectangular Hollow Section 
With this tool, user-definable rectangular hollow sections with or without rounded corners 
can be generated. The dialog box which allows for the parametrized input is accessible via 
menu 

Insert → Sections → Graphics → RHS 

or the corresponding button in the toolbar. The following dialog box appears. 

 
Figure 10.27: Dialog Set rectangular hollow section 

The numbers of the generated elements are shown in the Element section of this dialog box 
where it is also possible to control the number of the first element. The Material can be 
selected from the list. 
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Set the Corners by entering the coordinates of the two nodes that represent the diagonal of 
the hollow section. These can be related to the Absolute zero point (y0 / z0) or to the user-
defined Grid origin (y / z). The nodes can also be set graphically. After having chosen the 
first corner, the dotted outline of the new section can be moved with the mouse pointer. 
The second corner is then anchored by another click. The Snap on option makes positioning 
on a grid point easier. 

If the corner nodes are not defined graphically, the RHS parameters can be set by entering 
the Width b and Depth h of the section which refer to the outer contour of the section. The 
Thickness t has to be defined manually in any case, however. 

If the section is to be created with Rounded corners, the Radius r of the arc can be defined. 
In this case, it is not possible to Adjust corners as this option is applicable only for right-
angled corners for which smoothened corners can be created (cf chapter 10.2.2, page 175). 

10.2.10 Create Circular Hollow Section 
With this tool, user-definable circular hollow sections can be generated. The dialog box 
which allows for the parametrized input of pipes is accessible via menu  

Insert → Sections → Graphics → CHS 

or the corresponding button in the toolbar. The following dialog box is opened. 

 
Figure 10.28: Dialog box Create circular hollow section 

In this dialog box, it is possible to modify the number of the first generated Element and to 
select the adequate Material from the list. 

Determine the Center point by entering its coordinates y0 and z0 or by clicking on this point 
in the graphics. The Snap on option facilitates the graphical selection of a grid point. 

The Radius r refers to the outer diameter of the circular section. If it is selected graphically 
with the mouse by pulling up a circle, the projected pipe is interactively drawn by dotted 
lines. The Number of divisions controls the number of arc elements that are to be created. 

When the Thickness t has been entered, the CHS can be set with [OK] or by a mouse click 
that defines the radius. 
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10.3 Table Functions 
10.3.1 Editing Functions 
Editing functions facilitate the tabular input. Contrary to the block operations (cf chapter 
10.3.2), it is not necessary to previously select several cells. Editing functions only have an 
effect on the current cell in which the cursor is positioned. 

Call up the Editing Functions 
The cursor must have been placed in the table. All editing functions are available via menu 

Tables → Edit. 

Some editing functions are also accessible in the toolbar of the table. 

 
Figure 10.29: Buttons for some Editing Functions in the toolbar of the tables 

Alternatively, these functions can be called up via the table context menu (cf Figure 10.30, 
page 182). 

Functions and Commands 

Function Effect 

Cut [Ctrl+X] Removes the contents of the cell and saves it to the clipboard. 

Copy [Ctrl+C] Copies the contents of the cell to the clipboard. 

Paste [Ctrl+V] Inserts the contents of the clipboard. 

If the clipboard contents are bigger than a cell, the cells of the fol-
lowing columns and lines will be overwritten. Before this, a warning 
appears. 

Copy Row [Ctrl+2] Overwrites the following line with the contents of the current line. 

Empty Row [Ctrl+Y] 

 

Deletes the contents of the line without deleting the line itself. 

Insert Row [Ctrl+I] 

 

Inserts a new, empty line and moves all subsequent lines down-
wards. 

Delete Row [Ctrl+R] 

 

Deletes the entire line and moves all subsequent rows upwards. 

Find [Ctrl+F] Searches a number or string within the table. 

Replace [Ctrl+H] Searches a number or string within the table and replaces it. 

Pick [F7] Opens a list within a cell. 

Table 10.1: Editing functions 
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Examples 
Copy Row 
The function is called up via the context menu of row 6. 

 
Figure 10.30: Copy row 6 via the context menu 

Row 7 will be overwritten. 

 
Figure 10.31: Result 

Insert Row 
The function is called up via the context menu of row 3. 

 
Figure 10.32: Inserting row via context menu 

A new, empty row will be inserted. All subsequent rows are moved downwards. 

 
Figure 10.33: Result 
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10.3.2 Block Functions 
Specific tools assist with the tabular input. Before the following operations can be carried 
out, it is necessary to mark several connected cells as a block, i.e. selection. 

 
Figure 10.34: Selected block of several cells in the table 

It does not matter if the cells are with or without contents. A block operation modifies the 
contents of the selected cells uniformly. 

Call up the Block Functions 
A block must have been selected in the table. This can be done by pulling the mouse across 
several cells with left button kept pressed. Clicking on a table header (A, B, C etc.) selects 
the entire column, clicking on a row number selects this row. 

All selection functions are available via menu 

Tables → Block. 

Some block functions are also accessible in the toolbar of the table. 

 
Figure 10.35: Buttons for Block Functions in the toolbar of the table 

Alternatively, these functions can be called up via the context menu within the table. 

 
Figure 10.36: Block Functions in the context menu 
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Functions 

Function Effect 

Deselect [Ctrl+U] Cancels the selection of the rows or columns 

Cut [Ctrl+X] Removes the selection and saves it to the clipboard 

Copy [Ctrl+C] Copies the contents of the selection to the clipboard 

Paste [Ctrl+V] Inserts the contents of the clipboard 

This function is only available for suitable clipboard data, 
e.g. from MS Excel. 

Delete [Ctrl+Del] 

 

Deletes the contents of the selected cells 

Add 

 

Adds a value to those cells that contain numerical values 

Multiply 

 

Multiplies cells that contain numerical values by a factor 

Divide 

 

Divides cells that contain numerical values by a factor 

Set Assigns the value of the topmost selected cell to the entire selection 

Generate [Ctrl+G] Interpolates numerical values between first and last selected cell 

Save Saves the selection as a file 

Import Reads a selection which has been saved as a file 

Table 10.2: Block functions 

Examples 
Add 
Several cells with numerical values have been selected. 

 
Figure 10.37: Block context menu 
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The Value which has to be added can be entered in a dialog box. 

 
Figure 10.38: Dialog box Edit Operation - Addition 

 
Figure 10.39: Result 

All numerical values within this selection have been reduced by 50. Empty cells are still 
empty. 

Generate 
With this function, it is possible to quickly fill cells. The numerical values are linearly interpo-
lated from the start value of the top cell (e.g. 5.00) and the end value of the bottom cell 
(e.g. 350.00). 

 
Figure 10.40: Block context menu  

All selected cells will be filled with the intermediate values. 

 
Figure 10.41: Result 
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10.3.3 Viewing Functions 
By means of the viewing functions, the number of cells that are displayed can be reduced. 
Thus, the clarity within the tables is improved. 

Call up the Viewing Functions 
All viewing functions are available via menu 

Tables → View. 

Some viewing functions are also accessible in the toolbar of the table. 

 
Figure 10.42: Buttons for Viewing Functions in the toolbar of the tables 

Functions 

Function Effect 

Used Rows Only 

 

Hides all empty rows. 

Marked Rows Only 

 

Shows only selected rows. 

Selected Objects Only 

 

Shows only objects that are selected in the graphics. 

Title Bar Switches the title bar on and off. 

Toolbar Switches the toolbar on and off. 

Column Header Switches the column bar (A, B, C, ...) on and off. 

Status Bar Switches the status bar of the table on and off. 

Table 10.3: Viewing Functions 

Example: Used Rows Only 
A table contains several empty rows, which might be distracting. 

 
Figure 10.43: Table with empty rows 
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The function Used Rows Only hides all empty rows. 

 
Figure 10.44: Table without empty rows 

10.3.4 Table Settings 
The fonts and colors of the tables can be adjusted. Furthermore, the selection of the 
graphics can be synchronized with the tabular selection. 

Call up the Table Settings 
All table settings are available via menu 

Tables → Settings. 

Some settings are also accessible in the toolbar of the table. 

 
Figure 10.45: Buttons Synchronization of the Selection 

Functions 

Function Effect 

Colors Calls up the Colors dialog box in which the color settings 
can be adjusted for all elements of the table individually 

Fonts Calls up the Fonts dialog box in which the font, font style 
and size can be changed for the tables 

Select Object in Graphics 

 

If this option is active (default), the objects of the current 
cell(s) are selected in the graphics. 

Show Selected Objects in Tables 

 

If this option is active (default), the selected objects of 
the graphics are highlighted in the table, too. 

Table 10.4: Table Settings 
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10.3.5 Filter Functions 
The filter options in the tables of the section characteristics and stresses allow for a user-
definable layout of those results tables. 

The result filters are accessible via menu 

Tables → View → Columns filter 

or the extra button in the toolbar of the table. 

 
Figure 10.46: Button Filter results in the toolbar table 3.1 Normal stresses 

The following dialog box opens in which the results that are to be displayed can be select-
ed. 

 
Figure 10.47: Dialog box Show Columns 

10.3.6 Import and Export Tables 
An Excel table can be imported directly into the current input table of SHAPE. MS Excel 
must have been started before these functions can be carried out. Vice versa, it is possible 
to export the current SHAPE table to Excel. 

Call up the Import and Export Function 
The function is started by clicking on the [Excel] button in the toolbar of the tables. 

 
Figure 10.48: Button Import/Export to MS Excel in the table toolbar 

 
Figure 10.49: Dialog box Import from MS Excel 
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Figure 10.50: Dialog box Export to MS Excel 

Depending on the Action Type settings of the dialog box, the import resp. the export op-
tions can be defined in detail. 

Import Tables 
Excel must have been opened before the import. In case of worksheets with headers, the 
check box Table has Header is to be activated. Then the header lines are ignored and only 
the selected list is imported in the SHAPE tables. 

In section Transfer Parameters, the import of the active workbook or worksheet can be se-
lected. When importing a complete workbook, the order and structure of the worksheets 
must completely correspond with the SHAPE tables. 

The import is started with [OK]. 

If only parts of the worksheet are to be imported, the copying function is advisable: Mark 
the area in the Excel table and copy it to the clipboard with [Ctrl]+[C]. Then place the cur-
sor in the adequate cell of the SHAPE table and insert the contents with [Ctrl]+[V]. 

Export Tables 
Excel does not need to run in the background before exporting SHAPE tables. In the dialog 
section Table Parameters, the export with or without header can be defined. If the check 
box is active, the result in Excel will be the following: 

 
Figure 10.51: Excel table with exported header 

If the check box is inactive, then only the table contents are imported in Excel as shown in 
the following image. 
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Figure 10.52: Excel table without header 

The check box Only Selected Rows is available if a block was selected in the table. It controls 
whether only this block or the complete table is to be exported. 

The Transfer Parameters control whether the active workbook is to be used. If this check 
box is deactivated, a new workbook will be created. The same applies to the option Export 
table to active Excel Worksheet. If the check box is activated, the current worksheet is used, 
with the option to overwrite it. 

If Rewrite Existing Worksheet in Excel is enabled, a table with the same name as in SHAPE is 
searched for and then overwritten. 

[OK] starts the export of the current SHAPE table. 
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10.4 General Functions 
This chapter describes some program functions which are of general importance and which 
are accessible in many dialog boxes. 

10.4.1 Display Objects 
The display settings determine which graphical objects are shown. The viewing options that 
are described in the following chapter, however, control how the objects are displayed. 

The dialog box to define the display parameters for the objects is called up via menu 

View → Display 

or the corresponding button in the toolbar. This option is also included in the context menu 
which can be activated by right-mouse clicking in the ‘empty’ work area. 

 
Figure 10.53: SHAPE context menu  

The following dialog box appears. 

 
Figure 10.54: Dialog box Display, category Section properties 

For every Category, many different items can be selected among the Subcategories that are 
to be displayed. The Details that can additionally be set depend on the selected item. 

If several windows are being used in SHAPE, the reference of the modified settings can be 
specified in dialog section Apply to. 
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10.4.2 Viewing Options 
The viewing options control how graphical objects are displayed. By contrast, the display 
settings that are described in the previous chapter determine whether an object is shown 
or hidden in the graphics. 

The dialog box in which you can customize the viewing options is called up via menu 

Options → Viewing options 

or the general context menu which can be activated by right-mouse clicking in the ‘empty’ 
work area (cf Figure 10.53, page 191). 

The following dialog box appears. 

 
Figure 10.55: Dialog box Settings, Colors tab 

This dialog box consists of several tabs which allow for a detailed allocation of colors, line 
types, fonts, sizes etc. of the various items. An interactive Sample is shown in each tab. 

In general, the graphical object is selected from the Category list. Then its parameters can 
be defined for the display. The following figure illustrates all options for the elements. 

 
Figure 10.56: Dialog box Settings, Elements tab 
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The Program tab allows for program-specific settings. Among others, the language of the 
SHAPE user interface can be selected: 

• English 

• German 

• Czech 

It is possible to save user-defined viewing options via menu 

Options → Save as. 

The Windows dialog box Save as is called up where the location and the file name of the 
new configuration file (*.cfg) can be defined. 

Vice versa, configuration files with user-defined settings can be imported via menu 

Options → Load. 

10.4.3 Units and Decimal Places 
Units and decimal places are managed in a separate dialog box. 

In the General Data dialog box, the units and decimal places can be directly accessed via the 
respective button. Alternatively, apply menu 

Options → Units 

to call up the following dialog box. 

 
Figure 10.57: Dialog box Units and Decimal Places 

The settings for the units and decimal places can be changed when working on a section. 
All numerical values are converted or adjusted. 

All settings can be made in detail for the Geometry of the section, the Material properties, 
the Forces and moments and for the Results. 

Via the [Save as default] button, the modified settings can be set as standard for new 
sections. 
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10.4.4 Dimensions 
Apart from the automatically created dimensioning of the section, user-defined dimension 
lines can be added. The dimensions may refer to nodes, auxiliary points or some results data 
(e.g. centroid C, shear center M). 

The function to set dimension lines is called up via menu 

Insert → Dimensions 

or the corresponding button in the toolbar. 

 
Figure 10.58: Button Set dimensions 

The Dimensions dialog box appears. 

 
Figure 10.59: Dialog box Dimensions 

Click the two objects (nodes, auxiliary points etc.) that represent the reference nodes of the 
new dimension line. Either the true length or the projection in the direction of one of the 
global axes can be selected as Reference. 

The offset of the dimension line from the first selected object is determined by moving the 
mouse pointer in the graphics. The dimension line is finally set by a mouse click. 

The display of the dimension lines is controlled in the Display dialog box or the general 
context menu in the work window. 

 
Figure 10.60: Dialog box Display: Category Dimensions 

The dimension lines will be adjusted automatically when changes in the sectional geometry 
occur. 

If you want to modify the offset of a dimension line or refer it to different objects, you have 
to delete the dimension line and define it again. 
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10.4.5 Comments 
Two different types of comments are available: Texts can be inserted both in the graphics 
and in the comment boxes of the dialog boxes and tables (as seen e.g. in Figure 5.4 on 
page 66). This chapter deals with the comments in the graphical user interface. 

Comments can be arranged for nodes, auxiliary points, elements and point elements via the 
snap function or can be placed arbitrarily in the current work plane. 

The comment function can be called up via menu 

Insert → Comment 

 or the corresponding button in the toolbar. 

 
Figure 10.61: Button Create comments 

The dialog box Comment Text appears. 

 
Figure 10.62: Dialog box Comment text 

The Comment is entered in the respective input field. Color, [Font] and font size of the text 
can be specified in detail. Optionally, a Frame can be set around the comment. 

If the check box With offset is activated, the comment will be arranged at a certain distance 
of the selected object. This distance can also be defined graphically: Click the relevant ob-
ject first and then define the distance of the comment by a second click. 

The display of the comments is controlled in the Display dialog box (cf Figure 10.60, page 
194) or the general context menu which can be called up by a right-mouse click into an 
‘empty’ area of the work window. 

A comment can be edited at a later time by double-clicking it. If the offset is to be modi-
fied, a redefinition will be necessary. 
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10.4.6 Measure Function 
Distances and angles can be measured in order to check the data. This function can be 
activated in the Extras menu. 

There are three options available to measure the 

• Distance between two objects (nodes, auxiliary points, centroid, shear center), 

• Angle between three nodes, 

• Angle between two elements. 

Click the relevant objects one after another. The detailed result will be shown. 

 
Figure 10.63: Information on Distance 

10.4.7 Find Objects 
The tables can be used when certain objects are searched for. If the cursor is positioned in a 
table line, the corresponding object will be highlighted in the graphics. It is important that 
the synchronization of the selection has been activated (see chapter 10.3.4, page 187). With 
this method, objects can be easily located in the graphics. 

SHAPE also has an extra search function which is called up via menu 

Extras → Find. 

The following dialog box appears. 

 
Figure 10.64: Dialog box Find 

The Find list controls whether a node, section, element or point element is to be searched 
for. Its Number can be entered in the input field next to it. 

After [OK], the sought-after object will be marked by an arrow in the graphics. 
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11. Interfaces 
It is possible to exchange data between SHAPE and other programs. This allows for the use 
of templates that have been created in CAD applications. Moreover, the results data of 
SHAPE can be made available for add-on design software. 

The sectional data of previous versions of SHAPE can also be accessed. You can import the 
input data from the DOS versions SHAPE 1.xx/2.xx or directly open SHAPE 5.xx/6.xx files in 
order to calculate the effective widths, for example. 

There are interfaces to other programs of the DLUBAL family. On the one hand, the internal 
forces of members can be imported from RSTAB or RFEM. This is described in chapter 5.7 
on page 88. On the other hand, the characteristics of user-defined SHAPE sections are avail-
able in RSTAB or RFEM and can be allocated to members. Several add-on modules allow for 
the design of SHAPE members, too. 

For details on how to export print data as RTF file, see chapter 9.1.10 on page 159. 

Moreover, SHAPE can be run externally via a programmable interface based on COM tech-
nology (e.g. Visual Basic). The additional module DU-COM (not contained in SHAPE) allows 
for user-defined input macros and follow-up programs. 

The data import is started via menu 

File → Import. 

The common Windows Open dialog box appears. 

 
Figure 11.1: Dialog box Import 

SHAPE files can be exported via menu 

File → Export. 

The common Windows Save As dialog box is opened. 

 
Figure 11.2: Dialog box Export 
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11.1 DLUBAL ASCII Files *.inp / *.aus 
SHAPE 5/6 and SHAPE 7 can be installed parallel (cf chapter 2.2.4, page 10). If projects have 
been created in the Project Manager of SHAPE 5/6, they are automatically shown with the 
contained sections in the Project Manager of SHAPE 7. 

Import 
SHAPE 1/2 files in the DOS format *.inp can be imported via menu 

File → Import. 

The dialog box shown in Figure 11.1 opens in which the folder and the file name of the 
DOS section can be selected. The Files of type DUENQ1 files inp (*.inp) are preset. 

After [Open], the dialog box New Cross-Section - General Data appears with the Section 
name of the DOS file. This section will be automatically integrated in the current project, 
which can be changed via the Project list. 

If several DOS files are to be imported, it is recommended to connect the entire project via 
the Project Manager. Details on this feature can be found in chapter 4.4.1.1 on page 48. 

Export 
SHAPE 7 files can be exported to the ASCII format *.inp and *.aus via menu 

File → Export. 

The dialog box shown in Figure 11.2 opens in which the folder and the file name of the 
ASCII data can be selected. Among the Files of type list, three control options are available: 

• Input data *.inp creates an ASCII file with the input data only. 

• Results *.aus creates an ASCII file with the results data only. 

• All files *.* creates two ASCII files that contain the input and results data each. 

Alternatively, the SHAPE tables can be exported to an MS Excel file *.xls. For details on 
this function, see chapter 10.3.6 on page 189. 

11.2 ASCII Files *.dxf 
Via the DXF interface, templates of sections can be imported that have been created in CAD 
applications. The DXF format transfers the general information on the lines of a section. 

It is advisable to use a ‘cleaned-up’ DXF file for the import. If necessary, delete e.g. dimen-
sion lines or comments in the DXF file as those are irrelevant for SHAPE. To avoid problems, 
complex objects should also be dismantled (via Explode in AutoCAD, for example).  

Files in the format *.dxf can be imported via menu 

File → Import. 

This calls up the dialog box shown in Figure 11.1 where the Files of type ASCII DXF files 
(*.dxf) can be selected. Before the actual import, a new section has to be defined in SHAPE. 

If the DXF template is to be applied for the current SHAPE section, however, it can be im-
ported via menu 

File → Load DXF template  or 

Extras → Load DXF template. 

The Windows Open dialog box appears in which the folder and the name of the *.dxf file 
can be selected. After [OK], the Import DXF template dialog box is called up. 
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Figure 11.3: Dialog box Import DXF template 

In the dialog section Create SHAPE model, there are three options available: 

• Create elements automatically converts parallel lines of the DXF model to elements. 

• Assign element thickness to center lines applies a uniform thickness to all lines. 

• Create DXF template for further editing only generates a layer. 

Detailed settings control the conversion of the DXF template. Apart from the Length unit, 
the Maximum occurring thickness is decisive for the automatic detection of parallel ele-
ments. If the allowance is too large, defective elements may be created. 

For the template, a convenient angle of Rotation β can be defined. If there are several layers 
in the template, the relevant Layer is to be selected from the list.  

It is possible to Position the DXF template on a node, auxiliary or grid point or on a user-
defined point by entering its coordinates y0 and z0. 

The location of the Offset point can be defined in the template coordinate system yp and zp 
or simply picked in the image of the template. 

The [Remove lines] button calls up an extra dialog box in which irrelevant lines of the tem-
plate can be deleted by left mouse clicks. 

After [OK], SHAPE tries to automatically convert as many elements as possible. Center lines 
are created from parallel lines, and nodes of elements are created at their intersections. If 
not all lines can be converted to elements, a message appears that the DXF template has 
not been correctly defined. This means that some reworking of the section is required. 

If the option Activate element setting has been enabled in the Import DXF template dialog 
box, the following dialog box is called up after the conversion. 
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Figure 11.4: Dialog box Create elements from DXF contour 

Set center lines allows for manually defining center lines by selecting the two parallel DXF 
lines one after another. 

If there is no intersection between center lines, it is possible to Extend one (or both) lines by 
a percentaged value. This can be done by clicking on the side of the line – repeatedly, if 
necessary – until the intersection has been reached. 

To Set elements on the center lines between two intersection nodes, simply click the rele-
vant center lines. 

The option Connect nodes inserts a new element with an intermediate thickness between 
two nodes that have been created with their elements. 

The [Automatic generation] is the default setting when importing DXF files. Via this button, 
the elements can be created once again after having reworked the center lines. 

Please note that sectional models with irregular contours may be problematic. Parallel lines 
or arcs in the DXF file are prerequisite for a successful conversion into SHAPE elements. 

It is possible to subsequently create elements from an imported DXF template via menu 

Extras → Set elements from DXF template. 

The dialog box as seen in Figure 11.4 is called up. 
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